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Overview

Keyboard Maestro will take your Macintosh experience to a new level. Keyboard Maestro enables you to create or record
custom macro shortcuts that you can activate at any time. For example, your macros could help you navigate running
applications or work with an unlimited number of clipboards. Best of all, every macro you create is available using simple
keystrokes you choose or a variety of other triggers. The only limit to Keyboard Maestro is your imagination!

Using Keyboard Maestro’s powerful Macros, you can make your Mac behave the way you want it to behave — open documents

when and where you want them, type sentences with the press of a key, expand abbreviations into entire paragraphs, control
web applications, and much more. You simply define what you want your Mac to do and when you want it done.

Keyboard Maestro comes complete with a clipboard history, saving everything you copy for later use so you’ll never lose

something on your clipboard again, as well as named clipboards where you can store commonly used images or text.

Keyboard Maestro also includes a powerful Application Switcher and Window Switcher so you can cycle through applications

or windows, closing, hiding, launching, and more as well as an Application Launcher that lets you quickly launch applications.

Keyboard Maestro is free to try with no limitations. Once the trial period ends, a license must be purchased to continue using
it.

What’s New?

Keyboard Maestro 9 expands on the powerful base of previous versions, adding Dark Mode, multiple editor windows, and

Capitan or later.
Major Changes

¢ Support multiple editor windows.

¢ Support Dark Mode (requires 10.14+).
e Added JSON support.

¢ Added OCR support.

¢ Added extended Regex support.

¢ Added support for Stream Deck.

¢ Hardened Runtime. Notarized.

Dark Mode

 Support Dark Mode (requites 10.14+).

¢ Added Dark Mode preference (System, Light or Dark) (requires 10.14+).

* Added Set/Toggle System Dark Mode actions (requires 10.14+).

e Added Set/Toggle Keyboard Maestro Dark Mode actions (tequites 10.14+).
Added DARKMODE and KMDARKMODE functions (requires 10.14+).

JSON

¢ Added Set JSON Value action.
¢ Added Set Variables to JSON action.
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Added Set Dictionary to JSON action.

Added %JSONValue%VarName[2+3].field. {%FieldName%} % token (and Pretty and Strict variants).
Added %]SONFromVatriables%Prefix% token (and Pretty and Strict variants).

Added %JSONFromDictionary%Dictionary%o token (and Pretty and Strict variants).

Added JSONVALUE(VarName[2+3] field. {%Variable%FieldName%}) function.

Added JSON Keys collection.

Added context sensitive COUNT() function within JSON array accesses.

Added filter to JSON Compact and JSON Pretty.

Stream Deck

Added Stream Deck Plug In.

Added Stream Deck Plug In to USB Device Key trigger.
Added Stream Deck Set Title action.

Added Stream Deck Set Image action.

Added Stream Deck Show OK action.

Added Stream Deck Show Alert action.

Extended Regex

Support \U, \u, \L, \l and \E in token fields including Search & Replace fields.
Support named capture groups (${name}) in regular expression replacement fields (10.13+).

Editor

Support multiple editor windows.

Support for Increased Contrast.

Support contextual menu in Macros column.

Support contextual menu in Macro Groups column.

In the Insert Action/Token/Function by Name windows, Option-Double Click, and Option-Return open the wiki help.
(forum [https://forum.keyboardmaestro.com/t/is-there-any-action-that-can-run-an-url-like-this /13071/6)])

Dragging a folder in to a macro now creates an Open Folder action.
Dragging a workflow into a macro now creates an Execute an Automator Workflow action.

Use VarName as the default variable name in more places.

Changed “Import Macros Disabled...” menu name to “Import Macros Safely...” to avoid confusion.

Added a Sort Disabled Macros to Bottom option.

Select from Recently Executed now focuses on Macros Column/Macro in non-Edit mode.

Added macros to Spotlight index (requires 10.13+). (forum [https://forum.keyboardmaestro.com/t/how-can-i-include-km-

macros-in-my-macos-spotlight-searches/9805)])

Adjust macro name / trigger column resizing to allow for longer trigger names.

Better display of invalid calculations in the editor. (forum [https://forum keyboardmaestro.com/t/request-change-behavior-of-
km-editor-display-of-invalid-actions/11237)])

No display of calculation errors in the editor if the issue is only that a Local or Instance variable has no value. (forum

[https://forum.keyboardmaestro.com/t/request-change-behavior-of-km-editor-display-of-invalid-actions/11237)])

Large Text setting now affects resizable text views in actions.

Added hidden preferences to allow setting the font/size of text views in actions, including fixed width sctipt fonts.
Added Toolbar labels to enhance accessibility. (mjtsai [https://mijtsai.com/blog/2019/05/22/mac-toolbat-labels-and-
accessibility/])

Enhanced the Interactive Help with further support for when a macro is triggered but not doing what you want.

Added detection of Mojave accessibility setting bugs to the Interactive Help system (sigh).

Engine

Added Display Layout Changed trigger.
Added Iconaholic Rotate status menu icon.
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¢ Added default Clipboard Filters group.

¢ Support sorting the Applications Palette by launch date. (Quinn)

» Preserve DPI of images in image actions. (forum [https://forum.keyboardmaestro.com/t/problems-with-km-image-tools-retina-
screens/6860)])

¢ Add “real-time” recording mode. (forum [https://forum keyboardmaestro.com/t/realtime-recording-and-playback-of-keys-and-
mouse/12355)])

¢ Avoid copying as PDF in Microsoft apps (Microsoft apps are still slow on first copy while starting the RTF engine).

* Avoid copying many different image formats on the clipboard, only save TIFF and PNG formats.

* Support “Place Under Mouse” in Clipboard History Switcher.

¢ Large Text setting now affects Quick Look and Display Text in Window plain text size.

 Support button keys with or without command keys in Prompt For User Input windows with no text fields. (forum

[https://forum keyboardmaestro.com/t//9935)])

¢ Added JavaScript in Front Browser script condition. (forum [https://forum.keyboardmaestro.com/t//9912)])

e Treat clipboard entries with file references to images as images.
* Add Large Text Display period to the Set Action Delay action settings.
¢ Support the AppleScript “windows” property returning all the panel windows in the Engine. (forum

[https://forum.keyboardmaestro.com/t/ clipboard-history-switcher-window-remember-placement-or-move-via-macro-script/8110)])

* Triggering a macro will not necessarily cancel a conflict palette or “for once” palette. This may change in the future.
Themes

¢ Added Dark Mode palette theme.
¢ Added Mojave Night palette theme. (forum [https://forum.keyboardmaestro.com/t/custom-palette-style-colors/3516/12)])

¢ Added Blue Lagoon palette theme.

¢ Added Blue Night palette theme.

¢ Added Purple Dream palette theme.

¢ Added Orange Light palette theme.

¢ Added enhanced custom palette theme with gradient options. (forum [https://forum.keyboardmaestro.com/t/custom-palette-
style-colors/3516/6)])

¢ Added an option to center or not center the text in palette themes. (forum [https://forum.keyboardmaestro.com/t/custom-
palette-style-colors/3516/14)])

Clipboard Switcher

e If multiple items are selected in the Clipboard Switcher, Command-C merges them into the system clipboard.

e If multiple items are selected in the Clipboard Switcher, Command-V merges and then pastes them.

* If multiple images are selected, merging them creates a single larger image (horizontally or vertically, depending on the
separator).

¢ Added a contextual menu to select the Multiple Clipboard Separator.

e If a single item is selected in the Clipboard History Switcher, command-C sets the system clipboard to it.

Actions

¢ Added OCR (Optical Character Recognition) action for screen and images.

¢ Added OCR condition for screen and images.

¢ Added Set Desktop Image action.

¢ Add Cancel a Specific Macro action.

» Added Append/Prepend to Variable actions.

¢ Added Set Clipboard to Image action.

¢ Added Set Clipboatd to File Reference action.

¢ Added Append Text to Variable option for various outputs (eg Execute Script output).
* Added Show/Hide/Toggle Applications Palette action.

¢ Updated Open 1Password action to work with 1Password 7.3+.

¢ Added Display Name option to Filter and Get File Attribute.
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¢ Added modifiers to Simulate the Hardware Key action.

* Added Small Increase/Dectease System Sound Volume actions.

e Added Small Increase/Dectease System Brightness actions.

¢ Add clipboard and file options to Find Image action.

¢ Add clipboard and file options to Click at Found Image action.

¢ Add clipboard and file options to Found Images collection and condition.

¢ Added bottom to top and right to left options for Found Images collection.

¢ Added image selection (eg “rightmost”) options to Find Image action.

¢ Added non-unique image selection (eg “rightmost”) options to Click at Found Image action.
¢ Added %ApplicationPath%1% token.

e Added “All”, “Foreground”, “Background” options to Application tokens.

e Added “All” option to Window and Screen tokens.

¢ Added %Executinglnstance% token representing the current execution instance.

¢ Added %Executinglnstances%o listing the current execution instances.

¢ Added %ExecutinglnstanceName%instance% giving the name of a specific instance.

¢ Added %FrontBrowser%, %FrontBrowserBundleID% and %FrontBrowserPath% tokens.
¢ Added HEX, OCT, and BIN functions.

e Added DIV operator.

¢ Support two-parameter variants of RANDOM and RAND functions. (forum

[https:/ /forum. keyboardmaestro.com/t/random-negative-numbers/12561)])
* Support SCREENVISIBLE(VarName,...) when VarName is “Back”, etc (forum
[https:/ / forum keyboardmaestro.com/t/ vatiables-in-move-and-resize-front-window/1560)])
 Support “Index” as a coordinate to the SCREEN and SCREENVISIBLE function.
* Support Smart Groups in Trigger Macro By Name action.

¢ Support Smart Groups in Show Palette of Macros action.

¢ Added an option to select the units for the Pause action.

¢ Added screen selection menu options for second, third, external, internal, etc in various actions.

¢ Added an option to not sort entires in the Prompt With List action. (forum [https://forum.keyboardmaestro.com/t/feature-

request-sorting-options-in-prompt-with-list-action/8579)])

¢ Added an option to set the title of the Prompt For File action. (forum [https://forum.keyboardmaestro.com/t/feature-request-
add-titles-to-all-km8-prompts/8423)])
¢ Added an option to set the initial directory of the Prompt For File action. (forum

¢ Support token processing options in the various web browser actions.
o Tokens that start with %Local or %Instance but that do not match an existing local/instance variable are assume to be
empty variables. (forum [https://forum.keyboardmaestro.com/t/using-local-variable-token-without-the-variable-prefix /10893 /7)])

Speed

¢ Improved launch speed, especially with multiple editor windows.

¢ Improved speed displaying the All Macros group with large numbers of macros.

¢ Improved Clipboard History display speed and memory usage with lots of large images.
* Improved Clipboatd History save/load speed with lots of latge images.

* Improved Named Clipboatd save/load speed with lots of large images.

Minor

¢ Added “load” and “save” as search synonyms for Read File and Write File actions.

¢ Added “create” and “directory” as search synonyms for New Folder action.

¢ Added “annotate” as search synonyms for Composite onto Image action.

¢ Added “dialog” and “window” as search synonyms for Alert and Prompt for User Input actions.
¢ Added “Insert Styled Text by Pasting” to action insertion lists.
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Added options to match applications based on just Bundle ID (rather than Path & Bundle ID).
Expanded hex character tokens to include emoji (eg %01F300%0).

Adjusted Search the Web action to token expand the Title field. (forum [https://forum.keyboardmaestro.com/t/search-the-

web-action-macro-name-as-background-text/13272])

Default shell environment to UTF-8 if not explicitly set.

Changed Application Trigger to set TriggerValue to the path of the application. (may break macros)
Include Smart Groups in macro selector popup menu.

Trigger Macro by Name initial search now processes tokens.

Adjusted Comment action to enable automatic link detection.

Adjusted Insert Styled text and Display Styled Text action to enable automatic link detection.
Adjusted the palette displays slightly, de-bolded the content text and added some space. (forum

[https:/ /forum.keyboardmaestro.com/t/ui-palette-suggestion/13942])

Disabled Smart Copy/ Paste in most text fields. (forum [https://forum.keyboardmaestro.com/t/wish-list-ot-alternative-solution-

insert-url-in-comment-action/13281])
Attempt to better support control over Smart Quote/Dash/Link Substitution/Detection.
Detect AppleScript errors and abort/fail the Execute AppleScript action. (may break macros)

Detect Shell script etrors and abort/fail the Execute Shell Sctipt action. (may break macros)
Detect Plug In script errors and abort/fail the Plug In action. (may break macros)(forum

[https:/ /forum.keyboardmaestro.com/t/how-do-i-abort-mactro-if-plugin-script-gets-error/10558])

Avoid New Folder action failing in the case where the folder already exists.

Improve error display of text script errors (remove long extraneous temporary path).
Hidden Windows show slightly dimmed text in the Window Switcher.

Handle kmtrigger: URLs with bogus slash (/) at the end added by Word.

Worked around Google Chrome’s stupid window title accessibility issue. (forum

[https:/ /forum.keyboardmaestro.com/t/found-images-suddenly-broken-in-google-chrome/11510])

Worked around Safari 12.1 not disabling the Stop menu when the page is finished loading (radar 49309868).

Worked around an issue with dates and times not being localized in Mojave. (CFBundleAllowMixedLocalizations)
Support Brave and Vivaldi browsers as a Chrome-compatible Front Browser. (forum

[https:/ /forum keyboardmaestro.com/t/using-a-non-safari-non-chrome-browser/13712])

Rate-limit Named Clipboard Change notifications.

Rate-limit Allow JavaScript from Apple Events notifications.

Improved Search Using Regular Expressions to indicate invalid variables in red. (forum

[https:/ /forum keyboardmaestro.com/t/bug-variables-illegal-characters-without-warning-via-search-using-regex-action/11003])

Invalid variables that are entered in various fields and show up red will not be saved.
Improve error display of calculation errors. (forum [https://forum keyboardmaestro.com/t/is-there-any-name-of-action-to-

tepeat-some-macro-till-last-tab-of-the-window/13798 /4])

Added primary trigger to Macro Inspector / Trigger Macro by Name windows.
Adjusted the Continue/Retry Loop action icon to a Control Flow icon instead of a Stop icon.
Adjusted the Share to Forum default name to be less verbose. (forum [https://forum.keyboardmaestro.com/t/change-request-

macro-upload-name/7951])

Detect Universal Clipboards and display a network icon as the source.

Removed support for signatures in Send Mail Message as Mail.app’s signature support is broken.

Detect more Audio Output Device changes. (forum [https://forum.keyboardmaestro.com/t/macro-not-triggering-on-audio-
output-change/12651])

Fixes

Fixed Revett to interact propetly with Undo/Redo. (forum [https://forum keyboardmaestro.com/t/how-to-discard-undo-the-

revert-macros-action/13240)])

Fixed the title of the Set Action Delay action. (forum [https://forum.keyboardmaestro.com/t/set-action-delay-title-doesnt-
update-correctly/13344)])
Fixed a crash if the engine is launched via a .kmtrigger file.

Fixed the non-edit display of the Macro condition.
Fixed the non-edit display of the Modifiers condition.
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e Fixed the non-edit display of the Text condition.

e Fixed performance issue with Word Count filter. (forum [https://forum.keyboardmaestro.com/t/filtering-large-amounts-of-text-
in-the-clipboard/13575)])

e Fixed an issue where the “ends with” condition fails if the end string is also in the middle of the string, (forum

[https:/ /forum.keyboardmaestro.com/t/switch-ends-with-bug/13619)])

* Fixed an issue where macro groups that were inactive and then had their configuration changed would not necessarily
activate.

¢ Fixed an issue with Prompt With List action not showing as much as possible of long entries.

* Fixed an issue with gestures of a single diagonal direction being allowed.

e Fixed an issue with the character selection menu highlighting in the Icon Chooser Character display.

¢ Fixed an issue with highlighting display of truncated names in Window Switcher.

* Fixed an issue when running a macro from the editor immediately after making a change.

¢ Fixed an issue where Conflict Palettes could not use the key they were triggered with. (forum

[https:/ /forum.keyboardmaestro.com/t/how-to-double-tap-a-non-alphanumeric-conflict-palette-trigger /8089)])
e Fixed Command-V in the search field in the Clipboard Switcher.

e Fixed a crash in ThemedPaletteMatrixCell when the entry is tracking the mouse but the palette changes.
¢ Fixed an issue with the Prompt for File action not honouring the file types. (forum

[https:/ /forum.keyboardmaestro.com/t/prompt-for-file-allowed-types-not-working/13807)])

e Fixed an issue where the editor window would hide if you selected Help from a Insert By Name window. (forum

[https:/ /forum keyboardmaestro.com/t/is-there-any-action-that-can-run-an-url-like-this /13071 /6)])

* Fixed Icon Chooser sorting applications case sensitively.
* Fixed an issue with Enable/Disable macros resulting in a delay in operation of Typed String trigger. (forum

[https:/ /forum. keyboardmaestro.com/t/delay-after-enabling-macro /14060)])

* Fixed Break From Loop, Retry Loop, Continue Loop considering a Group to be a loop. (forum
[https:/ / forum keyboardmaestro.com/t/bug-group-treated-as-loop/11632)])

¢ Fixed an issue with Emoji character transparency in palettes. (forum [https://forum.keyboardmaestro.com/t/ transparency-

issue-with-palettes-and-emoji/13971)])

e Fixed Get Touch Bar to propetly handle Code__Title options. (forum [https://forum.keyboardmaestro.com/t/touch-bar-
prompt-values/13566)])

Download

Download Keyboard Maestro [https://www.stairways.com/action/linkthrurdownload] now to try all these great capabilities. Or

keep reading for even more details about the Features of Keyboard Maestro.

Alternatively, you can contact us [mailto:mailto:support@stairways.com] if you have a question about whether Keyboard Maestro

can solve your automation needs. We want all our customers to be satisfied, so we are happy to help you understand how
Keyboard Maestro can achieve your automation goals.

Features

Keyboard Maestro is a productivity enhancer with several main functions. It allows you to:

e record and design your own macro shortcuts and activate them at any time.
 work with clipboard history using Clipboard History Switcher.

¢ work with an unlimited number of saved clipboards using Named Clipboard Switcher.

* navigate through running applications with Application Switcher and open windows with Window Switcher.

Macro Groups allow you to organize your macros. Think of them as folders of macros. Each Macro Group controls when the

macros it contains are active. A Macro is made of two parts: a set of Triggers you choose to determine when the macro is
executed and a list of Actions that define what the macro does when it is executed.

By creating macros, you can customize your Mac to suit your use, streamline tedious tasks, and remove opportunities for
mistakes by automating repetitive jobs. Make stubbornly difficult applications behave the way you want them to; press a key
and have the computer do the next minute worth of tedious tasks for you; type a few characters and have a page full of
boilerplate text appear; and so much more. Soon you’ll wonder how you could have used your Mac without Keyboard Maestro.
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Here are some of the primary features of Keyboard Maestro.

General

¢ Use Dark Mode or Light Mode (10.14+).
* Sync your macros across multiple Macs using DropBox or other file sharing systems.

e Trigger macros by key, typed string, menu, by name, remotely, via MIDI, and more.

¢ Use the included Assistance system to help if you get stuck.

Macro Groups

¢ Create Macro Groups, which contain Macros and control when they are active.

¢ Macro Groups can be restricted to or excluded from specific applications.

¢ Macro Groups can be restricted to or excluded from specific windows.

e Macro Groups can be activated or deactivated with hot keys, or via the status menu or global macro palette.

¢ Macro Groups can display a themed palette of contained macros.

¢ Macro Groups can be enabled or disabled.

¢ Customize the Macro Group icon by pasting an icon, or using the Icon Chooser and creator.

e If you are syncing your macros, Macro Groups can be disabled on specific Macs.

Triggers

¢ Macros can be triggered by one or more Macro Triggers using any number of the following:

Hot Key trigger — when you press, hold, release or multi-tap a key.
Global Macro Palette trigger — with a click on a context sensitive Macro Palette.

Status Menu trigger — by selecting from a global system status menu.

Typed String trigger — type a string of keys.

Application trigger — on launch, quit, activate, deactivate, or periodically while an application is running or active.

Audio Output Changed trigger — whenever your audio output device changes.

Clipboard Changed trigger — when the system clipboard changes.

Clipboard Filter trigger — select macros from the clipboard switchers.

Cron trigger — periodically based on time or day or date.

Dragged File trigger — trigger when a file is dragged onto the macro in a palette icon.

Display Layout Changed trigger — trigger when the display layout changes.

Engine Launch trigger — when the Keyboard Maestro engine launches.

Focused Window trigger — when the front/focused window changes.

Folder trigger — when a file is added to or removed from a folder.

er — when you draw a pre-set shape with the mouse or trackpad.

Idle trigger — when your Mac has been idle for a period of time (but not yet asleep).

Login trigger — when you log in to your Mac.

Mounted Volume trigger — when a volume is mounted or unmounted.

Periodic trigger — periodically while logged in.

Public Web trigger — over the Internet, explicitly to the public, or via authenticated log in.

Remote trigger — when you access a link on our trigger server.
Sleep trigger — when the system goes to sleep.

Time of Day trigger — at a particular time of day.

USB Device Key trigger — when you press, hold, release or multi-tap any HID (Human Interface Device) device key.

USB Device trigger — when a USB device is attached or detached.

Wake trigger — when the system wakes from sleep.

Wireless Network trigger — when your Mac connects ot disconnects to/from a witeless network.

iPhone trigger — from your iPhone, iPod touch or iPad.

URL trigger — from an AppleScript or other script.
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Actions

* You can create Macro Actions manually or by recording them.

¢ There are many, many actions covering a broad range of facilities, including:
¢ Plug In Third Party Actions.
¢ Application Control actions to launch, activate, quit, show, hide, etcetera, applications.

¢ Clipboard actions to set, read, delete, style, filter, search, replace, etcetera clipboards.

¢ Control Flow actions to pause, loop, test conditions, process sets of items, and more.

¢ Debugger actions to breakpoint, pause, step over, step into, etcetera, while debugging macros.

» Execute AppleScripts, shell scripts, JavaScript (for Automation or in Safari/Chrome) and more.

¢ Read, write, trash, duplicate, append files, or get or set information about them.

e Safari/Chrome actions to work with the front web page, filling forms.

¢ Image actions to find, capture, read, write, crop, annotate, or display images.

e Interface actions to move or resize windows, click the mouse, type keystrokes, press buttons, etcetera.
e iTunes actions to play tracks, fast forward, rewind, change the volume and more.

¢ Actions to control Keyboard Maestro itself, enabling or disabling macros, showing and hiding palettes, etcetera.
e MIDI actions to send notes, control changes, or arbitrary packets.

¢ Send notifications via email, SMS, iMessage, notification center, sounds, alerts, etcetera.

¢ Open files, folders, URLs, system preferences, even 1Password bookmarks.

¢ QuickTime player actions to play movies, step forward or backward and more.

¢ Actions to control a Stream Deck device.

¢ Actions to launch applications, select windows, or switch clipboards.

e Sleep, restart or shut down your Mac, Fast User Switch, log out, change brightness or volume, etcetera.
¢ Type or paste strings, speak text, work with variables or dictionaries.

¢ Perform calculations, prompt for information, read or write passwords from the Keychain and more.

¢ Web actions to search the web, download files, remotely trigger actions, etcetera.

Basically, if you can do it yourself, Keyboard Maestro can probably do it for you.
Editor

¢ Dark Mode support.

e Multiple editor windows.

* Interactive Help system.

¢ Large Text support.

¢ Basic Touch Bar support.

e Smart Groups.

¢ Select from recently triggered or edited macros.
¢ Autocompletion.

e Integrated access to wiki help.

¢ Rename, color, group, and add notes to actions.
e Palette Theme Editor.

Named and History Clipboard Switcher

¢ Never lose your clipboard again.

¢ Browse your past clipboards and paste any previous clipboard item.

¢ An unlimited number of Named Clipboards.

* Send clipboard entries to other Macs.

¢ Clipboards display rich text and images.

¢ Use Quick Look to view clipboard entries.

 Apple Clipboard Filter triggered macros directly to selected clipboard entries.

e Set clipboard entries as favorites so they are always available in your clipboard history.
 Copy, Cut or Paste to/from Named Clipboards using a single keystroke.

* Clipboard History is optionally saved across logins and restarts.
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¢ Named Clipboards are saved permanently.
Application and Window Launching and Switching

* Display a Cover Flow view of available applications for quick launching,
¢ Optionally replace the system Command-Tab application switcher.

¢ Customize the switcher to match the look you want.

 Switch to any application or window with a keystroke.

e Switch to an application and hide all others.

e Easily select the exact application or window you want.

¢ Launch, hide, quit or force quit any application.

¢ Close ot minimize any window.

¢ Quit (or force quit) and relaunch applications.

¢ Get Info or reveal applications.

¢ Choose the application ordering you want: alphabetically, by last use, or by launch order.
¢ Sort windows alphabetically or by window depth order.

¢ Optionally hide other applications.

¢ Optionally always hide other applications.

Purchase

Keyboard Maestro is engineered by Stairways Software Pty Ltd and distributed by FastSpring

[https:/ /www.stairways.com/action/linkthru?fastspring]. Keyboard Maestro is licensed on a per-user basis and individual users may

use it on up to five Macs.

New customers can purchase Keyboard Maestro for US$36 by choosing the Keyboard Maestro » Purchase Keyboard

Maestro menu. Customers with five or more users should contact us [mailto:mailto:support@stairways.com] for a volume discount

Keyboard Maestro 9 is a paid upgrade for most users of previous versions. Existing users are eligible for a discount and can
purchase an upgrade by choosing the Keyboard Maestro » Purchase Keyboard Maestro Upgrade menu.

Customers who purchased Keyboard Maestro after 1 February 2019 have been issued a free upgrade to Keyboard Maestro 9.
If you have not received your free license, you can find your free license upgrade at https://enquiry.stairways.com/

[https://enquiry.stairways.com/].

Customers who purchased Keyboard Maestro 8 prior to March 2019 can upgrade to Keyboard Maestro 9 for US$18 until 8
October 2019. After that date, or customers who purchased older versions of Keyboard Maestro can upgrade to

Keyboard Maestro 9 for US$25. If you have not received your instructions on how to upgrade, you can find details by looking
up your Keyboard Maestro license at https://enquity.stairways.com/ [https://enquiry.stairways.com/].

Customers who have not disabled upgrade emails have been emailed with new license or upgrade instructions as approptiate.
If you have not received this email, please contact us [mailto:mailto:support@stairways.com] so we can resolve this promptly.

It is our informal policy to have a paid major upgrade roughly once every 12 to 24 months. This allows us to have a reasonably
consistent revenue stream with which to fund development of Keyboard Maestro, and ensures we are working as much for
existing customers as to expand the customer base. It means you can keep what you have purchased and not have to pay a
subscription, but also that we will still be around working on improving Keyboard Maestro and adding features for when you
choose to upgrade.

A fully-functional trial version of Keyboard Maestro is available for download from https://download.stairways.com/

[https:/ /download.stairways.com/].

For sales enquires, customer service, technical support, or to contact project management, our current contact information is

listed at https://contact.stairways.com/ [https://contact.stairways.com/].
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For mote information about anything to do with Keyboard Maestro, visit https://www.keyboardmaestro.com/

[https:/ /www.keyboardmaestro.com/].

Screenshots

Here is a quick taste of what Keyboard Maestro offers.
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Tour

This demonstration will begin to show you the power and versatility of Keyboard Maestro.
Getting Started

To start, launch Keyboard Maestro. It will initially display the Welcome window.
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Welcome to Keyboard Maestro 9

The best way to get to know Keyboard Maestro is to see it in action.

If you're new to Keyboard Maestro, try the Tutorial to see how you can
create a simple macro in just a few steps.

Start Tutorial

Quick Start

Learn about the components
of Keyboard Maestro and how
they work together.

Learn more »

L

Assistance

Immediately solve problems or
get more support options.
Learn more »

If you are new to Keyboard Maestro, start the tutorial and Keyboard Maestro will show you how easy it is to create a macro.
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You can see some example Macros we have included for you.

Make New Mactro

Click the |+| button under the Macro column to add a macro and display the Macro Editor window. We will now design a
complex Macro enabling you to save clippings to a text file. First, launch TextEdit and create a new empty document. Save this

blank document as |Clippings.rtf| in your folder.

Normally, to add a selection to the |Clippings.rtf] file, you would have to do all this:

Press Command-C to copy the selection in an application.

Go to the Finder, open your folder, then open the Clippings.rtf file.
Go to the end of the file in TextEdit.
Press the Return key and type a line of dashes and return to separate the clippings.
Press Command-V to paste the selection you made before.



e Save the file and close the document.

e Switch back to the application where you originally selected some text or a picture.

That is all very tedious, and probably explains why most people never even bother with such an operation.

So let’s define the whole sequence as a Macro.
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Now any time you have some text you want to save, just select it and press F2 (or Fn-F2 depending on the state of the |Use all
F1, F2, etc. keys as standard function keys| preference in the System Preferences). What used to be too much hassle to bother
with is now done in seconds!

Clipboard History

Keyboard Maestro automatically remembers your clipboard history, saving a copy of each new clipboard item as you copy it.
You can then paste any previous clipboard using the defined Hot Key (by default, Command-Control-Shift-V).
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Another advantage of the Clipboard History is you can leave the window open (by toggling the ‘Close After Action (X)‘ button)

and paste previous clipboards by simply double clicking the desired item. This is particularly helpful when you need to copy
many items in many places to be pasted into one application. Hold down the shift key to paste without styles.

Keyboard Maestro can even save your clipboard history across restarts and log outs. Just enable the “Save Clipboard History to

Disk” preference in the General preference pane.

Named Clipboards

For more permanent information, Keyboard Maestro lets you create as many named clipboards as you want using the
Clipboards preference pane.
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Named clipboards let you save frequently used information, like your company logo, timely information like a customer’s

address, or your address so you never have to type it again. This allows you to paste the saved information whenever you want,
wherever you want.

Then you can cut, copy ot paste to/from the named clipboatds using the defined Hot Keys (by default, Command-Shift-X, C
and V respectively, but you can change them, too).
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If you have a large screen, or a specific job that needs it, you can have the window stay open (by toggling the |Close After
Action (x)| button) and copy or paste named clipboards easily.



Application Switcher

At the end of the Macro we defined, we used the Switch To Last Application action to switch back to the application you were
using before. But most of us use a lot more than one application and we need to be able to switch between them, whether or
not the application is already open. You can do more than just switch between applications with Keyboard Maestro: it lets you
define applications that always appear when you are switching so you can launch them quickly, and also Excluded Applications
that you never want to see. As well, you can quit, hide or show applications. The Application Switcher is activated like any
other macro, so you can find it in the Switcher Group in the Macros window. By triggering the Application Switcher macro
(for example by entering the default Command-Tab key trigger, though this can be changed) you can display the

Application Switcher window.

Keyboard Maestro

Note the applications set to be launched or quit.

If you want a specific keystroke to always launch a certain application, you can define a Macro to do that. For example, you
could create a Macro with a Hot Key Trigger of F3 so it always activates Safari.

Window Switcher

Keyboard Maestro also includes a Window Switcher. By triggering the Window Switcher macro (for example, by pressing
Control-Tab), the Window Switcher window appears showing all the windows of current application (in the current space).

y —
|V ”
1 . ™

Finder

Desktop
Documents

Downloads

Library’

Movies
MUsic

windows

Note the windows set to be closed. This is a very useful way of cleaning up an application with a lot of open windows.
Conduct Your Mac Like a Pro!

This is just a taste of all that Keyboard Maestro can do for you. It’s time you started getting the most from your Mac!
Download Keyboard Maestro [https://www.stairways.com/action/linkthrudownload] today and you can be working faster and
smarter in no time.
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Links

Download Keyboard Maestro from https://download.stairways.com/ [https://download.stairways.com/].

Purchase Keyboard Maestro at https://purchase.stairways.com/ [https://purchase.stairways.com/].

Look up your current or previous license status and serial numbers, and get information about discounted upgrades from
https:/ /enquiry.stairways.com/ [https://enquity.stairways.com/].

Join the Keyboard Maestro Forum [https://forum.keyboardmaestro.com/] online community consisting of the developers and

Keyboard Maestro usets at https://forum.keyboardmaestro.com/ [https://forum.keyboardmaestro.com/].

Documentation desctibing Keyboard Maestro is available at https://documentation keyboardmaestro.com/

[https://documentation.keyboardmaestro.com/].

A wiki containing additional information, macros and other resources for Keyboard Maestro is available at
https:/ /wiki.keyboardmaestro.com/.

For sales enquires, customer service, technical support, or to contact project management, our current contact information is
listed at https://contact.stairways.com/ [https://contact.stairways.com/].

For more information about anything to do with Keyboard Maestro visit https://www.keyboardmaestro.com/

[https:/ /www.keyboardmaestro.com/].

Quick Start

Keyboard Maestro is easy to use once you understand the way the Editor and Engine, Macro Groups and Macros, Triggers and
Actions work together.

By using these six components together, you can dramatically enhance your Mac experience.
Just remember:

* If you want to make changes, use the Editor.

e If you want anything to work, make sure the Engine is running;

* If you want to control when a Macro is active, configure the Macro Group.
¢ If you want to control when a Macro is executed, configure its Triggers.

e If you want to control what a Macro does, configure its Actions.

Keyboard Maestro editor

The Keyboard Maestro application is the editor. It lets you create and modify macros and configure preferences. You use it
only when you want to make changes and then you quit it. It does not always need to be running. Whenever you launch
Keyboard Maestro, it also launches the Keyboard Maestro Engine which continues running until you log out (you can, and
should, have the Keyboard Maestro Engine launched automatically when you login by enabling the “Launch Engine at Login”
preference in the General preference pane).

Keyboard Maestro Engine

The Keyboard Maestro Engine is a background only application that enables all of Keyboard Maestro’s features. It responds to
your Hot Key presses, watches the time, tracks applications and maintains your clipboard history, handles receiving clipboards,
displays palettes, and, of course, executes your Macros. It should be running at all times, so we recommend you enable the
“Launch Engine at Login” preference in the General preference pane.

Macro Groups
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Keyboard Maestro allow you to organize your Macros into Macro Groups which are like folders of macros. Each

Macro Group controls when the macros it contains are active. A Macro Group can target or exclude specific applications,
which means the macros it contains will only be active in those desired applications. For example, you can have macros which
are active only in Mail.app, or only in Mail.app when a compose window is open.

A Macro Group can also act as a container for specific-use macros which are enabled only when you specifically activate them.
For example, you could create a Macro Group containing macros that resized or repositioned windows using the arrow keys,
but those macros would only be active after a specific Hot Key was pressed so that the arrow keys could be used normally at
other times.

Macro Groups can be displayed as palettes, allowing you to create your own custom toolbars which can be configured with a
variety of themes.

You create a Macro Group by clicking the | +| button at the bottom of the Macro Groups list. You can disable or enable
Macro Groups by clicking the |¥'| button. You can configure a Macro Group by selecting it and clicking the Edit button, or by
double-clicking on it.

You can also create Smart Groups, which are essentially saved searches and will show you any macros that match any of the set
of search criteria.

Macros

Keyboard Maestro’s main purpose is to execute Macros. A Macro lives in a Macro Group and consists of a set of Triggers that
determine when the macro is executed, together with a list of Actions that define what the macro does when it is executed.
You create a Macro by clicking the |+| button at the bottom of the Macros list. You can disable or enable Macros by clicking
the || button. Keep in mind that a Macro can only be active when the Macro Group that contains it is active. You can edit a
Macro by selecting it and clicking the Edit button, or by double-clicking on it.

Triggers

A Trigger defines when a macro will be executed. There are a variety of Triggers available, the most common is the Hot Key
trlggerwhlch executes the macro when a specified Hot Key is pressed. Similarly, you can use a Typed String trigger to execute a
macro when you type some text (for example =addr=). Other common triggers are the Macro Palette which lets you trigger a
macro by clicking on a context (front application or window) sensitive floating palette of macros and the Status Menu trigger
which displays the macro in the Status Menu. You can trigger macros from the clipboard history (to apply to the clipboard

entry), or by drawing a shape with the mouse or trackpad.

You can also trigger a macro when you login or when your Mac sleeps or wakes or goes idle, at a specific time or on a specific
day, when an application launches, activates or quits, by executing a script, or remotely using a web browser or iPhone or our
trigger server. And you can trigger a macro when something changes, like a volume being mounted or unmounted, plugging in
headphones, connecting a monitor, a USB device, or to a wireless network.

A Trigger will only execute the macro if the Macro Group and Macro are enabled and currently active. You create Triggers by
creating or editing a Macro and clicking the green |®)| button near the top of the macro detail view.

Actions

When a Macro is Triggered it executes a list of Actions. Keyboard Maestro performs each of the Actions in order. There ate a
wide variety of Actions allowing you to control applications, simulate user interface events like key presses, mouse clicks and
menu selections, work with files or images, control your Mac ot the clipboard, or display a variety of powerful switchers
(Application, Window, Clipboard and Clipboard History Switchers). You can also execute a script (AppleScript, Java, Swift,
shell Script or Automator Workflow) or even download or create your own custom plug in actions. There are many, many more

actions, so if you can do it yourself, Keyboard Maestro can probably do it for you. You create Actions by creating or editing a

Macro and clicking the |+| button to display available actions, or by clicking on the Record button and performing the action
while Keyboard Maestro records your actions to your Macro.
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Assistance

If you have any problems writing macros, you can get help from a number of places.

¢ This User Manual describes the basics of using the Keyboard Maestro editor.

* The Tutorial will show you how to create a simple macros. You can start the Tutorial by choosing the Help » Tutorial

understand these basics to get the most out of Keyboard Maestro.
¢ The Wiki includes lots of information on all aspects of Keyboard Maestro.

¢ The Forum [https://forum.keyboardmaestro.com/] is a great place to ask for help with macros.

¢ FEach action in Keyboard Maestro includes a Help option in the @ menu at the top right of the action.
¢ Holding down the option key while choosing from any of the Insert menus in the Edit menu will get you help on actions,

functions, or tokens.

» Holding down the option key while choosing from the new trigger menu will get you help on the triggers.

¢ Holding down the option key while choosing from the new condition menu will get you help on the _gonditions.

* Holding down the option key while choosing from the new collection menu will get you help on the

And last but not least, you can ask Keyboard Maestro itself for assistance by choosing Help » Interactive Help menu.

In particular, the Interactive Help window can help you:

* if something is happening that you do not expect — Keyboard Maestro can show you what it is doing
e if a macro is not doing anything — Keyboard Maestro can help you to learn why.

HowdoI...?
How do I install Keyboard Maestro?

To install Keyboard Maestro, simply copy it to your Mac’s |Applications| folder (or anywhere you like).

Note: You must use the Finder to do this since the Finder will turn off Apple's App Translocation security feature when you
move the application.

When you launch Keyboard Maestro it launches an invisible “Keyboard Maestro Engine” that continues to run even after you
quit Keyboard Maestro. The engine is the process that enables your Macros, Application Switcher, and Clipboard History

Switcher to work. This means that they will continue to work after you quit Keyboard Maestro, as long as the engine is still

running,

You can quit or launch the engine manually using the File menu.

You should consider turning on the “Launch Engine at Login” preference in the General preference pane to ensure all of

Keyboard Maestro’s facilities are available to you as soon as you login or startup your Mac.
How do I upgrade Keyboard Maestro?

Keyboard Maestro includes an automatic upgrade mechanism, so to upgrade Keyboard Maestro simply click the

Install Update| button when prompted.

To upgrade Keyboard Maestro manually, quit the engine by choosing the File » Quit Engine menu, and quit the editor, and
replace the Keyboard Maestro application in your |Applications| folder with the new one. Finally, launch Keyboard Maestro to
restart the engine.

Keyboard Maestro will automatically import your previous version mactros, clipboards and preferences. Your old macros will be

saved in the ‘N /Library/Preferences/Keyboard Maestro/Keyboard Maestro Macros Saved Version 8.plist‘ in case you wish to

revert to version 7 for any reason.
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If you are upgrading directly from a much older version, you will get better results by upgrading to the last of each major
version in turn, ie, run 2.1.3, then 3.5, then 4.3.2, then 5.3.2, then 6.4.8, then 7.3.1, then 8.4.2, then the current version. You can
download old versions from our file archive [https://files.stairways.com/].

How do I purchase Keyboard Maestro?

New customers can purchase Keyboard Maestro for US$36 by choosing the Keyboard Maestro » Purchase Keyboard

Maestro menu. Customers with five or more users should contact us for a volume discount quote.

You can look up your current or previous license status and serial numbers, and get information about discounted upgrades

from https://enquiry.stairways.com/ [https://enquiry.stairways.com/].

Thanks for supporting us and enabling us to continue work on Keyboard Maestro.

See also the Purchase section.

Can I purchase Keyboard Maestro from the Mac App Store?

Keyboard Maestro will not be available on the Mac App Store. Apple requires applications on the Mac App Store to be
Sandboxed, and workflow applications like Keyboard Maestro cannot be sandboxed so it is excluded from the Mac App Store.

See also the Purchase section.

How do I register Keyboard Maestro?

When you purchase Keyboard Maestro you will be given a serial number, and will also promptly be emailed your username
(email address) and serial number in the “Thanks For Your Purchase” email. Although you can retrieve this information from
us at any time in the future, it is a good idea to keep this safe.

If you do not receive your serial number promptly after purchasing, it may be that the email has not reached you, possibly due
to spam filtering on your email service. In this case, try looking up your purchase at https://enquity.stairways.com/

[https:/ /enquiry.stairways.com/] (although that will email you your serial number which might again be lost to over-zealous spam
filters).

Once you have your username (email address) and serial number, launch Keyboard Maestro and either immediately click the

‘Use Existing License‘ button or choose Keyboard Maestro » Register Keyboard Maestro menu and then enter the username

(email address) exactly as shown and the serial number exactly as shown and click the \%‘ button. If you have any problems,
recheck that the email address and serial number you are entering are exactly as shown (the serial number’s email address does
not change even if you have changed your email address with us) and also that your license matches the major version number
(eg, a version 8 license will work with version 8.x of Keyboard Maestro). If you ate already registered, the

Register Keyboard Maestro menu will show you the registration details in the About Keyboard Maestro window — if it says it
is registered to you, you are all set.

How do I get started?

The first thing to do is to read the Quick Start and do the tutorial by choosing the Help » Tutorial menu. You may also want

to subscribe to our Getting Started emails (Keyboard Maestro will ask you to subscribe or you can do that at your customer
database page [https:/ /www.stairways.com/form/manageemail] on our web site).

The best way to start using Keyboard Maestro is to start simple:

¢ Read the Quick Start.

¢ Do the Tutorial by choosing the Help » Tutorial menu.

¢ And then grow your macros organically, starting simple.
¢ Join the forum (https://forum.keyboardmaestro.com/ [https://forum.keyboardmaestro.com/]) and ask for help with any

macros you get stuck on.
¢ Consider enrolling in David Spark’s Keyboard Maestro Field Guide [https:/ /learn.macsparky.com/p/km].
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You may also want to subscribe to our Getting Started emails (Keyboard Maestro will ask you to subscribe or you can do that

at your customer database page [https://www.stairways.com/form/manageemail] on our web site).

Then use your Mac normally and keep an eye out for things you do repetitively. Things like:

e launch or switch to a particular application.
¢ open a particular document.
e type a specific string of text (eg your name, address, etc).

When you notice something, consider making a Macro to do it and assigning it to a Hot Key or a Macro Palette or Status Menu
trigger.

Try to be consistent with your Hot Keys, for example you might have a set of applications you open, using a function key for
each, and a set of documents you open, using a Control-Function Key combination for each of them, and a bunch of snippets
of text your type, using Control-Letter for each of them (the letter could be a mnemonic to help you remember which one is
which). Consider putting a sticker on your keyboard across the top of your function keys to help you remember which ones do
which function. Remember that you can use the number pad keys as well.

Also, keep in mind common command keys and system defined hot keys and try to avoid conflicting with them.

See also the Tips section.

How do I create a new Macro?

If you have not done so, use the tutorial by choosing the Help » Tutorial menu to lead you through the process of creating a

simple macro.

To create a Macro, launch Keyboard Maestro and select the Global Macro Group, then click the |+| button under the Macros
list. Give the Macro a name, add one or more triggers, and one or more actions. The Macro is immediately active

you do

not need to stop editing, quit the editor or anything else.

An easy way to generate macro actions is to turn on recording and proceed to show Keyboard Maestro what you want to do.
Then turn recording back off and look through the actions — chances are you will want to delete or adjust some of the
recorded actions to make a robust macro, but this will give you a quick start on creating the macro.

How do I find a Macro I've used or modified recently?

You can sort the macros by name, by trigger, by date created, modified or used. So if you launch Keyboard Maestro, select the
All Macros smart group, and then choose the View » Sort Macros by Date Modified menu (ot choose the View » Sort

Macros by Date Used menu) to sort the recently modified (or used) macros to the top.

You can also click the |®| button above the macro editor pane to select from recently modified macros, or use the |d6| button to
select from recently used macros.

How do I cancel a running Macro?

You can cancel all running macros by holding all the modifiers (Control, Option, Shift and optionally Command) and clicking
on the Keyboard Maestro Status Menu Icon.

You can cancel a specific macro by choosing from the Status Menu » Cancel menu and selecting the macro. This is also a

useful way of seeing what macros are currently running, if any.

You can also see and cancel macros by choosing the Status Menu » Start Debugging menu.

And finally, you can use the Cancel All Macros, Cancel Other Macros, Cancel This Macro, or Cancel Just This Macro actions.

In desperation, you can quit the Keyboard Maestro Engine from the status menu, and you can launch the editor while holding
all the modifiers down to quit all running engines and not launch the engine.
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How can I get the mouse coordinates on the screen or in a window?

If possible, you should avoid using mouse click actions. They tend to be very fragile, easily broken by subtle changes to the
system or applications. And they also require the screen to be in the expected state, so you usually need to add a Pause action
before them to ensure the item they are clicking on is where it is expected to be.

That said, you can use the Mouse Display window by choosing the Window » Mouse Display menu which will let you see the

mouse coordinates relative to the window or main screen. Click the lock button to lock the display after a few seconds, and
then put your mouse over the desired location. You can then change the relative corner, and click the Clipboard buttons to
copy the coordinates.

Alternatively, you can simply record the click. Turn on recording in Keyboard Maestro, go to where you want to be, wait a
couple seconds for the screen to be stabilised so the click will be relative to the front window, and click. Turn off recording,
delete any extrancously recorded actions and you have your coordinates. Immediately after recording you can adjust the relative

corner of the window or screen, and the recorded coordinates will adjust to match.

Remember that offsets are always to positive to the right and positive down, so if you are making a mouse click up from
bottom edge of a window or screen, or left from the right edge of a window or screen, you will need to use negative
coordinates.

How do I insert styled/colored text or images?

You can use the Insert Text action to insert styled text by pasting.

You can insert an image by copying it to the clipboard and then pasting it in using the P ion (which just types the

Command-V keystroke).
You can get your image from a Named Clipboard, or by reading an image file.
Here is how to create a Macro to insert an image when you press a Hot Key.

¢ Create a macro (see the How do I create a new Macro? section) with the Set Clipboard to Image action.

e Paste your image in to the action, or have the action read the image from a file or Named Clipboard.
¢ Then use the Paste action to paste your image.

Name the macro, and assign it whatever trigger you desire.

Now whenever you trigger the macro you just created, your image will be pasted in.
How do I Insert the current date?

You can insert text using the Insert Text action, and it processes Tokens. There are some basic date format tokens (such as the

%LongDate% token), or you can use the %ICUDateTime% token with any ICU date format

ttps:/ /www.stairways.com/action/linkthru?icudatetime].
p y

How do I get more than one Macro Palette (Toolbar)?

There are three kinds of palettes in Keyboard Maestro:

¢ There is one “Global Macro Palette” which includes any active macro that has the Macro Palette trigger. It appears
whenever there is any active macro with the Macro Palette trigger. It shrinks to the size of an icon until you hover over it
and then it expands to display the currently active macros with Macro Palette triggers. You can show and hide it using
specific Macro Palette actions.

¢ Each Macro Group can be displayed as a palette. The macro group can be global to all applications, or specific to any
subset of applications. It can be toggled on and off with a hot key (or a status menu selection or from the Global Macro
Palette) or it can be displayed for a single action. Actions can hide or show the macro group palettes.

¢ When a hot key (or typed string or device key) conflicts (ie, triggers more than one macro), the Conflict Palette appears

which lets you select from the conflicting macros. This can be an easy way to allow a single hot key to offer a multitude of
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similar actions. You can then use number keys or the mouse to select the desired hot key, or can use other keys to filter the

palette until only one macro remains.

So to have more than one macro palette, create a macro group for each desired palette and configure it to show a palette as
desired. Put your macros in there. Create as many of these as you like. The macros in such a macro group are only active while
the palette is displayed, so if you only display it occasionally, especially only for one action, then they can have very simple hot
keys (like plain letters for example).

You can control the order of macros in a macro palette (or the status menu) by prefixing their name with two characters and a
closing parenthesis (eg “01)” - two characters and a closing bracket). The macros will be sorted based on the code, but the code
will be stripped off before display in the palette (or status menu).

How do I use a multiple keystroke trigger?

You can assign the same hot key to multiple macros, and Keyboard Maestro will display a palette of the conflicting macros
when you press that hot key allowing you to select the desired macro. You can select a macro from the palette using either
number keys, or by typing the first distinct character to filter the macros down until only one is left. This is especially useful
when you have a variety of similar or related tasks. You can also assign a hot key to a macro group which can activate it for one
action (with or without a palette), and the contained macros can have whatever ”second” hot key you desire.

But Keyboard Maestro does not directly support assigning a two-keystroke hot key to a trigger. The problem with multiple
keystroke triggers like Option-F R is what to do if you type Option-F A? Logic dictates that the Option-F A should go through
to the system unimpeded, but Option-F R should be swallowed entirely. But this is impossible. The only way to do it would be
to swallow the Option-F key, and then swallow the second key and then resubmit the Option F and the second key unless it
matches Option-F R.

However, that is fraught with peril and cannot work robustly in the presence of other applications placing things on the
keyboard event queue (or even a sufficiently fast typist).

For example, suppose you quickly typed Option-F A B. Keyboard Maestro would have swallowed the Option I and then the
A, and then resubmitted it to the event queue, resulting in the stream of characters B, Option-E, A. There is no way to avoid
this race condition, and as such Keyboard Maestro does not support any such mechanism.

As described above, Keyboard Maestro has a variety of ways you can use Option-F as a hot key that allows a second key to be
used to select a macro. However in all cases it is clear that the Option-F has been used and there is no concept that the
Option-F might come back later to do something else.

How do I configure the Application Switcher?

The Application Switcher (and all the switchers) are activated by macro actions. Keyboard Maestro creates a default
“Switcher Group” Macro Group containing several macros, each macro has a hot key trigger and a matching action which
activates the appropriate switcher.

So to configure the Application Switcher, launch Keyboard Maestro, select the Switcher Group, and double click the Activate
Application Switcher macro. You can then configure the various Application Switcher parameters, such as style and icon size by
configuring the Application Switcher action. You can also configure the hot key used to activate the switcher, or disable the
switcher.

How do I backup / transfer my installation to another Mac?

indeed you can use Macro Syncing to transfer to a new Mac (even if both Macs wont be on at the same time as long as you
preserve the sync file).

To transfer all your information to a new Mac you can copy the ‘N/ Library/Application Support/Keyboard Maestro‘ folder
and optionally the ‘~ /Library/Preferences/ com.stairways.keyboardmaestro.*‘ files to your new Mac. You can get to |~ /Library
in the Finder by holding down the shift (or option) key and selecting Library from the Go menu.




Make sure that Keyboard Maestro and Keyboard Maestro Engine are not running on the source or target Mac when you
transfer the folder. And make sure the resulting files and folders have the correct ownership and permissions.

the same Mac for syncing purposes, so you should not do this if you intend to continue using the old Mac.

Alternatively, to just transfer the macros, you can turn on Macro Syncing and save the macro sync file anywhere. Transfer it to
the new Mac, install Keyboard Maestro as normal, and then turn on macro syncing and select the transferred file to replace
your macros. Then turn off macro syncing. This will transfer just the macros, not any settings, variables, or clipboards or the

like.

How do I uninstall Keyboard Maestro?

Launch Keyboard Maestro and ensure the “Launch Engine at Login” preference in the General preference pane is turned off.
Then choose the File » Quit Engine menu to quit the engine, and then choose the Keyboard Maestro » Quit Keyboard

Maestro menu to quit the application.

You can then trash the Keyboard Maestro application from your |Applications| folder, as well as the preferences in the
‘ ~/Libratry/Application Support/Keyboard Maestro‘ folder and ‘~ /Library/Preferences/com.stairways.keyboardmaestro.*
files and logs in the ‘~ /Library/Logs/Keyboard Maestro‘ folder.

How do I revert to a previous version of Keyboard Maestro?

Launch Keyboard Maestro and ensure the “Launch Engine at Login” preference in the General preference pane is turned off.
Then choose the File » Quit Engine menu to quit the engine, and then choose the Keyboard Maestro » Quit Keyboard

For version 2, open the ‘N /Library/ Preferences‘ folder and the folder |~ /Library/Preferences/Keyboard Maestro/Saved

Version 2| folder. Move the files from the latter folder into the former folder. Trash the ‘N/ Library/Preferences/Keyboard
Maestro| folder. Download Keyboard Maestro 2.1.3, if necessary, from
https://files.stairways.com/keyboardmaestro/keyboardmaestro-213.dmg

[https:/ /files.stairways.com/keyboardmaestro /keyboardmaestro-213.dmg]. Move Keyboard Maestro 2 to the Applications folder and

launch it. Turn on the “Launch Engine at Login” preference if desired.

For version 3, open the |~ /Library/Preferences/Keyboard Maestro| folder. Trash the [Keyboard Maestro Macros.plist| and

replace it with the ‘Keyboard Maestro Macros Saved Version 6.plist‘. Download Keyboard Maestro 3.5, if necessary, from

https:/ /files.stairways.com/keyboardmaestro/keyboardmaestro-35.zip

[https:/ /files.stairways.com/keyboardmaestro /keyboardmaestro-35.zip]. Move Keyboard Maestro 3 to the Applications folder and

launch it. Turn on the “Launch Engine at Login” preference if desired.

For version 4, open the ‘~/ Library/Preferences/Keyboard Maestro‘ folder. Trash the ‘Keyboard Maestro Macros.plist‘ and

replace it with the ‘Keyboard Maestro Macros Saved Version 6.plist‘. Download Keyboard Maestro 4.3.2, if necessary, from

https://files.stairways.com/keyboardmaestro/keyboardmaestro-432.zip

[https:/ /files.stairways.com/keyboardmaestro /keyboardmaestro-432.zip]. Move Keyboard Maestro 4 to the Applications folder and

launch it. Turn on the “Launch Engine at Login” preference if desired.

For version 5, open the |~ /Library/ Application Support/Keyboard Maestro| folder. Trash the [Keyboard Maestro Macros.plist|

and replace it with the ‘Keyboard Maestro Macros Saved Version 6.plist‘. Download Keyboard Maestro 5.3.2, if necessary, from

https://files.stairways.com/keyboardmaestro/keyboardmaestro-532.zip

[https:/ /files.stairways.com/keyboardmaestro /keyboardmaestro-532.zip]. Move Keyboard Maestro 5 to the Applications folder and

launch it. Turn on the “Launch Engine at Login” preference if desired.

For version 6, open the ‘~/ Library/Application Support/Keyboatrd Maestro‘ folder. Trash the ‘Keyboard Maestro Macros.pljst‘

and replace it with the ‘Keyboard Maestro Macros Saved Version 6.plist‘. Download Keyboard Maestro 6.4.8, if necessary, from

https:/ /files.stairways.com/keyboardmaestro/keyboardmaestro-648.zip

[https:/ /files.stairways.com/keyboardmaestro/keyboardmaestro-648.zip]. Move Keyboard Maestro 6 to the Applications folder and

launch it. Turn on the “Launch Engine at Login” preference if desired.
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For version 7, open the ‘~/ Library/Application Support/Keyboard Maestro‘ folder. Trash the ‘Keyboard Maestro Macros.plist‘

and replace it with the ‘Keyboard Maestro Macros Saved Version 7.plist‘. Download Keyboard Maestro 7.3.1, if necessary, from

https://files.stairways.com/keyboardmaestro/keyboardmaestro-731.zip

[https:/ /files.stairways.com/keyboardmaestro /keyboardmaestro-731.zip]. Move Keyboard Maestro 7 to the Applications folder and

launch it. Turn on the “Launch Engine at Login” preference if desired.

For version 8, open the ‘N/ Library/Application Support/Keyboard Maestro‘ folder. Trash the ‘Keyboard Maestro Macros.plist‘
and replace it with the ‘Keyboard Maestro Macros Saved Version 8.plist‘. Download Keyboard Maestro 8.2.4, if necessary, from

https://files.stairways.com/keyboardmaestro/keyboardmaestro-824.zip

[https:/ /files.stairways.com/keyboardmaestro /keyboardmaestro-824.zip]. Move Keyboard Maestro 8 to the Applications folder and

launch it. Turn on the “Launch Engine at Login” preference if desired.

Editor Window

To edit your macros, launch the Keyboard Maestro application. It will display one or more Editor Windows. If you close the
last editor window, the Keyboard Maestro application will quit, but the Keyboard Maestro Engine will continue running to
perform your macros. Normally you only launch the Keyboard Maestro editor application when you want to change your
macros, and leave only the Keyboard Maestro Engine running normally.

You can create a new editor window by choosing the File » New Editor Window menu.
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One the Group column (1) on the left, you have the a list of all your Smart Groups and Macro Groups. Smart Groups are

saved searches of macros.

In the Macro column (2) in the middle are the Macros. Macros are the primary way you describe what you want Keyboard

Maestro to do. This column will list all the macros matched by any selected Swart Groups, and all the macros contained by any
selected Macro Groups. You can filter the list to find specific macros by using the Search Field (3).

In the right column (3) you have a description of the selected macro. When in Edit mode (which you can toggle with the
button (5)), this is where you will edit your Smart Group searches, your Macro Group configurations, and your Macros.

At the bottom of each column (4) it a set of buttons to create (, delete (Eb ot enable/disable ( their respective groups,
macros or actions. There is an extra |®| button at the far left to create a Smart Group.

Next to the button (5) are buttons to set a timeout for a specific action, to try the selected actions, and the enter
recording mode to add new actions by recording what you are doing (moving and clicking the mouse, selecting menus, moving


https://files.stairways.com/keyboardmaestro/keyboardmaestro-731.zip
https://files.stairways.com/keyboardmaestro/keyboardmaestro-824.zip

and resizing windows, typing characters, etc).
Along the top of the window is the toolbar. From left to right the buttons let you:

e Share your macros, including directly to the Keyboard Maestro Forum [https://forum.keyboardmaestro.com/].
¢ Select the most recently used (triggered) macros.

¢ Select from the recently edited macro history.

¢ Select the most recently edited macro.

¢ Run the selected macro.

¢ Search for macros. The Macros column (2) will be filtered to only matching macros, and any parts of the macro that
match will be highlighted in striped blue in the detail column (3).

When you are in Edit Mode, and you select a Smart Group, you can edit its search settings.
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You can adjust the name of the Smart Group (1), and adjust its Search Strings (2).

You can add another Search String by clicking the green |+ | button.

When you are in Edit Mode, and you select a Macro Group, you can edit its configuration.
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You can adjust the name of the Macro Group (1).

For a Macro to be available to trigger, it must be enabled and its parent Macro Group must be enabled, and active. The
configurations for the Macro Group control when it will be active, and thus when the macros it contains will be active
(available to be triggered and executed).

You can adjust whether the macro group is enabled (2), whether it is only active in some specific applications (3) (ie, when they
are at the front, and their menu bar is showing), whether it is only active in specific windows (4), whether it is only active when
you explicitly toggle it on or off, and whether and how it shows a palette containing its macros (5).

When you are in Edit Mode and you select a Macro, you can edit its behaviour.
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You can adjust the name of the Macro (1), and whether it is enabled (2) (a macro must be enabled for it to be available to be
triggered (executed) - its parent macro group must also be enabled and active).

A macro consists of a set of triggers (3). When it is active, if any of these triggers happen, then the macro executes the actions

s e

You can add a trigger by clicking and holding on the green |+| button (4) and selecting the kind of trigger you would like to use.
Some triggers, like the S Menu trigger, do not have any additional configuration. Simply adding them to the macro will
have macro triggered when the event happens (in this case, the macro will be listed in the Keyboard Maestro status menu, and
will be triggered if you choose it from that menu).

Other triggers, like the Typed String trigger, require you to configure more details about when the trigger should happen, such

as the specific string you have to type to trigger the macro. For the macro shown, the macro will be triggered when you type
the string “=-="

When a macro is triggered, it will execute the actions you have specified (5).

You can add a new action by clicking the button or the |+ | button at the bottom of the macro detail view (6) to
display the list of actions ot by choosing the Edit » Insert Action By Name menu ot choosing from the Edit » Insert Action

In the displayed macro, the action uses the %SystemClipboard%o token to read the system clipboard, and will then insert it by
typing (rather than the normal pasting for the System Clipboard). This can be useful for cases where you are disallowed from
pasting for some reason.

Macro Groups

Keyboard Maestro organizes your macros into Macro Groups which are like folders of macros. Each Macro Group contains a
number of macros and controls when those macros are active.
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A Macro Group can target or exclude specific applications, which means the macros it contains will only be active in those
desired applications or when those applications are running. For example, you can have macros which are active only in
Mail.app. It can also be active only in specific windows. So for example, you can have macros which are active only in Mail.app,
or only in Mail.app when a compose window is open.

A Macro Group can also act as a container for specific-use macros which are enabled only when you specifically activate them.
For example, you could create a Macro Group containing macros that resized or repositioned windows using the arrow keys,
but those macros would only be active after the Hot Key was pressed so that the arrow keys could be used normally at other
times.

Macro Groups can be displayed as palettes, allowing you to create your own custom toolbars which can be configured with a
variety of themes and to appear under the mouse.

If you are syncing your macros with another Mac, Macro Groups can be disabled specifically on this Mac.

To create a new Macro Group, first launch Keyboard Maestro.

[ ] [ ] ¢ Keyboard Maestro Editor — Type Clipboard
th e < 0] > Q-
Share Used Histary Modified Run Search
Groups A 4 Macros Y
& All Macros [ Lowercase Eritter |
# Enabled Macros B open in BBedit CIFilter L] Type CIi pboard
Acorn @ Paste Plain Text GV
BBEdi P Previ Clipboard ~3V = =
S T Pasta Previous Clipboard Triggered by any of the following:
Clipboard Filters @ Paste Selection Into... LOEC ~
Clpboads = The Status Menu
Finder G- Uspercase —Filter [ The exact case string “=-="is typed (then
Global Macro Group
Switcher Group deIEtEd)
And 3 Disabled Groups f & i
Will execute the following actions:
[ Insert Text by Typing
| %SystemClipboard%
® + - v + - v Edit ?

Now click the |+| button below the Macro Groups list.
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Enter the name of your new Macro Group.
You can choose to target the macros in your Macro Group at specific applications.

By default, Macro Groups and their Macros are available in all applications, that is they are always ready to be triggered. These
are especially useful for Macros that give you instant access to applications or documents, or type in globally applicable text.
For example you might have a Macro to launch your email client or word processor, a Macro to open your financial accounts,
and a macro to type your name or email address.

To have macros only active in specific applications, set the Macro Group to be “Available in the following applications” and
add the desired applications to the list.

For example, you could have macros targeted at:

e Mail.app that insert common text messages.

e BBEJit and Xcode that insert code chunks or duplicate lines or add #include headers.
e Safari that configure windows or enter information.

¢ Photoshop or Acorn that arrange items or script guides.

To have macros active everywhere except specific applications, set the Macro Group to be “Available except in the following
applications” and add the desired applications to the list. For example, you could exclude macros from triggering in games.
Also, if you have an application that uses lots of function keys for crucial tasks, you could exclude that application to allow you
to use the function keys for macros elsewhere without conflicting with that application.

You can restrict a macro to be active only in certain windows based on the window title.
You can also choose to activate the macros manually or display the macros in a floating macro palette. The options are:

¢ Always activated.

¢ Activated for one action when:

e Activated/deactivated when:

¢ Shows a palette for one action when:

 Shows/hides a palette when:

¢ Shows a palette until:

¢ Always activated and shows a palette for one action when:
* Always activated and shows/hides a palette when:

¢ Always activated and shows a palette until:
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To have the macros in a Macro Group always ready to be triggered, set the Macro Group to be “Always activated”.

To have macros that are active only immediately after you trigger the Macro Group with no visible palette, set the Macro
Group to be activated “Activated for one action when”. The macros in the Macro Group will be enabled when you trigger the
Macro Group and will remain enabled until either any macro is triggered or you press any other key. You could use this to
create a set of related actions with easily remembered hot keys that will not conflict with normal use because they are not
activated until you trigger the group. For example, you could have a group of macros to launch vatious applications so that
Command-Control-L activates the group and then a single letter press launched the application (eg M for Mail, S for Safari, F
for Finder).

As with each of the following options, you can trigger the macro group by pressing a Hot Key, by selecting from the Status
Menu, or by clicking on the global floating palette.

'To have Macros that are remain active after you trigger the Macro Group, set the Macro Group to be “Activated/deactivated
when”. The Macros in the Macro Group will be enabled when you trigger the Macro Group and will remain enabled until you
dismiss the Macro Group by repeating the trigger. You could use this to create a set of related actions with easily remembered
hot keys that will not conflict with normal use because they are not activated until you press the group Hot Key. For example,
you could have a group of macros to move and resize windows and have Command-Control-W activate the group. Then a
single arrow key press moves the front window. When the window is positioned, press Command-Control-W a second time to
disable the macros.

To have Macros that are active and displayed in a macro palette only immediately after you trigger the Macro Group, set the
Macro Group to “Shows a palette for one action when”. The Macros in the Macro Group will be displayed in a floating Macro
Palette and enabled when you trigger the Macro Group and will remain displayed until either any macro is triggered or you
press any other key. You could use this to create a set of related actions that do not even need a Hot Key. For example, you
could have a group of macros to launch various applications like Mail, Safari and the Finder so when you press Command-
Control-L, a palette of these macros is displayed and a single click on the desired application will launch the application.

To have Macros that are active and displayed in a macro palette after you trigger the Macro Group, set the Macro Group to
“Shows/hides a palette when”. The Mactos in the Macto Group will be displayed in a floating Macto Palette and enabled when
you trigger the Macro Group and will remain displayed until you trigger the Macro Group again. You could use this to create a
set of related actions that do not even need a Hot Key. For example, you could have a group of macros to align objects in a
CAD application, so when you press Command-Control-A, a palette of these macros is displayed and you can click various
alighment options (distribute left-right, align top edges) and then close the palette by pressing Command-Control-A a second
tume.

To have Macros that are initially active and displayed in a palette, set the Macro Group to “Shows a palette until”. The Macros
in the Macro Group will be displayed in a floating Macro Palette and enabled. The palette will close when (if) you trigger the
Macro Group and will remain closed (and the macros disabled) until you trigger the Macro Group again. You could use this to
create a set of related actions that do not even need a Hot Key and that ate available in a Macro Palette. You could make the
Macro Group available only in a specific application so that it appears only in that application. For example, you could have a
group of macros to align objects in a CAD application, and have the Macro Group available (and hence the palette displayed)
only in the CAD application.

Whether the macros are displayed in a Palette or not, the macros can still have Hot Key (or any other kind of) triggers which
will be available whenever the macro group is active.

With the previous three settings, the macros are active if and only if the palette is displayed. The final three options ate the
same except that the macros are always active, so they are always available to be triggered by another means, and sometimes by
the palette.

You can change the targeting of an existing group by selecting it in the Groups list and ensuring you are in Edit mode by
clicking the button, or by double clicking the macro group.

You can disable or enable a macro group by selecting it and clicking the |¥'| button at the bottom of the Groups list. If a
Macro Group is disabled or inactive for any reason, all its contained Macros will be inactive. You can disable or enable a Macro
Group using the Set Macro Enable action, you can show in a palette or activate a Macro Group using the Show Macro Group
or Activate Macro Group actions.



Disabled Macro Groups can optionally be hidden using the choosing the View » Hide Disabled Macro Groups menu.

You can control or right click on a macro group to Disable, Enable, Rename, Duplicate, or Export it.

The Keyboard Maestro editor has full AppleScript support so you can manipulate macro groups in many ways via AppleScript.
See Scripting the Keyboard Maestro editor

To delete a Macro Group, select the macro group and then press Command-Delete or click the H button at the bottom of the
Groups list.

You cannot delete or rename or disable the Global Macro Group. If you want to control when some of the macros within the
Global Macro Group are active, make a new macro group and drag those macros to it.

Smart Groups

You can create Smart Groups which let you see macros matching certain criteria by clicking the |@®| button button at the
bottom of the Groups column, and you can edit a smart group selecting it in the Groups list and clicking the button, or
by double clicking the Smart Group.

A Smart Group consists of a set of Search Strings, and any macro that matches any of the search strings will be listed in the
Smart Group.

You can control or right click on a smart group to Rename or Duplicate it.

Mactros

Macros are used to automate your workflow, procedure, or process on your Mac. Macros, also known as Shortcuts, are a way of
improving your productivity by allowing you to perform repetitive or frequently required actions more quickly and accurately,
tailoring your Mac to your usage patterns.

A Macro consists of:

¢ One or more Macro Triggers which define when the macro will be executed, if it is Active.

e A series of steps to execute called Macro Actions.

Macros are contained in Macro Groups, much like files are contained in folders. The Macro Group determines when the

* A single action like Insert Text by Pasting the text “SomeName@SomeDomain.com”

¢ Isin the “Global Macro Group”, making it available to all applications.

Macros can do almost anything you can do manually on your Mac, and much that you can't, like running scripts.
How To Create a Macro

To create a Macro, first launch Keyboard Maestro, select the desired Macro Group to contain it, and then click the |+| button
below the Macros list. To edit a Macro, double click it, or select it and ensure the button is pressed. The Macro Editor
window will be displayed.
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Enter the name of your new Macro (you can skip this and it will be named for you based on the action you select).

You can create a new trigger by clicking on the green |®) button. There are several Macro Triggers to choose from, the most

different triggers, and any of the triggers will execute the Macro Actions. You can delete a trigger by clicking the red |©| button.

You can add a new action by clicking the button or the |+| button at the bottom of the macro detail view to
display the list of actions ot by choosing the Edit » Insert Action By Name menu ot choosing from the Edit » Insert Action

menu. There are many Macro Actions to choose from. The actions you include will be executed in order. You can reorder the

actions by dragging them around. You can copy actions by Option-Dragging or by using Copy and Paste. You can delete an

action by selecting it and pressing the Delete key. You can enable or disable actions by selecting them and clicking the
button at the bottom of the macro detail view.

You can control or right click on a macro group to Disable, Enable, Rename, Duplicate, or Export it.

An easy way to generate macro actions is to turn on recording by clicking the button at the bottom of the macro detail
view and proceeding to show Keyboard Maestro what you want to do. Then turn recording back off and look through the
actions. Chances ate you will need to delete or adjust some of the recorded actions to make a robust macro, but this will be

quicker than creating each action manually.

Macros are continuously saved, so the macro is live as soon as it is created. It will be available immediately (subject to the
restrictions of the Macro Group it is contained in). There is no need to turn off editing, switch to a different macro, or quit the
editor (although quitting the editor after you have finished editing all your macros is a good idea).

You can select a recently triggered macro by clicking on the |d8| toolbar button to select it or select from recently modified
macros by clicking the |®| toolbar button.

You can share a macro to the Keyboard Maestro Forum, or to a friend via Mail or Messages using the sharing button at the top

of the Macros window.

You can disable or enable a macro by selecting it and clicking the |¥'| button at the bottom of the Macros list. You can also
disable or enable a Macro using the Set Macro Enable action, or from AppleScript with:

tell application "Keyboard Maestro"
set enabled of macro group "Macro Name" to true
end tell

You can start editing a Macro from AppleScript with:
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tell application "Keyboard Maestro"
editMacro "Macro Name or UID"
end tell

The Keyboard Maestro editor has full AppleScript support so you can manipulate macros in many ways via AppleScript.
How to Edit a Macro

You edit a macro by selecting it and ensure you are in Edit mode. Double clicking on the macro will turn on Edit mode.

You can select a macro by name by choosing the View » Select Macro By Name menu.

How to Run a Macro

In order to run (execute or trigger) a macro it must be active, that is:

e It is enabled
¢ It’s containing Macro Group is enabled
* It’s containing Macro Group meets all its activation criteria.

Activation/Deactivation ot a Macro Group is a dynamic process, automatically set by the Keyboard Maestro Engine as your
Mac's environment changes in real time. For details, see Macro Activation

You can try out a macro from the Keyboard Maestro by clicking the E Run button at the top of the editor window. Of
course, macros are often sensitive to the context, so it may not be appropriate to run them directly from the editor.

Generally, you run a macro by invoking any one of its triggers.

You execute a macro’s action sequence by invoking one of its Macro Triggers that you have defined (such as pressing a hot key
if you have configured a hot key trigger). For some triggers, no action is required on your part. For example, the macro could
be triggered at a specific time, or when a specific USB device is attached.

You can also trigger macros by name using the Trigger Macro by Name action, which in turn can be in a macro and triggered

any way you desire.

value is accessible via the ‘%TriggerValue%‘ Text Token).

If the web server is enabled for remote access, you can trigger a macro remotely after logging in using a web browser or the
Keyboard Maestro Control iPhone application. Alternatively, you can use the Remote trigger and trigger your macro using a

You can also trigger a macro using AppleScript or another scripting language (select the “Or by script” entry to display script
code in various languages such as AppleScript or Perl).

Note that the web server needs to be separately enabled in the Web Server preference pane, and all macros are subject to the

restrictions of the Macro Group they are contained in. If the Macro Group is not enabled and active, the macro will not be

available.
How to Import Macros

You may want to import Macro(s) you have downloaded from other sources, like the Keyboard Maestro Forum

[https:/ /forum.keyboardmaestro.com/].

You may use any of the following to import the macro file (. kmmacros):

¢ Double-click on the macro file in the Mac Findet.
¢ In the Keyboard Maestro app, goto File > Inmport Macros Safely. .. and select the macro file.
¢ In some browsers, click on the downloaded file icon at the bottom of the browser window.
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@ Note that the macro file (. kmmacros) may contain one or more macros, and will also create the Macro Group if it does 7oz
exist in your configuration. Otherwise, it will put the Macro in your existing Macro Group.

Import Macros Safely
. You should be aware that the macros will be imported in the same state, triggers, and macro group that they were saved in.
By default, macros are imported disabled unless you hold the Option key down. Importing them disabled is important, because
otherwise this could result in the imported Macro being triggered (executed) as soon as it is imported. If you are at all

uncertain about the source of the macros, ensure you import the macros disabled or choose the File » Import Macros Safely

See also the Macro Groups, Macro Actions, Macro Triggers, Macro_Activation, Macro Examples, Macro Library and

Recording sections.

Macro Triggers

A Macro is executed when any of its Macro Triggers is activated. There are several triggers to choose from, the most common
being a Hot Key, that is a Macro is executed in response to a keystroke, usually in conjunction with one or more modifier keys.
You can also trigger a macro by typing a string. Or you can display a Macro Group as a floating palette, or execute macros

remotely.
Hold the option key down while adding a new trigger to get help on that trigger.

You can also trigger macros by name using the Trigger Macro by Name action, which in turn can be in a macro and triggered

any way you desire.

The Hot Key trigger is perhaps the most common and most basic of all triggers. When you press the configured keyboard key,
the system swallows the keystroke, and Keyboard Maestro executes the macro.

The Typed String trigger is also very common, it lets you execute a macro in response to a sequence of keys like an

abbreviation.

The Global Macro Palette trigger lets you add your macro to a floating palette, so you can trigger it by clicking on the macro

name in the palette.

The Status Menu trigger lets you add your macro to the Keyboard Maestro status menu so you can trigger it by selecting the

macro name from the status menu.

There are many more triggers, and you can learn more about them on the wiki Triggers page.

Macro Actions

A Macro executes a sequence of Macro Actions in order. There are many actions to choose from. Some simple actions, such as
Sleep Computer, require no other information and simply do their job, while other more complex actions, such as Select Menu
Item, require you to specify more information, such as a target application or menu name. You do this by editing the values for
the action.

Keyboard Maestro actions have two very distinct types of fields: text token fields and numeric calculation fields. You can learn
more on the wiki Text Fields page.

There are many powerful Macro Actions available for your use, and you can sequence them together to perform complex tasks.

To add an action, edit your macro, click the New Action button, or equivalently the |+| button below the detail view. This will
show the lists of possible actions.

To see all actions, select the |All Actions| category. To select just your favorite actions, select the category. You can

drag actions into your Favorites category. To see plug in actions that you have added to Keyboard Maestro, select the | Third

Party Plug Ins| category.
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Double click or drag one or more of the actions to add them to the action list for the currently edited macro.

Alternatively, choose the Edit » Insert Action by Name menu and quickly seatch for and add an action by name, or choose
from the Edit » Insert Action by Name menu.

You can drag Macro Groups or Macros into the action list. With no modifiers, this will create an Execute Macro Action or
Show Macro Group action. With the Option key, this will copy in the macro's actions. With Command-Shift, this will create an
Enable Macro Group or Macro action. With Option-Shift, this will create a Mark the Macro action.

You can drag a file into the action list. This will create an Activate Application, Execute Script, or Open File action.

You can use the Engroup or Degroup from the Actions menu to enclose actions in other containers (or remove them from

containers).

You can enable or disable actions by selecting them and clicking the |¥'| button at the bottom of the macro detail view. You can
set the timeout or other options on an action clicking the ¥ | menu at the top right of the action and selecting an option.

You can display more or less detail about some actions by clicking the disclosure triangle. You can disclose all the actions (in a
sublist) simultaneously by option clicking on the disclosure triangle.

You can try the action immediately by clicking the @ button at the top right of the action and selecting Try. Alternatively, you
can try the selected actions immediately by clicking the button at the bottom of the macro detail view.

You can control or right-click on an action to act on it, including pasting other actions above or below it.

You can configure the action using the various menus and text fields, as well as by clicking the ®  button and using the action
menu. This allows you to rename actions, color them, add notes, configure their time out and failure behaviour and more.

The action menu also allows you to get help on the specific action.

You can share an action sequence to the Keyboard Maestro Forum, or to a friend via Mail or Messages using the sharing
button at the top of the Macros window.

You can learn more about the available actions on the wiki Actions page.

Macro Syncing

Keyboard Maestro is licensed on a per user basis on up to five Macs, so if you use it on two or more Macs you may want to
transfer some of your macros from one to the other. You can do this by selecting the desited macros and choosing the File »

Export Macros menu to export your macros, and then importing them on the target Mac.

Alternatively, you may want (almost) all your macros on both Macs, in which case you can set up your macros to sync between
them. This means any change you make on one Mac will be mirrored on the other and vice versa, although you generally
should not edit your macros simultaneously on both Macs.

NOTE: You can only sync between identical versions of Keyboard Maestro. If the sync file is newer than the current
version, you will be warned to upgrade, turn off syncing, or live dangerously (which temporarily disables syncing
and allows you to make changes that will likely cause trouble later).

To do this, you need a file location that is mirrored on both Macs. Dropbox or a similar service is good for this, or you can use
a shared file server, although you must ensure it is available at all times to both Macs.

You are then ready to start syncing your mactos.

!. WARNING: Syncing macros is an all or nothing affair, so any macros on the target Mac before you start syncing
will be lost.

! WARNING: If you make changes on one Mac, and then make changes on the other Mac before syncing has
taken place, you may lose one or other changes. Be especially careful if you are working with your Mac when offline.
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NOTE: Keyboard Maestro references to files or applications that exist on one Mac and not the other will likely cause
problems, so you should ensure any application you reference on one Mac is available at the same path on both Macs.

On the Mac that currently has your macros, choose the File » Start Syncing Macros menu. Read the text carefully, and then
click the button. Save your existing macros in the macro sync file in your shared location. From now on,
Keyboard Maestro will sync any changes to/from that file.

Wiait for the file to be mirrored to the second/target Mac. On that second Mac, choose the File » Start Syncing Macros menu.

Again, read the text carefully, and then click the |Open Existing| button.

!. WARNING: All of the existing macros on this second Mac will be destroyed if you continue. If you have any

macros on the second Mac that you wish to preserve, export them first, and then after syncing is enabled, import them (and
they will then be synced to your other Macs).

Select the mirrored sync file. Your existing macros will be replaced with the macros from your first Mac.
Repeat the process for any other Macs.

If there are some macros you do not want active on a Mac, you can configure any given Macro Group to be disabled on that

particular Mac by turning on the ‘Disabled on this Mac‘ setting in that Macro Group.

Dropbox may keep backup versions, and Keyboard Maestro keeps backup revisions (in the File » Revert Macros menu), so

you should be able to recover from any conflicts that happen. Dropbox may notice a conflict if you edit your macros on both
Macs simultaneously. As a general rule this should not be an issue, though you may lose a change if you make changes on both
Macs quickly (and note that quitting the Keyboard Maestro editor is considered a change).

Since your two Macs will likely not be identical, you may have to adjust your macros to work propetly on both Macs. Using the
various Tokens and Functions can help. For example the %0MacUUID% token is a unique ID for each Mac, and can be used to

behaves appropriately regardless of the details of the Mac.

Note: Only your macros are synced. None of your preferences, clipboards or variables are synced.

Macro Debugger

Keyboard Maestro includes a built-in macro debugger which you can turn on by choosing the Status Menu » Start Debugging

menu or by using one of the Debugger actions. This will display the Macro Debugger window.

(:) B Keyboard Maestro Debugger

V| Pause New Macros

X | Calculate
Prompt for User Input ‘Calculate’

Once debugging, you can control whether new macros start paused or start running;

The macro debugger shows all running macros, and what action they are currently executing (including showing nested

actions).

Using the associated buttons, you can:

4 Eirae-

Continue Pause Step Step Step Cancel
Over In Out
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¢ Continue the macro — allowing it to run until completion, or until it hits a Debugger Breakpoint action.
¢ Pause the macro.

¢ Step Over the current action, including any subactions.

 Step In To the current action, stepping in to any included subaction.

¢ Step Out Of the current action and any other actions at the same level.

» Cancel the macro.

To debug a macro:

e Make sure the “Pause New Macros” is checked.

e Trigger your macro.

* Your macro will appear in the Debug window.

* Click on the icon/button with the down arrow to step into the macro to the first step.
¢ Click again to advance to further steps/Action.

All the debugger actions can also be done via the Debugger actions.

Keep in mind that once a macro has started executing, the engine has taken a copy of the macro to execute, so any changes you
make in the editor will not affect the execution of the macro (although any changes you make to a sub macro that has not yet
started executing would apply).

Also keep in mind that macros can often be time sensitive, so if you find your macro runs fine when stepped through in the
debugger, but not when run normally, the issue is quite possibly that the macro is executing actions like click actions before the
system has caught up and the screen is stable. Add an appropriate Pause action if that is the case.

If you close the debugger window, the paused macros will resume their normal operation.

Variables

Like most programming languages, Keyboard Maestro allows you to create Variables to store data for use later on in the same
Macro, or in other Macros.

Variables can be set from many actions. You can set variables to specific tokenised text, to the result of a calculations, from

and from many other sources.
Scope

Keyboard Maestro includes variables with different breadth or scopes, in order of scope, with broadest scope first:

Scope Availability

Global, Permanent variables | ¢ Accessible basically everywhere, including Scripts.
* You can also see and edit variables in the Preferences.
* You can see global variables in the Value Inspector.

Password, Semi-permanent | ¢ Available to macros but not displayed.

variables * Not directly accessible via AppleScript.

* Concealed in password fields in Prompt For User Input actions.
* Not saved to disk.
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Scope Availability

Instance Variables (v8+) * Restricted to a specific execution sequence.

* Available to the Macro where it was created and Sub-Macros of that Macro, for a given
execution instance of the main macro.

* These Variables are private to each execution of the same Macro, even when running
simultaneously.

* Accessible by Prompt For User Input

* As of v8.0.3, is accessible by scripts (when used in an Execute Script Action).
* Accessible by Custom HTML Prompt (v8.0.3+).
* Accessible by AppleScript with the instance specifier.

Local Variables (v8+) * Restricted to the specific Macro it is in.
* Not available to any of its Sub-Macros
* Same accessibility as Instance Variables.

Dictionary, Permanent, * Accessible basically Everywhere, including Scripts.

global in scope. * Dictionaries consist of the Dictionary Name, One or more pairs of Key Name, and Valne.
* Although Dictionaries are sort of like structured Variables, they are kept in a separate

category called Dictionaries.

Macros can create or read existing variables, which persist and are permanently stored (except Local and Instance variables
which are transient, and Password variables which are never saved to disk).

Variables contain only plain, un-styled, text and may be used in any token text field in an action, as well as in Calculations in a
numerical field. Variable may be used in Calculations if they contain a valid number or expression.

Kinds of Variable
Global Variables

Global Variables are permanently stored on your Mac drive (like a file), and are available for read/write in any Macro or
Action, not just the Macro where the Variable was created. These variables persist between logins and restarts of your Mac.

Variable names must start with a letter, and then can contain letters, numbers, spaces, or underscores. Vatiable names are case
insensitive, but their case is remembered. Variable names should not include a function or operator name with spaces around it
(eg “MOD ”, so “A MOD B” would not be a valid variable, although “MODULE” would be fine).

Password Variables

Variables with names that start or end with “Password” or “PW” are considered passwords — their values will not be stored
(except in memory) and they cannot be read directly by shell scripts or AppleScripts, though their consequences can easily be
extracted, eg with the Set Clipboard to Text action, so you should clear them as soon as they have served their purpose. The
Prompt For User Input dialog will display such variables concealed in a password field.

Instance Variables (v8+)

Variables with names that start with “Instance” (trailing space not necessary) are considered private to a specific execution
sequence. Each time the macro is run, they will start empty but their value can be seen and changed by other macros within the
same execution sequence (for example, if you execute a macro using the Execute Macro action, that macro can see and change

the instance variable). Since two instances of a macro can be running at the same time, this is useful to ensure they each have
their own version of the variable.

Since Local and Instance variables are transient, they are not shown in the Variables preferences pane.

Local Variables (v8+)
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Variables with names that start with “Local” (trailing space not necessary) are considered local to a specific execution of a
specific macro. Each time the macro is run, they will start empty and no other macro will see or be able to change values.

Note that Loca/ and Instance Variables are available in scripts onfy when the script is called in an Execute Script action,
unless you specify the execution instance explicitly.

For a good discussion on the new Version 8 LLocal and Instance Variables, see this Forum topic:
KMS8: Local and Instance Variables [https://forum.keyboardmaestro.com/t/km8-local-and-instance-variables/7946]

Setting Variables

Variables are usually created and set by Macro Actions, but can also be set by scripts. The Action that sets a variable will create

it if need be. Vatiables do not need to be declared in any way.

The most direction Action to set a variable is the Set Variable to Text action.

v X' Set Variable ‘First Name' to Text ‘Johnny’ {:}
Set variable |First Name ¥ Insert Token~
to: | Johnny

You can also use the Set_Variable_to_Calculation action. This action evaluates the numeric expression and then sets the

variable to the result. As with all numeric fields, if you wish to use another variable in the calculation, you use the variable
unadorned, eg VarName * 3.

There are many other actions that set variables.
Using Variables

There are many Macro Actions that can use variables. Some of these explicitly provide for entry of the variable name, but most
provide for a more general text entry that accepts either token text or a numeric expression.

When editing a field:

e Fields that expect text tokens show a small .
e Fields that expect calculations show a small .
* Fields that expect just a variable name show a small .

Variables in Text Fields

Variables can be used in text fields using the %Variable%o token. The %1 ariable’o<VariableName>%o token allows you to

include a variable in the text, where <VariableName> is the name of the variable, and this is replaced by the value of the
variable.

For Example, using the Insert Text Action:

¥ | Insert Text ‘Sally said “Hello” to %Variable%First Nam... {:}

% Insert text by pasting Insert Token~

Sally said "Hello” to % Variable%First Name%

You can also use a short form of just %1 ariable Name% to include variables as long as the variable exists and has a value and
there is no corresponding text token, although generally it is better and clearer to use the longer form %1 ariable%oV ariable
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Nane%.
Variable Arrays

While technically all Variables ate just strings, you can access a variable as if it were an array (v7.2+4) by setting the Variable to a
delimited list of text, and then using the following notation:

$Variable%<VariableName>[<IndexNumber>]%
where

e “<variableName>" is any valid Keyboard Maestro Variable with a delimited set of values.
¢ By default the comma , is the delimiter (see below for setting a custom delimiter).

e “<IndexNumber>" is an integer indicating the index (starting with 1) of the array value within the Variable Array.
¢ This index can be determined using any Calculation, including simply a Variable Name, like i.

* Examples:
® %Variable®myList[i]$%
® %VariablegmyList[3 * i + 2]%

How to Use Custom Array Delimiter
Place the custom delimiter after the closing bracket 1.

¢ For Example: $VariablesmyList1[i]:%, where the colon : is the delimiter used in the Variable Array.
e Of course, the Variable Array, #ylList1 in this case, zust use the same custom delimiter.

Simple Example of Variable Array

» ! ~~~Create a Variable Array ~~~ {:i

v Set Variable “myList” to Text “apples,oranges,pears” ﬁ

Set variable |m~,ﬂLis‘t ¥ Insert Token~

to: | apples,oranges,pears

apples,oranges,pears — apples,oranges, pears
b ! ~~~Select the 2nd Element of the Array ~~~ {:i

v Set Variable “myChoice” to Text “%Variable%myList[... ﬁ

Set variable |myChoice ¥ Insert Token~

to: | %Variable%emyList[2]%

oranges — oranges

Example of Variable Array Using a Variable for the Index



» [X]cALC: SetitoO

& |0

v ﬁ FOR EACH: Cycle through Each Item in List 1

For each |Line ¥ in these collections:
©© 2 Thelinesin:
2 Variable |List1 |~

[ Include blank lines

execute the following actions w

2 CALC: Increment i by 1 Q
v [X|Build Combined List, Using KM Variable Array ¥
Set variable |ListCombined | ~ Insert Token~

to: | %Variable%sListCombined%
%Variable%Line% -- %Variable%ListQ[iﬁ

A\

Use KM Variable "i" as index
to the Variable Array "List2"

For a real-world example, see this Forum post: Combine Two Lists Using Keyboard Maestro Variable Array

[https://forum.keyboardmaestro.com/t/easiest-way-to-align-2-collections /8372 /5]

Variables in Calculation Fields

Variables can be used in calculations if their value holds a number or a numeric expression that can be evaluated. Variables are

used #nadorned in calculations, for example My Variable * 7.

You can also access variables in a token field numerically using the %Calculate% token. It is important to note that

array element, it will convert the element to a number.

Variable Dot Notation

In a Calculation field you can reference the numbers in a variable (which is always a string) using dot notation:

Variable.x x coordinate
Variable.y y coordinate
Variable.left the left coordinate of a rectangle
Variable.top the top coordinate of a rectangle

Variable.right the right coordinate of a rectangle

Variable.bottom | the right coordinate of a rectangle

Variable.width | the width of a rectangle or size

Variable.height | the height of a rectangle or size

Variable.fuzz the fuzz of an image match (rectangle,fuzz)

Variable MidX | the horizontal middle of a rectangle

Variable MidY | the vertical middle of a rectangle

The Variable Name and Dot reference are case insensitive.
Using Variables in Scripts

Variables values can be accessed from scripts you execute with Keyboard Maestro via environment vatiables, and from
AppleScript using AppleScript commands to the Keyboard Maestro Engine, and from web browser JavaScript you execute
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with Keyboard Maestro via the document.kmvar dictionary, see the Scripting section for more details.

You can get and set Keyboard Maestro Variables (Global, Local, and Instance) in these types of scripts:

e AppleScripts

e JavaScript for Automation (JXA)
e JavaScript in Safari or Google Chrome (Get only)

e JavaScript in Custom HTML Prompts
e Shell Scripts (Get only)
e Swift Scripts

use.
Deleting Variables

o Global Variables, including Password Variables, continue to exist (remained stored) until their value is set to "", the empty
string;

e Setting a Variable to $Delete% does nof technically delete it. It continues to exist. It is just bidden from view in all of the
Variable lists and in the Preferences.

e However, a Variable set to $Delete% will behave as if it does 707 exist in most Actions, like a If Then Else Action using a

Variable Condition comparing to exists.

It may be a good idea to set a Variable to "" do if you no longer need it, or if it contains sensitive information (like a password)

or a large value (like a file or web page contents).

Perhaps the best way to avoid variable clutter and eliminate sensitive and/or large values is to use either Loca/ ot Instance
Variables when you do not need the Variable after completion of the Macro in which the Variable is used.

Inserting In Actions

You can add a variable to an action using the Edit » Insert Variable menu or Edit » Insert Function » Variable menu or

Edit » Insert Token » Variable menu, or by selecting from the popup menu next to some variable fields.

Fields that expect just a variable show a small | V| in the field while editing it, and you can use Type Completion to complete
variable names in such fields.

View Your Entire List of Variables

You can add, delete, see or change global variables in the Variables preference pane that have been created by your macros and

scripts. There are no variable preferences to be set here. This is sometimes called the “Variables Panel” or “Variables Tab” in

Keyboard Maestro Preferences.
Local and Instance Variables are nof accessible from either the Preferences Window.
Watching a Variable’s Value

You can use the Value Inspector to watch the value of a global variable.

Tokens

Tokens allow you to add textual information to token text fields. You can tell that a field accepts tokens because a small
shows in the field while editing it.

For example, $SystemClipboards will be replaced by the text in the clipboard.
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You can insert tokens into a field using the Insert Token popup near the field or by choosing from the Edit » Insert Token

menu. You can also start typing a token and use type completion to complete the token. You can insert a token by name by

choosing the Edit » Insert Token by Name menu.

The available tokens are listed on the wiki Tokens page.

Processing

Text token fields also process %oNN% or %NNNN% or %NNNNNNY% as arbitrary hex unicode characters (eg %041% is an
A, %01F300% is © ), and (except for regular expression fields) process backslashed characters \a,\b,\e,\f,\t,\r,\n
(bell,backspace,escape,form feed,tab,return,line feed).

To include a percent in yout text, simply double the petcent (). To include a backslash \ in your text, double the backslash (\\).
In most text fields, you can select (in the BUTTON {{ {0 13} menu) whether to process tokens normally, or just tokens (not
backslashed characters) or do no text processing at all. Alternatively, to include a percent in your text, simply double the
petcent (). To include a backslash \ in your text, double the backslash (\\).

Text Case Conversions

Text token fields also support (v9.0+) text case conversion escapes. The most common use is to change the case of an
interpolated variable or other token, as well as in Search and Replace by regular expression action. The conversion escape

codes are:

¢ \U converts everything up to the next \L or \E to uppercase.
* \L converts everything up to the next \U or \E to lowercase.
¢ \u converts the next character to uppercase.

¢ \1 converts the next character to lowercase.

* \U\1 lowercase first, then uppercase.

e \L\u uppercase first, then lowercase.

* \E stop changing case.

You should not use \u after \U or \1 after \L unless you terminate the sequence with \E first.
Arrays

With tokens that commonly contain arrays of information, you can easily access the individual parts using the token array
notation, eg $Triggervalue[3]% will be the third comma-separated value, and $Triggervalue[3];% will be the third
semicolon-separated value, and $Triggervalue[3] % (note the space between the ] and the %) will be the third space-
separated value (8.0.4+). This currently works with the following tokens:

e TriggerValue

e FrontWindow*

o Window*

e Screen*

* PastClipboard
¢ NamedClipboard
e TriggerClipboard

 CurrentMouse
¢ FoundImage

Calculations

Overview
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Keyboard Maestro supports calculations in almost any numeric t:

s. For example you can Pause for “60*Time in
Minutes”. Calculations can also use comma separated lists of numbers as arrays, and can return such arrays, so you can operate
on rectangle frames and points. Numeric fields often start small with up/down step arrows, but if you type anything other than
a number they will expand to allow a more complex expression to be entered. You can tell that a field accepts calculations
because a small |C| shows in the field while editing it.

Examples

For example:

v [X|Set Variable “Temp” To Calculation “WINDOW(1,Mid... 1§
Set variable Temp =

to: | WINDOW(1,MidX) WINDOW(1,MidY)

1ty —» 2022 591
¥ | X |Use Variable "Temp” to Set the Mouse Location Q
Use variable Temp !

Z to set the mouse location

will result in the mouse being placed at the center of the front window.

Note: You must use commas for this purpose, and full stops (.) for decimal numbers, and never use any thousands separators,
regardless of your desired language.

Expressions

Keyboard Maestro’s expressions include precedence, nested bracketed expressions, many built-in functions, various numeric

bases, so you should be able to write almost any expressions you might like to use, as well as use it as a general purpose
calculator if desired.

Operators

Operators based on precedence from lowest to highest are:

Array Separator (,) Allows a text Variable, which has comma separated values, to work
somewhat like an Array.

Assume MyKMvVariable contains “valuel,value2,value3”, then
MyKMVariable[2] returns “value2”.

Ternary Operator (?) a=b?3:4

Bitwise OR (]), Bitwise AND (&) and Bitwise XOR bitwise operators.

Comparison Operators (<, =, =, >, 2, #) compare for (in)equality and return 0 or 1.

Shift Operators («, ») shift a number left or right.

Arithmetic Operators A mathematical function that takes two operands and performs a
* Add (+) calculation on them.

* Subtract (-)
« Multiply (+)
* Divide (/)

Modulo [https://en.wikipedia.org/wiki/Modulo_operation] | The remainder of the division of i by n.

(i MOD n) Both values (i, n) will be treated as integer.
n must not be 0.
the sign of the result is the same as the sign of 1.

Integer division (i DIV n) (v9.0+) The integer quotient of the division of i by n.
Both values (i, n) will be treated as integer.
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n must not be 0.
the sign of the result matches the sign of regular division.

Power Operator (*) exponentiation.

Unary Prefix Operators (V, -, ( ) ) square root, negation, sub-expressions.
Functions a large variety of functions.

Numbers and Variables or Array Accesses identifiers and values.

(5,$5A,0x50,8#007, Variable, Variable[5])

Unary Postfix Operators (!, %,°)) factorial, percent, degrees.

Numbers are in decimal by default, but may use base 16 if they start with $ or 0x (eg $5A or 0x5A), or may start with a specific
base followed by a # (eg 8#007).

Variables can be used if they contain numeric expressions, including an array of numbers separated by commas, in which case
you can use an array index to select the desired number.

You can use either = or == (v8+) for testing for equality.

Operators and functions must be in uppercase to minimize conflict with variables.
Functions

The available functions are listed on the wiki Functions page.

You can insert a function by name by choosing from the Edit » Insert Function menu or choosing the Edit » Insert

Function by Name menu.

Variables

In numeric calculation fields, Variable Names are used without the % that are used in text token fields. Do not try to use tokens
(like $variable¥MyVar$) in numeric calculation fields, just use MyVar by itself. The vatiable must contain a valid numeric
value, or an expression (v8+) that evaluates to a valid numeric value. So for example, if MyVar contains a text value of 23,
then the calculation 4*MyVar will return 24.

Screen Coordinates

Keyboard Maestro refers to screen coordinates as two or four comma separated numbers in the text of a Keyboard Maestro
Variable (which is always a string).

¢ Screen object points, like the left,top position of a window, have two values, like 12,34
¢ Screen object rectangles, like the frame of a window, have four values 12,34,56,78 (with a fifth value for fuzz in some
instances).
* You can reference these values by position in the string, as it the Variable were an array:
e For example:
if the Variable mywindow is “12,34,56,78”
then all of these forms of reference will provide a value of 34 in a Calculation field:
¢ myWindow|2]
e myWindow.y
e myWindow. Top

Variable Array Access

If a variable contains a sequence of numbers separated by comma (,) then you can access that variable using array notation (eg
MyVar[5]). So if variable MyVar has a text value of 10,20,30,40,50,60, MyVar[5] will return 50.

The index is itself an expression, so it can be arbitrarily complex.
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Indices are 1-based, so MyVar[1] is the first element. If the index is 0, the size of the array is returned (so MyVar[0] would be
6). If the index is less than zero, the array is indexed from the end (so MyVar[-5] would be 20).

Variable Dot Notation

In a Calculation field you can reference the numbers in a Keyboard Maestro Variable (which is always a string) using dot

notation:
Variable.x x coordinate
Variable.y y cootrdinate
Variable.left the left coordinate of a rectangle
Variable.top the top coordinate of a rectangle
Variable.right | the right coordinate of a rectangle

Variable.bottom

the right coordinate of a rectangle

Variable.width

the width of a rectangle or size

Variable.height

the height of a rectangle or size

Variable.fuzz

the fuzz of an image match (rectangle,fuzz)

Variable. MidX

the horizontal middle of a rectangle

Variable MidY

the vertical middle of a rectangle

The Variable Name and Dot reference are case insensitive.

Text Fields

In calculation fields, you can express a calculation as you would normally write an expression, for example:

3 * Count + 7

However in a text field, since any text is allowed, you must use percent encoded tokens to indicate where more processing is
required. You can include a variable in the text by using the % Variable% token, or you can use a calculation by using the

%Calculate% token, or any number of other Tokens.

The result is %Calculate%3 * Count + 7%.

Examples of Variable Data Reference
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Macro Actions

v Set Variable ‘WinFrame' to Text '‘“%WindowFrame%1%’ i:}

Set variable | WinFrame ¥ Insert Token~

to: | %WindowFrame%1%

v -:1 Display Text '--- KM Variable (string) ---..." in Window ﬁ

Z Display text in a window Insert Token

--- KM Variable (string) ---

--- Coordinates are Comma Separated ---

--- Left, Top, Width, Height -

KM Variable “WinFrame": %\Variable%WinFrame%

--- Reference Number by Position ---
[1): Y% Calculate%WinFrame[1]%
[2): % Calculate%WinFrame[2] %

--- Reference Number by Dot Motation ---
X %Calculate%WinFrame. X%

Y: %Calculate%WinFrame.Y%

Left: % Calculate%eWinFrame.Left%
Top: Y% Calculate%WinFrame.Top%
Width:  %Calculate%WinFrame.Width%
Height: % Calculate%WinFrame.Height%

--- Calculate Number by Dot Notation ---
Right:  %Calculate%WinFrame.Right%
Bottom: %Calculate%WinFrame.Bottormn%
MidX:  %Calculate%aWinFrame.MidX%
MidY:  %Calculate%sWinFrame.MidY %

Example Results

[ ] [ ] Keyboard Maestre - Display Text

The text is:

--- KM Variable (string) ---

--- Coordinates are Comma Separated ---

--- Left, Top, Width, Height -

KM Variable "WinFrame": 3067,43,1028,1105

--- Reference Number by Position ---

[ 3067

[2]: 43

--- Reference Number by Dot Motation ---
X 3067

Y: 43

Left: 3067

Top: 43

Width: 1028

Height: 1105

--- Calculate Number by Dot Notation ---
Right: 4095

Bottom: 1148

MidX: 3581

MidY: 5855

OK

Some example expressions might be:

Amount in Dollars * 100

MJID() > 55928

NOW() > TIME(2012,3,23,12,2,1)

DOW(TIME(2012,4,4)) = 4
Radius*SIN(20°),Radius*COS(20°)

Window Frame[l]+Window Frame[3]/2,Window Frame.MidY
MOUSEBUTTON() + 2 * MOUSEBUTTON(4)
SCREEN(Internal,Left,10%)

Conditions

Keyboard Maestro includes a variety of control flow actions which perform actions depending on a set of conditions.

The condition clause of the flow control actions can be any of:



¢ Any of the following are true — at least one condition must be true.

All of the following are true — every condition must be true.
* None of the following are true — no condition is true.

Not all of the following are true — at least one condition must be false.

This is followed by a set of specific conditions. If there are no conditions in the set at all, the action will not execute
anything except the Until action which will execute the actions once. Neither side of the If Then Else will execute.

The available conditions are listed on the wiki Conditions page.

See also the Variables and Calculations sections.

Collections

Keyboard Maestro includes a For Each action which perform a sequence of actions repeatedly, once for each element of a

collection.

Any time you have to deal with a set of things (lines, files, numbers, etc), you are probably thinking of a collection for which
the For Each action is the answer.

The available collections are listed on the wiki Collections page.

Filters

Keyboard Maestro includes a variety of filters that can be applied to either the system clipboard, Named Clipboards, or
variables. For clipboards, the filters preserve style information to whatever degree is possible. Use the Filter action to apply
filters.

The filters are:

¢ Remove Styles (ie, make the clipboard plain text — not applicable to variables).
e Set line endings to Mac, Unix or Windows/DOS.

e Trim Whitespace.

e Hard wrap or unwrap paragraphs.

e Lowercase (all characters), Lowercase First (just the first character).

e Uppercase (all characters), Uppercase First (just the first character).

¢ Capitalize (all words) or Title Case (intelligently uppercase certain first letters).
¢ Change quotes to Smart, Dumb or French quotation marks.

¢ Encode HTML or non-ASCII HTMI, entities.

¢ Quote for AppleScript, JavaScript, Shell (bash) Script, or Swift.

¢ Convert a JSON object string to Compact or Pretty format (v9.0+).

¢ Get the filename component of a path.

¢ Get parent of a path.

¢ Get the basename of the path (ie the name without directory or extension).
¢ Get or delete the path extension.

¢ Get the display name of a path.

¢ Expand tilde (~) paths, or abbreviate with a tilde.

¢ Resolve symlinks, or standardize the path.

¢ Delete or bullet (*) control characters.

¢ Get the value of a named variable or named clipboard.
¢ Count the characters, words or lines and return the result.


https://wiki.keyboardmaestro.com:8443/Conditions
https://wiki.keyboardmaestro.com:8443/action/For_Each
https://wiki.keyboardmaestro.com:8443/Collections
https://wiki.keyboardmaestro.com:8443/action/Filter

We will likely expand the list of possible filters, so if you have specific filtering needs that you think might be of general
interest, please let us know. In the mean time, remember that you can apply scripted filters using an AppleScript or shell script,
for example the shell script:

pbpaste | perl -pe 'tr/A-Z/a-z/' | pbcopy

Dictionaries

Keyboard Maestro includes permanently stored dictionaries that you can use or set.

A dictionary is a named set of mappings from a key name to a value. You can have multiple dictionaries, each with their own
name (so really, it is a set of mappings from a dictionary name and a key name to a value).

Dictionary names start with a alphabetic character, followed by any number of alphanumeric, space or underscores. Dictionary

names are case insensitive.
Key names can be anything, although leading and trailing white space is stripped off. Key names are case insensitive.
Dictionary values are plain text and can include leading or trailing white space.

For example, you might have a dictionary named “Shop Prices”, with keys being the item names and values being the cost of
the item.

Dictionary | Name | Value

Shop Prices | Coffee |3.45
Shop Prices | Cake |5.35
Shop Prices | Drink | 2.50

Setting Dictionary Values

Use the Set Dictionary Value action to set a dictionary value.

Accessing Dictionary Values

You can use the %Dictionary% token to access Dictionary values.

v :| Insert Text “Fred said “hello” to %Dictionary[First Mames,%Vari.." by Pasting {:!
Z Insert text by pasting Insert Token

Fred said "hello” to %Dictionary[First Names,%Variable%Person%]%

You can list the dictionaries with the Dictionaries collection, and you can list all the keys within a dictionary with the

Dictionary Keys collection.

AppleScript

You can read and write dictionary values from AppleScript.

snippet.applescript

tell application "Keyboard Maestro Engine"
name of dictionaries
end tell

snippet.applescript
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tell application "Keyboard Maestro Engine"
dictionary keys of dictionary "First Names"
end tell

snippet.applescript

tell application "Keyboard Maestro Engine"
set value of dictionary key "P" of dictionary "First Names" to "Fred"
end tell

See Also

See also the Set Dictionary Value action, the %Dictionary% token and the Dictionaries and Dictionary Keys collections.

JSON

Keyboard Maestro (v9.0+) includes comprehensive support for JSON |[https://json.org] (JavaScript Object Notation), which is a

formalized lightweight data-interchange format.
JSON objects consist of one of:

¢ An array, surrounded by square brackets and with comma-separated values,eg [ 1, "2", 3, "4" .
¢ A dictionary (aka, object), surrounded by cutly brackets with comma-separated key-value pairs, eg { "one" : 1, "two"
"2" }. The Key must be a propetly formatted, double quoted, string.

¢ A double quoted string, eg "hello". Strings can contain various backslash-escaped characters, including ", /, \, b
(backspace), £ (form feed), n (linefeed), r (carriage return), t (tab), and u followed by four hex digits to make a unicode
character.

¢ true - boolean true

* false - boolean false

¢ null - null (missing or absent value)

JSON terminology refers to dictionaries as “objects”, but also the whole thing as a JSON object, so generally within Keyboard
Maestro it will be referred to as a JSON dictionary when talking about a specific dictionary formatted part of a JSON object,
and object when it could be any of the various forms. A JSON container would be an array or a dictionary.

JSON Paths

Keyboard Maestro introduces the concept of a JSON Path. This is similar to the concept of an XPath, and there are other
similar but unrelated JSON path concepts around, and they have similar intentions, but none of these are the same, or have the

same syntax.
In Keyboard Maestro, for a variable named J, and JSON Path might look like:
J[2+3].fieldname{%Variable%FieldName%}

This would assume that variable | holds a JSON array, and would extract the fifth element. Then it would assume that contains
a dictionary and look for the field named “fieldname”. Within that, it would assume that contains a dictionary and look for a
field named by the variable FieldName.

After the variable name, the format of the path is any of:

e “|” followed by a numeric calculation, followed by “]”. The result of the calculation will be used to look for an indexed
element in the array, or for a matching named element in a dictionary.

o “{” followed by token text, followed by “}”. The result of the text will be used to look for a matching named element in a
dictionary, or for an indexed element in an array.

e “ followed by the field name. Field names are trimmed of leading or trailing whitespace - if your object field names can
start or end with white space, you need to use the { field name } notation.
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Array indices are 1-based. Negative indices count from the end of the array. The 0 index of an array access will return the
count of the number of entries in the array. When evaluating the index, the context sensitive COUNT() function will return the
number of elements in the array.

Keyboard Maestro will use arrays and dictionaries more or less interchangeably, so:

* Ji3
.3

< J3)

will all return the third element of an array, or the dictionary value for key “3”. And important distinction is that the first one is
a numeric calculation, the second one is plain text, and the third one is token text.

Pretty, Compact and Strict Flags

Many of Keyboard Maestro’s operations that produce a result from JSON have two flags associated with them: Compact or
Pretty; Strict or Not-Strict.

e Compact means all extraneous white space is omitted from JSON results
¢ Pretty means JSON results will include white space to format the JSON in a relatively readable manner.

For example, if the variable | contains the text { "a" : 3, "b" : null }, then the result of $JsONValueCompact$J% will
be:

{"a":3,"b" :null}
whereas the result of $7S0NValuePretty%Js will be:
"at : o3,
"b" : null
The exact indentation should not be assumed, it might be any number of spaces or tabs.
The Strict flag relates only to JSON results that are trivial JSON strings, eg JSON "result".

e Strict means even for trivial JSON strings, the result will be a propetly double quoted string (eg "result".

* Non-Strict means that for trivial JSON string results, the result will return just the resulting string without any double
quotes and with any escaping removed/evaluated. This will be more useful in some situations, but will lose the ability to
distinguish between strings, numbers and null.

For example, if the variable | contains the text { "a" : 3, "b" : "hello\n\"there\"\n" }, then the result of
8JSONValueStrict$J.b% will be:

"hello\n\"there\"\n"
whereas the result of $JSONvValue%J.b% will be:

hello
"there"

The Strict/Non-Strict flag will have no affect unless the result is a trivial JSON string - if the result is a JSON object or atray,
or a number or true, false, or null, the result will be the same either way - objects and arrays will be inherently strict, and
numbers and true/false/null will be unadorned.

The default result format is Compact, Non-Strict.

Use



There are actions to set dictionaries or variables from JSON containers, as well as an action to set a field within a JSON object

to a specified value.

Notes

JSON objects must be propetly legal to be processed. In particular keys to objects must be strings, which means strings must
be quoted with double quotes. { a :

3 }is notvalid, it must be { "a" : 3 }.

Although 3 and "a" are technically legal JSON, in Non-Strict mode with cases of ambiguity, Keyboard Maestro will not

consider a value or variable to contain JSON unless it is a container, ie an array or dictionary, which starts (without any leading

white space) with a { or [, and ends with a matching bracket followed by optional white space.

Search Strings

Search Strings are filters which, in addition to the text you type, can include qualifiers that may be applied to searches for

Macros and Actions in:

1. Keyboard Maestro Editor, Search field

2. Keyboard Maestro Editor, Smart Group

3. Trigger Macro by Name Action

Keyboard Maestro will search for the text you type, and all of the below qualifiers that you specify, for matches in your list of

macros. Each word is searched for separately (and in any order) unless you quote a phrase.

Note that the Trigger Macro by Name Action only searches among active macros.

Search Qualifiers:

The qualifier can generally be shorted to its shortest unique name, as shown in the Short Form column.

Qualifier |Short | Definition Example
form
all: al: Match everything al:
(Otherwise the empty search string
matches nothing)
group: or: Match any macro within the named macro group gr:"Forum Examples"
(Use quotes if Name contains spaces)
global: gol: Match any macro within any macro group that is globally gl:
active (aka universal:)
application | ap: Match any macro that is specific to (or excluded from) the |ap:Finder
specified application
enabled: e Match any macro that is enabled e:
(not necessarily active)
disabled: | d: Match any macro that is disabled d:
trigger: t: Match any macro that has a trigger matching the specified |t:;sig
string (Typed String of “;sig”)
hotkey: h: Match any macro with specified HotKey h:¥"C
Match any macro with any HotKey if no HotKey is (CMD CTRL C)
specified.
Modifier Keys must be one of these: *\_{+ 3 h:
(Matches any HotKey)
name: n: Match any macro that has a name matching the specified n:PDF
string
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Qualifier |Short |Definition Example
form

created: cre: Match any macro that was created less that the specified cre:lw
time ago (v8.2.1+)

modified: | mod: Match any macro that was modified less that the specified |mod:1d
time ago (v8.2.1+)

used: use: Match any macro that was used less that the specified time | use:1m
ago (v8.2.1+)

For the created:, modified:, used:, the parameter is a number followed by a letter (s for seconds, m for minutes, h for hours, d

for days, or w for weeks).

You can use a negative sign (-) to negate any match (for example, “-name:PDF”).

Palettes

Keyboard Maestro can display a number of Palettes (or Toolbars).
There are three types of palettes:

1. Global Macro Palette
2. Macro Group palettes
3. Conflict Palette.

4. Applications Palette

Global Macro Palette

Any macro with the Global Macro Palette trigger will be displayed in the Global Floating Palette. This palette appears whenever

there is one or more active macros with this trigger, so it may appear and disappear depending on which macros are active

(remember that Macro Groups control when a macro is active).

Macro Group Palette

Any Macro Group can be configured to display as a palette. Since Macro Groups can be active in specific applications, this can

be used for application-specific palettes.
Conflict Palette

When you use the same trigger (such as a hot key, device key, or typed string trigger) that is assigned to more than one macro,

and all of these macros are active, then Keyboard Maestro will display the Conflict Palette listing the triggered macros and let
you select the desired macro, either by clicking on it or by typing a letter that narrows that palette down until only one macro
remains at which point that macro is triggered.

You can use the Conflict Palette to limit the number of hot keys you need to remember by give a bunch of similar or related

macros the same hot key and then selecting the desired macro with a further keystroke based on the now visible palette.
Applications Palette

The Applications Palette shows the currently running foreground applications.

You can show/hide the Applications Palette in the General preference pane, ot by choosing the Status Menu » Show

Applications Palette menu.

You can drag files on to the palette icons, and you can control click on them to perform various actions like hiding or revealing
in the Finder. You can also hold vatious modifier keys down while clicking to perform the actions.
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Applications can be excluded from the palette by selecting Exclude from Applications Palette in the contextual menu, or by
adjusting the excluded applications in the Exclude preference pane.

You can order the applications alphabetically or by launch date by selecting Sor# by Launch Date in the contextual menu.
Controlling The Display of Palettes

By using the Show Macro Group or Show Macro Group for One Action actions, you can display a macro group as a palette.
This allows you to build nested palettes. For example, a palette could contain a number of macros that simply show different

macro groups.

By using the Mark or Unmark Macro action, you can have macros shown in macro palettes appear ticked to indicate some state
(for example an application dock that marks or unmarks the macro as the application launches or quits). Alternatively, you can
enable and disable macros to have them appear or disappear from a macro palette. Either of these techniques will allow some
level of dynamic behaviour of palettes.

You can control the appearance of the palettes in the Palettes preference pane or in the macro group configuration. You can

choose the style, the opacity of the palette, the size of the entries, the number of columns, whether the entries include the icon,
the text and/or the trigger, the title bar (v8.2.1+), and whether the palette shrinks when the mouse is not over it. You can use
the styling to build palettes that just display their icon for example, and combined with custom icons for your macros this can
create a nice looking icon palette.

Recording

Keyboard Maestro has the ability to create macro action sequences by recording your actions.

For example, to create a macro that simulates keystrokes, rather than create each macro action individually you can enable

recording and then simply type the keystrokes.
Keyboard Maestro can record the following actions:

¢ Moving a window

* Resizing a window

¢ Miniaturizing a window
¢ Clicking the mouse

¢ Typing a Keystroke

* Moving the scroll wheel
¢ Selecting a menu

e Activating an application
¢ Quitting an application

There are two ways you can use recording: when creating or editing a macro, or via a Record Quick Macro action.

When you are creating or editing a macro, with the Macro Editor window displayed, simply click the button. After a
short pause for you to get ready, recording will begin. To avoid the pause, hold the option key down while clicking the
button).

Once recording starts, demonstrate the task you would like to perform using any of the above actions and Keyboard Maestro
will record your actions directly into your macro.

While Keyboard Maestro is recording, it will display the Recording window.

Recording

While you are recording, you can pause the recording by clicking the button in the recording window.




Normally, Keyboard Maestro does not record pauses between actions, so the macro will play back at fast speed. However, you
can add a 0.25 second pause to your macro by clicking the button, or you can option-click the button (v9.0+) to
turn on “real time”, and Keyboard Maestro will record a pause between each action which will simulate playback at
approximately the same speed as you recorded.

When you are finished, click the button again to stop recording, or you can stop all recording by clicking on the

Recording window.

Typically you will need to make a few adjustments to the Macro Actions to ensure the macro will operate robustly when used.
Generally, use recording to create a base sequence of actions and then adjust as necessary.

The other way to use recording is via a Record Quick Macro action. When triggered, the Record Quick Macro immediately
starts recording your actions into a private macro. When you have demonstrated the sequence of actions you want, trigger the
Record Quick Macro action again. The sequence can now be executed via the specified Hot Key or the Status Menu or
Macro Palette. For example, if the Record Quick Macro is triggered by pressing Control-F1, and the specified Hot Key is
Option-F1, then if you typed:

Control-F1, h, e, 1, 1, o, Control-F1

Then each time you press Option-F1, Keyboard Maestro will type “hello” for you. One common use for this is if you want to
adjust a sequence of lines in a systematic way. For example, if you had a list of colors, and wanted to change them in to a list of
constants, say from this:

color Red
color Green
color Blue

to

const int kRed = "Red";
const int kGreen = "Green";
const int kBlue = "kBlue";

You could do this with grep and regular expression, replacing “color (¥)” with “const int k\1 = “\1”;”, which is fine if you can
remember how to do grep with regular expressions, whether it is \1 or $1, and whether the application you are in supports
regular expressions or not. But perhaps a simpler way is to just show Keyboard Maestro how to do the first line and then let it
do the others with a single keystroke each.

So move the cursor to the start of the first line, press Control-F1, then the sequence:
Option-Shift-Right Arrow, Delete, Forward Delete, Command-Shift-Right Arrow, Command-X, c, o, n, s, t,

Finish with Command-Left Arrow, Down Arrow to carefully put the cursor at the start of the next line. Now press Control-F1
again to finish the recording, and Option-F1 twice to translate the next two lines.

Record Quick Macros can record the same set of actions that normal recording can, however because you cannot see or edit
the recorded actions it is wise to keep them simple, preferably just a sequence of keystrokes. Typically, recorded Quick Macros
will be used immediately and not reused, but they are saved and remain available until you record over them.

Macro Library

The macro library is a place where we can provide you with a variety of ready-made macros for optional addition to your
macro collection.

To use the library, choose the Window » Macro Library menu to display the macro library. You can then look through the

available macros and insert any you'd like to use into your macros. You can then use them as is, or configure the new macros,
perhaps changing the hot keys or adjusting the macros to your liking,

Each macro comes with a short description to tell you what it does, so scroll through them to see all the possibilities, and click
on them to get more details.



You can also download new potential macros from us or from friends or colleagues or the forum

[https:/ / forum.keyboardmaestro.com]. You can also share your own macros with other Keyboard Maestro users by exporting your

clever macros.

Keep in mind that macros can do practically anything on your Mac, including cause a huge amount of damage, so you should
never execute a macro without verifying the source and better yet, checking exactly what it does.

You can export a set of macros to a macro library file, which you can share with others, and you can import kmlibrary files
into your macro library. Note that currently there is no way to delete imported macro library entries from your Macro Library

except by quitting Keyboard Maestro and Keyboard Maestro Engine and removing the files from the |~/ Library/Application
Support/Keyboard Maestro/Keyboard Maestro Libraries| folder.

Generally, for macros you want to share, it is better to export them as macros, or use the button at the top the editor
window, or choose from the File » Share menu.

For some other example macros, you can also look at the M on the wiki.

Macro Examples

A typical simple Macro consists of a single Hot Key trigger, such as Control-A, together with a single action, such as the Insert

Text by Typing Action that will “type my address” .

For some real examples, see the forum topics:

e List of Example Macros [https://forum.keyboardmaestro.com/tags/example]

¢ Best Macro List [https://forum.keyboardmaestro.com/t/best-macro-list|

¢ Best Examples of Keyboard Maestro Macros [https://forum.keyboardmaestro.com/t/best-examples-of-keyboard-maestro-

macros|

You can also use the Macro Library by choosing the Window » Macro Library menu to see some built in examples.

Here are a number of example and suggestions for Macros to give you some ideas of how you can get the most out of
Keyboard Maestro and your Mac. For tips on how to remember which Hot Key executes which action, see the Remembering

Macro Hot Keys section.

Launch Your Most Used Applications

Use function keys to launch or switch to your most used applications. For example, you probably often switch to the Finder,
your Email client, your Web Browser, your Word Processor. Consider putting these and other frequently used applications on
function keys.

Open Your Most Used Documents

Use Control-Function Keys to open your most used documents. For example, you might have a documentation file or financial
details file that you access frequently, consider putting these on Control-Function Keys.

Insert Text Templates

Use Control-Letter and the Insert Text action to type in text for you, such as your name, address, phone number, and so on.

Consider restricting these to just the appropriate applications like your Email client or Word Processor by creating a
Macro Group for them. Also consider using Typed String triggers for these sorts of macros, for example “=em="" for email
address and “=addr="" for address. The text you insert can be typed, pasted as plain text, or can be fully styled text.

Use Hot Keys to Open Financial Accounts

If you keep your finances on your computer, then you probably need to open a document every time you enter a bill or receive
a statement. By creating a Hot Key to open the document for you, you can save a few seconds every time — at least it might
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make receiving a bill slightly less unpleasant! If you have multiple accounts (eg personal, business, association) then this can be

even more useful.

Use Hot Keys to Connect to SSH or Web Sites

Simulate Bookmarks

Use the Click Browser Link and Browser Form Actions to open web pages, fill in fields, submit forms, follow links. For

example, you could use this to log in to the city library for all the members of your family, one in each tab, to easily check what
books are due back.

If you are going to use this to enter passwords, use the Set Variable to Keychain Password action to retrieve the password so

that it is not stored in plain text in the macros.
Remap Command Keys

If you find yourself pressing a command key in an application and expecting it to do something but it does not work (for
example, Command-T for “Replace and Find Again”), use a Macro to make the command key “do the right thing” in that
application. Similarly, if you use a function in an application frequently, but it has a convoluted command key or no command
key at all, define your own command key by using a Hot Key to select the menu item.

Keep in mind that you can do some menu key remapping in the System Preferences Keyboard preference.
Simulate Missing Features

If you find yourself missing a feature in one application that you are used to in another application (perhaps you switched email
clients and a feature is missing), see if you can simulate the feature with a sequence of commands and then use a Hot Key for
that. For example, Close Window, Down Arrow, Return to move to next email message, or Command-Left Arrow, Shift-Down
Arrow, Command-C, Down Arrow, Command-V to duplicate a line.

Swap Characters

If you often type characters out of order, use a Hot Key to swap them by first placing the cursor between them and then

executing:

¢ Simulate Keystroke Shift-Right Arrow
¢ Cut to Named Clipboard “Temp”

¢ Simulate Keystroke Left Arrow

¢ Paste from Named Clipboard “Temp”

Save a Text Clipping

If you often want to save snippets of text, you could create a Hot Key to save a clipping:

* Copy

¢ Open File “Clippings.rtf”

¢ Simulate Keystroke Command-Down Arrow

e Insert Text “== %LongDate% %ShortTime% ==<return>"" by Typing
e Paste

* Simulate Keystroke Return

¢ Simulate Keystroke Return

¢ Select Menu Item File » Save

e Manipulate Window Close Front Window

* Switch to Last Application (or Quit Specific Application or Command-Q)
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Delayed Click

Setup a macro which simply pauses for twenty seconds and then clicks the mouse. Then when you need to print on to an
envelope, go all the way through the process, position the mouse over the Print button, execute the Macro, walk over to the
printer, insert an envelope and then take the printed envelope back with you.

Insert Boilerplate Text

If you regularly need to insert boilerplate text (eg copyright or file creation text), use an Insert Text macro to insert the text
quickly and easily. It can even expand tokens to insert the date or other information.

Apply Text Conversions

If you are regularly translating text from one format to another in an automatic process, perhaps you can automate the whole
thing with a macro. For example, converting function declaration in a header file into function definition.

Simulate Workspaces

Create a macro to setup an application to your liking. For example, create multiple tabs in Terminal, each in its own directory,
or open multiple documents in TextEdit, each positioned and sized appropriately.

Setup an Application When Launched

If you always do a set of things every time you launch an application (eg arrange the windows in a particular way), use an
application Macro Trigger to execute a Macro when you launch the application, then have the Macro do the work for you.

Clean Up After Using an Application

If you always do something after quitting an application (eg unmount a server or disconnect from the Internet), use an
application Macro Trigger to execute a Macro when you quit the application. You might need to do a little AppleScripting to

perform the action and then use the Execute an AppleScript action.

Launch Scanner Application When Scanner is Connected

Set up a macro that automatically launches your scanner application when your scanner is connected, and quits it again when
the scanner is disconnected. This works brilliantly with the ScanSnap scanners — open the lid and the scanner software
launches, close it and the scanner software disappears.

Switch Network Location When You Connect

Set up a macro that automatically changes your Network Location when you connect to your home or work wireless network.

Feedback During Macro Execution

A Macro can play a System Beep or use the Speak Text action to speak directly.

You can also use the Alert action to display a window with specified text. This also allows you to stop the macro if you decide
not to proceed.

Icon Chooser

Keyboard Maestro includes an Icon Chooser and creator to allow you to select custom icons for your macro groups and

macros.

You can display the Icon Chooser by choosing the Window » Icon Chooser menu.
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Click on an image well for a macro or macro group (in Edit mode), and then click on an icon in the Icon Chooser to select it.
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The Icon Chooser includes three panes with different icons:

e Internal — all the icons Keyboard Maestro normally uses.
» Applications — all the icons Keyboard Maestro can find on your Mac.
¢ Character — icons you create based on a character.

The Character Icon Choose pane allows you to create your own custom icons by setting a few simple parameters.
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You can set the background and foreground color, shape, and an optional character:
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When you have a Macro or Macro Group icon well selected, and you make any change in the Icon Chooser, or if you click the
icon in the Icon Chooser, then the icon for the Macro/Macro Group will be set.

To load the Icon Chooser from an existing Macro or Macro Group, select the icon well of the Macro/Macro Group and then
open the Icon Chooser (close it first if necessary).

If an icon well is 7ot selected when you open the Icon Chooser, then it will retain the settings that were last used.

Note that icons configured from the Icon Chooser will be very small in storage size in your macros. /4. Icons set any other way

(including copy & paste from another icon) will be zuch larger.
To transfer an Icon Chooser created icon from one macro to another, use this process:

Double click the source icon well.

The Icon Chooser will open and take on the characteristics of the source icon.
e Select the target icon well.
¢ Click on the icon in the Icon Chooser.

Application Launcher

The Activate Application Launcher action is essentially a highly specialized macro action that enables you to launch
applications. By triggering the macro, the Application Launcher enables you to launch any applications in your Applications or
Utilities folder, as well as any recently running applications. Once the launching window appears, you may select the application
to launch, and Application Launcher will launch it for you.

The applications are also listed in the Status Menu, so you can launch applications that way if you prefer.

By default, Keyboard Maestro creates a Activate Application Launcher macro in the “Switcher Group” Macro Group, triggered
by Command-Control-Tab. You can disable this Macro by selecting the Switcher Group, then selecting the

Activate Application Switcher macro and clicking the |V'| button below the Macros list. You can edit this macro to change the
trigger to any other desired Hot Key.

Application Switcher

The Activate Application Switcher action is essentially a highly specialized macro action that enables you to launch, switch,
hide, and quit applications. By triggering the macro, the Application Switcher enables you to switch between all running



applications. Once the switching window appears, you may select the application to activate, and Application Switcher will take

you to it.

The Activate Application Switcher action lets you choose from three themes (vertical list, horizontal icons, or icon grid), as well
as configure the icon size, color tint, and the sort order.

You can also choose to hide other applications when switching (Keyboard Maestro also has a preference in the General

preference pane to always hide other applications when switching).

You can select vatious applications to always be displayed, even if they ate not currently running, perfect for launching
frequently used applications. In the Excluded preference pane, you can configure various applications to never be displayed.

While the Application Switcher window is displayed, you can perform various actions:

«

¢ Press “q” to mark (or unmark) an application to be quit.

¢ Press “k” twice to mark an application to be force quit.

e Press “s” or “h” to mark (or unmark) an application to be hidden.
e Press “I” or “2” to mark (or unmark) an application to be launched.
¢ Press “a” to hide (or show) “always included” applications.

¢ Press “e” to show (or hide) “always ignored” applications.

[13%2]

¢ Press “j” to show (or hide) “recently quit” applications.

¢ Press “c” to select the current application.

¢ Press “f” to select the Finder.

¢ Press “d” to switch directly to the current application and hide other applications.
¢ Press “1” to Get Info on the current application.

¢ Press “t” to reveal the current application in the Finder.

If you click and hold down on any icon, a menu with these options will appear. Using the menu, you can also configure the
switcher to:

e switch just the front window instead of all windows.
 reopen windows when switching,

By default, Keyboard Maestro creates a Activate Application Switcher macro in the “Switcher Group” Macro Group, triggered

by Command-Tab. You can disable this Macro by selecting the Switcher Group, then selecting the
Activate Application Switcher macro and clicking the |V'| button below the Macros list. You can edit this macro to change the
trigger to to any other desired Hot Key avoid replacing the system application switcher.

Window Switcher

Activate Window Switcher is essentially a highly specialized macro action that enables you to show, hide, and minimize
windows. By triggering the macro, Window Switcher enables you to switch between all open windows in the current
application. Once the switching window appears, you may select the window to activate, and Window Switcher will bring it to
the front.

While the Window Switcher window is displayed, you can perform various actions:

[73 ]

e Press “q” to mark (or unmark) a window to be closed.

2
S

¢ Press “s” to mark (or unmark) a window to be minimized.
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By default, Keyboard Maestro creates a Activate Window Switcher macro in the “Switcher Group” Macro Group, triggered by
Control-Tab. You can disable this Macro by selecting the Switcher Group, then selecting the Window Switcher macro and and
clicking the |¥'| button below the Macros list.

Clipboard History Switcher

Clipboard History Switcher saves a copy of each clipboard every time you copy something, You can then paste any previous
system clipboard by triggering the Clipboard History Switcher macro. Clipboard History Switcher will present you with a
window allowing you to select any of the past clipboard and paste them.
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You can press arrow keys to scroll through the clipboatd entties, and return/enter to paste in an entry. Hold the Shift key while
pressing return or double clicking to paste as plain text. You can also drag items around - if a new item becomes the first item,
then it will replace the current System Clipboard - and you can drag text and images out from the clipboard switcher to other
applications.

You can include information about the clipboard entry (index, time copied, size) by toggling the |i| button. Whether the
switcher closes when you paste something is controlled by the |x| button. The switcher honours the text size setting in the
Preferences.

You can mark entries as favorites, in which case they will never be removed from the clipboard history. You can toggle a filter
to show only the favorites in the search field (top right), or by option clicking on the favorites button.

You can use the search field to filter the clipboards.

In the @ | menu in each clipboard entry, you can Paste the item or use it Set the System Clipboard, optionally removing styles
or forcing it as an image. You can also Favorite, Send or Delete the item.

Any active macros that have the Clipboard Filter trigger will be displayed in the @ menu. They can use the Trigger Clipboard
facility to operate on the selected clipboard, allowing you to make macros that apply to any selected clipboard (for example,
save the clipboard to disk, or uppercase it).

You can select multiple entries and paste them as a single unit, or press 8 C to merge them to the System Clipboard. The | %@
menu includes a selection for the separator to include between each item when pasting multiple entires. If multiple images are
selected, merging them creates a single larger image (horizontally or vertically, depending on the separator).

Clipboard entries that resemble passwords are obscured, deleted after they reach position ten in the clipboard history, and not
saved to disk. You can option click on an obscured password to reveal it.

You can send clipboards to another Mac running Keyboard Maestro. The received clipboard entries will appear in the
clipboatd history (assuming the Keyboard Maestro Web Server is enabled on the destination Mac).

Keyboard Maestro keeps a copy of everything you copy automatically each time you copy something. You can exclude certain
applications (for example, badly behaved applications or applications that often have very large clipboards) using the Keyboard
Maestro Excluded Preferences.

You can toggle to the Named Clipboard Switcher by clicking on the Q button.

By default, Keyboard Maestro creates a Clipboard History Switcher macro in the “Switcher Group” Macro Group, triggered by
Command-Control-Shift-V. You can disable the Macros by selecting them in the Macros window pane and clicking the

button.

Keyboard Maestro also has many macros in the Macro Library, such as macros for Paste Plain Text (Command-Shift-V) and

Paste Previous Clipboard (Command-Control-V).

Named Clipboard Switcher

The Named Clipboard Switcher enables you to define any number of named clipboards which can be use to Cut or Copy into
and Paste from in any application. To use the Named Clipboard Switcher you simply trigger the Named Clipboard Switcher
macro. The Named Clipboard Switcher will present you with a window allowing you to select the named clipboard to use.
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You can press arrow keys to scroll through the clipboard entties, or you can use type-ahead to select a named clipboard, and
you can use the search field to filter the clipboards.

You can cut or copy the current selection into the selected clipboard, or paste the selected clipboard into the current selection
(hold down the shift key to paste as plain text).

You can drag text and images out from the clipboard switcher to other applications.

You can include information about the clipboard entry (index, time copied, size) by toggling the |i| button. Whether the
switcher closes when you paste something is controlled by the |x| button. The switcher honours the text size setting in the

Preferences.

In the @ menu in each clipboatd entry, you can Cut, Copy ot Paste to/from the item or use it Set the System Clipboard,
optionally removing styles or forcing it as an image. You can also Rename or Delete the item.

You can select multiple entries and paste them as a single unit. The ¥ | menu includes a selection for the separator to include
between each item when pasting multiple entires.

Any active macros that have the Clipboard Filter trigger will be displayed in the @ menu. They can use the Trigger Clipboard
facility to operate on the selected clipboard, allowing you to make macros that apply to any selected clipboard (for example,
save the clipboard to disk, or uppercase it).

You can toggle to the Clipboard History Switcher by clicking on the Q button.

By default, Keyboard Maestro creates three Named Clipboard Switcher macros in the “Switcher Group” Macro Group,
triggered by Command-Shift-X, C and V (Cut, Copy and Paste). You can disable the Macros by selecting the Switcher Group,
then selecting the macros and and clicking the |¥'| button below the Macros list.

You can add or delete named clipboards in the Clipboards preference pane.

Preferences




The preferences are divided into sections.
General Preferences

In the General preference pane you can:

¢ enable or disable launching the Keyboard Maestro Engine at Login.
e enable or disable macro syncing,
¢ Show or hide the Applications Palette.

* configure whether to detect clipboards that resemble passwords and obscure them.
* configure the light/dark appearance (v9.0+, QS X 10.14+).

¢ configure the default text size used in various places.

e configure whether and how to show the status menu.

* configure the style of the status menu.

e configure whether to include pasting clipboards in the status menu.

* configure whether to include applications in the status menu.

* configure whether to save the recent applications between logins.

e configure whether to save the clipboard history between logins.

e configure whether to only notify about updates when the editor launches.

* configure whether to send diagnostics (crash reports).
Palettes Preferences

In the Palettes preference pane you can adjust the style of the default palette, the Global Macro Palette, the Applications
Palette, and the Conflict Palette.

You can configure the Contflict Palette to be placed under the mouse or to have it remain where you place it.

You can configure the Conflict Palette to include entries in the Touch Bar.
Web Server Preferences

In the Web Server preference pane you can:

e cnable or disable the web server.

* configure the username, password and port of the web server.

e cnable or disable web browser access.

e cnable or disable iPhone access.

e cnable or disable receiving clipboard entties.

¢ enable or disable replacing the current clipboard.

* access the web server in your default browser by clicking on Connect.

The web server is disabled by default.

If the web server and web browsing are enabled, then anyone who can connect to your Mac can execute any macro that has a
Public Web trigger.

If the web server and web browsing are enabled, and if you have configured a username and password, then anyone who can
connect to your Mac and login with the specified username and password can execute any of your macros.

If the web server and iPhone access are enabled, and if you have configured a username and password, then anyone who can
connect to your Mac from an iPhone and login with the specified username and password can execute any of your macros.

If the web server and receiving clipboard are enabled, then anyone can send you clipboards which will appear in your clipboard
history. By default they do not overwrite the current clipboard, but you can enable that to allow the current clipboard to be

directly written remotely.

Macros are still only available when they are enabled and their containing macro group is enabled and active.
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You can configure custom styles using the defaults write command to add a custom style, for example:
defaults write com.stairways.keyboardmaestro.editor WebServerCustomStyles -string 'body { background:

This might be useful if you are controlling multiple Macs and want to differentiate them more clearly.
Clipboards Preferences

In the Clipboards preference pane you can add, remove and rename Named Clipboards and see and change their values.

Named Clipboards store snippets or text or images (or anything the clipboard can hold) and you can copy or paste from them
using the Clipboard Switcher or using appropriate macro actions.

You can paste an image into a Named Clipboard by selecting it in the list and pasting an image (if you select part of the text, it
will paste the image into the styled text, which works but is probably not what you want).

You can also inspect variables and other values in the Value Inspector.

Variables Preferences

In the Variables preference pane you can add and remove variables and see and change their values.

You do not need to create variables, just using them and giving them a value is all that is required for them to spring into
existence. You can also inspect variables and other values in the Value Inspector.

Excluded Preferences

In the Excluded preference pane you can add and remove applications from the global excluded applications list. Excluded

applications will not be shown in the Application Switcher, and are (optionally) not hidden or quit by the Hide All Applications
or Quit All Applications actions.

You can add and remove applications from the Applications Palette exclusion list. Excluded applications will not appear in the

Applications Palette. You can also exclude applications by control or right clicking on them in the Applications Palette and
selecting Exclude from Applications Palette.

You can also add and remove applications from the clipboard history exclusion list. When an excluded application is at the
front, Keyboard Maestro will not automatically record the clipboard history each time it changes. It will still read the current
System Clipboard if you explicitly ask for it in a macro or open the Clipboard History Switcher.

Other Hidden Preferences

immediately, but others may require the editor or engine to be relaunched.
Editor

You can adjust the get mouse location delay with:

defaults write com.stairways.keyboardmaestro.editor MouseGetCountdown -int 5

You can adjust the spelling of Favorites with:

defaults write com.stairways.keyboardmaestro.editor FavoritesDisplayName -string "Favourites"
You can turn off automatic completion (autocomplete) with:

defaults write com.stairways.keyboardmaestro.editor AutomaticCompletion -bool NO

You can limit the maximum undo stack size in the editor with (default 200MB):
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defaults write com.stairways.keyboardmaestro.editor MaximumUndoSize -int 200000000
You can add some custom styling to the detail view displays with:

defaults write com.stairways.keyboardmaestro.editor DetailDisplayExtraStyle -string 'div.ActionComment
You can set your preferred first day of the week (1=Sunday, 7=Saturday):

defaults write com.stairways.keyboardmaestro.editor FirstDayOfWeek -int 2

You can disable all animation in the editor with:

defaults write com.stairways.keyboardmaestro.editor DisableAnimation -bool YES

You can configure the fonts used for the various action text views with:

defaults write com.stairways.keyboardmaestro.editor Font-Normal -string "Monaco"
defaults write com.stairways.keyboardmaestro.editor Font-Shell -string "USER"
defaults write com.stairways.keyboardmaestro.editor Font-AppleScript -string "FIXED"
defaults write com.stairways.keyboardmaestro.editor Font-JavaScript -string "SYSTEM"
defaults write com.stairways.keyboardmaestro.editor Font-Swift -string "Times"
defaults write com.stairways.keyboardmaestro.editor Font-HTML -string "Courier:25"

defaults write com.stairways.keyboardmaestro.editor Font-JSON -string "Marker Felt:10"
defaults write com.stairways.keyboardmaestro.editor Font-Comment -string "Palatino:20"

The value of this field can be one of “USER”, “FIXED” or “SYSTEM?” (for the default user, fixed and system fonts), or a font
name. This can optionally be followed by a colon and the point size. The default point size is 13. The font size is scaled based
on the Large Text setting, and this size is used for the Normal setting.

Clipboard

You can set the maximum number of items in the clipboard history (default 200)

defaults write com.stairways.keyboardmaestro.engine MaxClipboardHistory -int 200

You can set the maximum clipboard flavor size (default 100MB)

defaults write com.stairways.keyboardmaestro.engine ClipboardFlavorMaximumSize -int 100000000
You can set the maximum position of concealed (password) items in the clipboard history (default 10)

defaults write com.stairways.keyboardmaestro.engine MaxConcealedPosition -int 10

You can set a regular expression which matches text you think should or should not be concealed as passwords.

defaults write com.stairways.keyboardmaestro.engine LooksLikePassword -string ""“[a-2zA-Z0-9]+$"
defaults write com.stairways.keyboardmaestro.engine LooksLikeNotPassword -string ""“[a-zA-Z0-9]+$"

Microsoft applications include a PDF flavor with every copy, and starting up the PDF rendering engine is slow, making the first
copy after launching a Microsoft application. Keyboard Maestro (v9.0+) excludes PDF flavors from clipboards copied in
Microsoft applications by default, but you can turn this off with:

defaults write com.stairways.keyboardmaestro.engine ExcludeMicrosoftPDFFlavor -bool NO

Microsoft applications also include flavors for every possible image format with every copy. Keyboard Maestro (v9.0+)
excludes secondary image flavors like BMP when there is a PNG or TIFF flavor available. You can turn this off with:

defaults write com.stairways.keyboardmaestro.engine ExcludeMultipleImageFlavors -bool NO
Engine

You can set the command line tool that is used to execute AppleScripts

defaults write com.stairways.keyboardmaestro.engine OSAScriptCommand -string "/usr/bin/arch -i386 /usr



You can set the AppleScript name of the Safari application, as well as the name of the Safari browser shown in applications:

defaults write com.stairways.keyboardmaestro.engine AppleScriptSafariBundleID -string "com.apple.Safar
defaults write com.stairways.keyboardmaestro.engine BrowserSafariName -string "Safari Tech"

or
defaults write com.stairways.keyboardmaestro.engine AppleScriptSafariName -string "com.apple.Safari"
Similatly for Google Chrome:

defaults write com.stairways.keyboardmaestro.engine AppleScriptGoogleChromeBundleID -string "com.googl
defaults write com.stairways.keyboardmaestro.engine BrowserGoogleChromeName -string "Chrome Canary"

The AppleScript name is used in AppleScript's which control the respective browser in the form of ’tell app “<browser

name>""| Note that the Safari browser must still behave like Safari, and the Chrome browser must behave like Chrome, or the
actions will not work. Do not bother trying to set them to Firefox or something like that as it will not work. All this allows you
to do is select a specific version of Safari or Chrome respectively.

You can disable all animation in the engine with:

defaults write com.stairways.keyboardmaestro.engine DisableAnimation -bool YES

You can disable Shift-Space from clearing the Typed String buffer

defaults write com.stairways.keyboardmaestro.engine TypedStringResetWithShiftSpace -bool NO
and you can disable clicks from clearing the Typed String buffer

defaults write com.stairways.keyboardmaestro.engine TypedStringClearWithMouse -bool NO

and you can set the idle time for clearing the Typed String buffer (default 5 seconds)

defaults write com.stairways.keyboardmaestro.engine TypedStringClearTime -float 5.0

You can force Keyboard Maestro to simulate keystrokes only as Unicode characters, rather than typing them as you would on
the keyboard

defaults write com.stairways.keyboardmaestro.engine ForceInsertTextByTypingToUseUnicode -bool YES
You can set the maximum key down trigger time for Hot Key triggers (default 10 seconds)

defaults write com.stairways.keyboardmaestro.engine MaxKeyRepeatTime -float 10.0

You can silence the clipboard transfer sounds with:

defaults write com.stairways.keyboardmaestro.engine SilenceClipboardSounds -bool YES
And you can silence the recording sounds with:

defaults write com.stairways.keyboardmaestro.engine SilenceRecordingSounds -bool YES
You can adjust the recording delay with:

defaults write com.stairways.keyboardmaestro.engine RecordingCountDown -int 5

Note: you can option click the Record button to avoid the delay.

You can have the conflict palette use sequential hot keys from the first letter with:

defaults write com.stairways.keyboardmaestro.engine SequentialConflictPalette -bool YES
You can configure the timing of a “tap” (Hot Key and USB Device Key triggers) with:

defaults write com.stairways.keyboardmaestro.engine MaxTapDownTime -float 1.0
defaults write com.stairways.keyboardmaestro.engine MaxTapUpTime -float 1.0



The default allowable down time is the double click interval, and the default allowable up time is twice the double click interval.

You can set configure whether the Status Menu includes the Paste submenu and how many items it includes with:

defaults write com.stairways.keyboardmaestro.engine StatusMenuIncludePaste -bool NO
defaults write com.stairways.keyboardmaestro.engine StatusMenuPasteCount -int 30

You can set configure Display Large text color and display period with:

defaults write com.stairways.keyboardmaestro.engine DisplayLargeTextColor -string "502033"
defaults write com.stairways.keyboardmaestro.engine DisplayLargeTextDisplayPeriod -float 5.0

By default recorded clicks do not restore the mouse location, but you can change that with:
defaults write com.stairways.keyboardmaestro.engine RecordedClickRestoresMouseLocation -bool NO
You can control which notifications are displayed with:

defaults write com.stairways.keyboardmaestro.engine "Notification-Information" -bool NO
defaults write com.stairways.keyboardmaestro.engine "Notification-MacroExecution" -bool NO
defaults write com.stairways.keyboardmaestro.engine "Notification-MacroCancelled" -bool YES
defaults write com.stairways.keyboardmaestro.engine "Notification-ActionFailed" -bool YES
defaults write com.stairways.keyboardmaestro.engine "Notification-ReceivedClipboard" -bool YES
You can have new versions reported only when the editor activates with:

defaults write com.stairways.keyboardmaestro.engine ReportUpdatesWhenEditorActivates -bool YES
You can enable the WebKit inspector with:

defaults write com.stairways.keyboardmaestro.engine WebKitDeveloperExtras -bool YES

Then you can control-click on elements and use Inspect Element and get an inspector window, including a Console tab.
Custom Palette Theme
You can configure a custom palette theme color style with:

defaults write com.stairways.keyboardmaestro.engine CustomPaletteTheme -string "0,90,74, 110,90,74,

The style includes 3 or 6 HSB colors (being background, text, highlighted letter, selected background, selected text, selected
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highlight letter) each specified as hue,saturation,brightness. The background brightness is dropped by 33%, but if there are only

three colors, then the selected background color is the background without the 33% drop. You can select the Custom style in
the Theme Editor.

Alternatively (v9.0+), you can specify the theme using JSON and including all the details fo the theme including optional
gradients. The format is:

"IncludeTexture" :<BOOLEAN>,
"TitleBackground" :<COLOROrGRADIENT>,
"TitleBorder" :<COLOROrGRADIENT>,
"BodyBackground" : <COLOROrGRADIENT>,
"BodyBackgroundSelected" : <COLOROrGRADIENT>,
"Frame" :<COLOR>,

"TitleText" :<COLOR>,

"Text" :<COLOR>,

"TextHighlighted" :<COLOR>,
"TextSelected" :<COLOR>,
"TextSelectedHighlighted" :<COLOR>,

Type Value
<BOOLEAN> “true” or “false”
<COLOR> an array of three numbers, being hue (0-360), saturation (0-100), and brightness (0-100)




Type Value

<COLORotGRADIENT> | cither a <COLOR> or a dictionary {“c1”:<COLOR>, “c2”:<COLOR>, “angle”:<0-360>}

IncludeTexture specifies whether Keyboard Maestro includes the subtle mottling texture on the main background.
For example:

defaults write com.stairways.keyboardmaestro.engine CustomPaletteTheme -string '({
"IncludeTexture":false,

"TitleBackground":{"cl1" : [180,30,53], "c2" : [180,30,40], "angle":270},
"TitleBorder":[180,30,40],

"BodyBackground":{"cl" : [180,30,50], "c2" : [180,30,38], "angle":270},
"BodyBackgroundSelected":[180,30,60],

"Frame":[180,30,40],

"TitleText":[180,40,92],

"Text":[180,40,92],

"TextHighlighted":[180,40,70],

"TextSelected":[180,40,98],

"TextSelectedHighlighted":[180,40,75],

3

NoteL the “-string” is important - otherwise the defaults command will interpret the JSON itself and that will not work.
Scripting
Executing Scripts

The following Execute Script Actions are provided to execute a variety of script languages:

¢ Execute an AppleScript

e Execute an Automator Workflow

¢ Execute a JavaScript For Automation

¢ Execute JavaScript in Custom HTML Prompt

e Execute a JavaScript in Browser

e Execute a Shell Script

¢ Execute a Swift Script
e Apply a BBEdit Text Factory to the Clipboard

You can specify the script to be executed either by reference to a file or as text entered directly in the Execute Action. After
pasting or typing script text into the Execute Script Action, press the Enter| key to compile and format the script.

For example, the Execute_an_AppleScript Action:

There are two setup options:

Setup Option | Choices
(Default shown first)

Script location | Execute text script (type or paste script into Action text field)
Execute script file (This is faster if it is a compiled script file . scpt)

Script Results | Ignored.

Displayed in a floating window.

Displayed briefly in a Notification.

Typed in the current text field that has focus.

Pasted in text field that has focus.

Saved to a Keyboard Maestro Variable.

Saved to the System or Named Clipboard.

Ignore Results and run Asynchronously (the script runs while the macro continues on to the next Action.)
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Getting Script Results

The results of scripts can be displayed, or they can be typed or pasted in to the current application document, or saved into a
Keyboard Maestro Variable or the System Clipboard. This allows you to insert text that depends on many factors, such as date
calculations, file listings, SQL queries, web pages, or anything else you can imagine. Alternatively, the results can be displayed in
Notification Center, in a window, or in large type across the screen. Ot you can ignore the results, or execute the script
asynchronously, leaving it running in the background.

Using the Clipboard

You can also read and set the clipboard in a script, although the easiest way to set the clipboard to the results of a script is to
select the Execute Script Action option to “save results to clipboard”. This works on/y for plain text returned by the script. For
more complex formats, you will need to set the Clipboard directly in the script.

For more information about using the Clipboard in scripts, see:

o AppleScript Clipboard Commands suite

[https://developet.apple.com/library/mac/documentation/AppleSctipt/ Conceptual / AppleScriptlLangGuide/reference/ ASLR _cmds.htr

e Shell Scripts Pasteboard Commands: pbcopy, pbpaste

[https://developet.apple.com/legacy/library/documentation/Darwin/Reference/ManPages/man1/pbpaste.1.html]

Automating Applications and Adding Functionality to Keyboard Maestro

AppleScripts, JavaScript for Automation scripts, Shell scripts, and Swift scripts, give you a powerful way of adding new facilities
we have not specifically provided for, as well as controlling other applications.

Web Page Interactions

The Execute a JavaScript in Browser actions enables deep control over a web page, as well as extracting specific data from both

Shell Scripts

Shell scripts can execute any installed scripting language, such as perl, python, ruby or whatever. Be aware that because shell

scripts are executed in a non-interactive shell, typically none of the shell configuration files (like ‘.login‘ or ‘.proﬁleb will be

executed, which may change the way the shell script behaves.

Variables can be accessed from shell scripts via the environment variables in the form $KMVAR_Variable_Name where

KMVAR_ is prefixed, and spaces are converted to underscores. AppleScripts can also access the environment variables using

the |system attribute| command, but note that |system attribute| is not safe for international characters.

Note that the total size of the variables stored in the environment is limited to 100K, so larger variables may be excluded to
ensure the variables do not take up excessive amounts of environment space since this is limited by the system.

Variables whose names start with “ENV_" override regular environment variables (eg “ENV_PATH” overrides the regular
“PATH” environment variable).

AppleScript

AppleScripts can perform many tasks on the Mac and control many applications.

You can read and write variables, dictionaries and control the Keyboard Maestro engine with AppleScript:

tell application "Keyboard Maestro Engine"
set calcResult to getvariable "Calculation Result"
-- If the Keyboard Maestro Variable does not exist, the AppleScript Variable will be set to empty st

setvariable "Calculation Result" to (calcResult + 10)
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-— If the Keyboard Maestro Variable does not exist, it will be created
end tell

For AppleScripts compatible with prior versions of Keyboard Maestro, see Using AppleScript prior to version 7.1.

JXA
JavaScript for Automation (JXA) can access Variables with:

var kme = Application("Keyboard Maestro Engine");
var oldvalue = kme.getvariable('Calculation Result');
kme.setvariable('Calculation Result', { to: 10 });

For details on JXA, see JavaScript for Automation. This provides an introduction to JXA and comparison with AppleScript.

JavaScript

JavaScript in web browsers can access the variable values by using the document.kmvar dictionary, like
document.kmvar.Variable_Name (spaces are converted to underscores), but they have no way to write values back to variables,
except by returning a result from the script.

User Interaction

AppleScripts and JavaScript For Automation scripts are executed in the background via . This means they are not
allowed to do user interaction. You can work around this by asking an application like System Events to do the user interaction
for you, for example:

tell application "System Events"
activate
display dialog "Hello"

end tell

The tool will execute in 64-bit mode, which may be a problem if you have old versions of AppleScript extensions
installed. However, you can set the command line tool that is used to execute AppleScripts as described in C

Preferences.

Controlling Keyboard Maestro Engine via Scripting

The primary scripting interface to Keyboard Maestro Engine is the Keyboard Maestro Engine’s support. You can ask
Keyboard Maestro Engine to:

e execute a macro by name
¢ execute a macro by unique ID
e cxecute an action given its XML code

Note in most cases you must tell “Keyboard Maestro Engine”, not “Keyboard Maestro”.
The easiest way is to use the name, for example:

tell application "Keyboard Maestro Engine"
do script "[Name of Your Macro]"
end tell

The macro must be defined and enabled, and the macro group must be enabled and currently active.
If there is more than one macro with the same name, you will get an error, so you can use a UID instead of a name.

tell application "Keyboard Maestro Engine"
do script "DOC150C7-8A0C-4837-918A-427E2BCFB6B9"
end tell
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The will not return until the macro is finished executing;

An even more powerful way to script Keyboard Maestro is to execute specific actions based on their XML code. This allows
you to construct any action, including changing the action on the fly, without having to create a macro first. A simple example
would be:

tell application "Keyboard Maestro Engine"
do script "<dict><key>MacroActionType</key><string>SwitchToLastApplication</string></dict>"
end tell

The easiest way to determine the appropriate XML is to create an example action in an example macro and then choose Copy

as XML in the Copy as sub-menu in the Edit menu.

You can read information about the existing macros using the ‘gethotkeys and ‘ getmacros‘ commands. See the Keyboatd

Maestro Engine AppleScript dictionary for more information.
Using Keyboard Maestro Facilities from AppleScript

Keyboard Maestro Engine makes several of its facilities available to AppleScript.

You can ask it to play a sound with:
tell application "Keyboard Maestro Engine"

play sound alias "Harddisk:System:Library:Sounds:Glass.aiff"
end tell

You can ask Keyboard Maestro Engine to perform a calculation for you with:

tell application "Keyboard Maestro Engine"
set n to calculate "JULIANDATE()"
end tell

You can ask Keyboard Maestro Engine to find strings in other scripts:

tell application "Keyboard Maestro Engine"
count found in "The Source" for ".e" with regex
end tell

And you can search and replace with:

tell application "Keyboard Maestro Engine"
search "3+4" for "(\\d+)" replace "%CalculateFormat%CALCULATE(\\1l)%Currency%" with regex and
end tell

Controlling Keyboard Maestro via Scripting

Macro Groups, Smart Groups, Macros, Triggers, Actions are all available via AppleScript. So you have deep control over
controlling the Keyboard Maestro editor itself, allowing you to automate creating macros in a variety of different ways.

You can disable or enable a Macro Group (or similarly Macro) from AppleScript with:

tell application "Keyboard Maestro"
set enabled of macro group "Macro Group Group Name or UID" to true/false
end tell

Alternatively you can use the Set Macro Enable action.
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You can rename, create, delete, duplicate macro groups and macros. You can add and remove actions. You can get or set the

selection.

You can start editing a Macro or Macro Group from AppleScript with:

tell application

"Keyboard Maestro"

editMacro "Macro/Macro Group Name or UID"

end tell

See the Keyboard Maestro AppleScript dictionary for more information.

Controlling Keyboard Maestro Engine via Scripting

You can adjust Keyboard Maestro Engine windows with:

tell application

set bounds of window "Clipboard History Switcher" to {1000,

end tell

"Keyboard Maestro Engine"

URL Schemes

Editor

50, 2000, 1200}

Description

keyboardmaestro:

//u=support%40stairways.com/s=ABCDEFGH0123456789

enter your username/serial number.

keyboardmaestro:

keyboardmaestro:

//m=Activate%20Application%20Switcher
//m=D2F427A1-51E3-4719-820B-4C25B6FF7329

edit a specific macro or macro group.
You may used either the Macro Name, or
UUID.

keyboardmaestro:

//g=Activate

filter macros with this keyword.

keyboardmaestro:

//g=All%20Macros/g=Activate

select a macro group and filter macros

with this keyword.

keyboardmaestro:

//a=Execute

filter actions with this keyword.

keyboardmaestro:

//c=A11%20Actions/a=Execute

select action category and filter actions
with this keyword.

Triggers

kmtrigger://macro=<Macro Name or UUID>[&<Trigger Value>]

where

e <Macro Name or UUID> is either the Macro Name, OR, its UUID

e <Trigger Value> is the optional Trigger Value

e [ ] are notincluded. Used only to show gptional parameters

¢ & must precede the Trigger Value, if it is provided.




Example Trigger URL Command Description
kmtrigger://macro=Your$20Macro%20Name Using the Macro Name
kmtrigger://macro=224AA8CB-07EB-4C92-8201-68FED82B6EIF Using the Macro UUID
kmtrigger://macro=Your%20Macro%20Name&value=Your%20Triggers20Value Using Macro Name with Trigger
Value
kmtrigger://macro=224AA8CB-07EB-4C92-8201- Using Macro UUID with Trigger
68FED82B6E9F&value=Your%20Trigger%20vValue Value

from remote locations via the Keyboard Maestro trigger server.

Status Menu Icons

Keyboard Maestro allows you to select the status menu icon.

The current lovely status menu icons were done by Iconaholic [https://www.stairways.com/action/linkthruPiconaholic], and you can

also use the Classic finger tapping icons. As well as that, you can get more status menu icons from our web site

[https:/ /www.stairways.com/action/linkthru?getmorestatusmenuicons] or the forum

[https:/ /forum.keyboardmaestro.com/c/statusmenuicon] and you can create and optionally contribute your own versions. You can

drop a new status menu icon .zip archive on the Keyboard Maestro application dock icon to install it.

The format is fairly simple, you need a folder with the name of the icon (which must be unique relative to other contributed
icons), and in that folder you have a sequence of files named Statusltem and then then the animated sequence Statusltem1,
Statusltem2, etc. You can have as many as you like. If the icon is a template icon (black and clear only), then add the word
“Template” to the name. And finally the extension can be ecither .tiff or .png, The file should be either a 16X16 icon, or ideally
a retina tiff file with both a 16X16 and 32X32 at 144dpi (you can create the retina-ready tiff files using tiffutil -cathidpicheck, or
you can use a tool like Opacity.app).

The two default icon folder structures look like this:

¢ (lassic

o Statusltem.tiff

o Statusltem1.tiff

o Statusltem?2.tiff

o Statusltem3.tiff

o Statusltem4.tiff

o StatusItem5.tiff

o Statusltem6.tiff
¢ Iconaholic

¢ StatusltemTemplate.tiff
Statusltem1Template.tiff
StatusItem2Template.tiff
StatusItem3Template.tiff
Statusltem4Template.tiff

Note that the “Template” appears at the end, after the animation index, and there are no spaces anywhere. You can have spaces
in the folder name.

Then you archive the folder into a zip file named NameStatusMenulcon.zip (eg ClassicStatusMenulcon.zip) and drop it on the
Keyboard Maestro application dock icon or email it to us [mailto:mailto:support@stairways.com] with a cover letter indicating your

Plug In Actions
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Keyboard Maestro has support for user written and contributable plug in actions. You can get more plug in actions from our

web site [https:/ /www.stairways.com/action/linkthru?thirdpartyactions] or the forum [https://forum.keyboardmaestro.com/c/plugin]

and you can create and optionally contribute your own. You can drop a new plug in action .zip archive on the Keyboard
Maestro application dock icon to install it (note that to update a plug in action you must manually remove it from the

~/Library/ Application Support/Keyboard Maestro/Keyboard Maestro Actions| folder before re-installing it).

A Third Party Plug In Action consists of a folder with a name (which should generally closely match the action name), and

actions. The folder name is stored in the Keyboard Maestro Macros.plist to reference the plugin action.
The folder contains a set of files, including:

¢ Keyboard Maestro Action.plist — an XML file describing the action.

extension. It may be a shell script or an AppleScript. If it is a shell script, it will be made executable automatically.
¢ An optional 64X64 png icon.

The format of the Keyboard Maestro Action.plist is a Cocoa property list containing a dictionary with the following keys and

values:
Name the name of the action (which appears in the Category/Actions list)
Script the name of the script, made up of only ASCII alphanumerics or underscores, plus an ASCII alphanumeric
extension
Icon the name of the icon png file, made up of only ASCII alphanumerics or underscores plus .png
[optional]
Title the title displayed on the action, which can include %Param%XYZ% tokens. It should usually not include
[optional] other tokens. If it is missing, the Name will be used
Timeout the default timeout in seconds. Set it to 0 if the action needs no timeout. The default is 99 hours
[optional
numbet]
Author the author of this action
[optional]
URIL, a URL, for the author or this action
[optional]
Help a short (Tool Tip) explanation of this action
[optional]
Results what to do with the output of the script if any. Possible Values: None, Window, Briefly, Typing, Pasting,
[optional] Variable, Clipboard — multiple values can be used, seperated by a bar (|), the first specified value is the default
Parameters | an array of parameters to the script, each entry is a dictionary as described below
[optional]

Each parameter in the Parameters array is a dictionary with the following keys:

Label the name of the parameter. The same rules as Keyboard Maestro Variable Names apply. The label is displayed
to the user and used to pass the parameter to the script. Obviously, the label must be unique amongst all
parameters

Type the type of the parameter. Possible Values: String (single line), TokenString, Calculation, Text (multi-line),

TokenText, Checkbox (0 or 1), PopupMenu or Hidden. The Type specifies how the value is displayed to the
user and what processing is applied before it is passed to the script. Hidden types ate text token processed, but
are not displayed in the editor

Default the default value when the action is created
[optional]

Menu the values of the popup menu, separated by |
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[required if
Type is
PopupMenul]

Warning: Keys are case sensitive.

Parameters are passed to the script via environment variables with names starting with KMPARAM__ similar to how variables
are passed to shell scripts with the Execute Script action. So a parameter named “My Text” would be in an environment
variable KMPARAM_My_Text. You can access the envirnment variables from AppleScript with |system attribute
“KMPARAM_My_Text”|. Note that AppleScript’s is not safe for international characters, although can use
code like:

set myText to do shell script "echo $KMPARAM My Text"

In normal use, once a plug in action is read, it will stay in memory and changes will not be noticed (although the script will be
executed each time, so changes to that will be noticed). To cause the editor and/or engine to notice changes to the plug while
in development, use AppleScript to reload the macros:

tell application "Keyboard Maestro" to reload
tell application "Keyboard Maestro Engine" to reload

Keyboard Maestro Plug In Actions go in the |~ /Library/Application Support/Keyboard Maestro/Keyboard Maestro Actions
folder.

If the Plug In script fails, the action will fail (v9.0+), potentially aborting the macro.
Windows

Welcome Window

This window welcomes new users and gives you some options for learning about Keyboard Maestro.

@ Welcome to Keyboard Maestro

soe # Wiytosad Marslrs Reifun: — P Subaction viva Lis | Appiication

Save to Clippings

ny of the following:

actions:

Quick Start

Learn about the components
of Keyboard Maestro and how
they work together.

Learn more »

e ha ME Kepsreion

& Acthain Last Azplcaiion

= 3 Troe e MY irpticki

=00 - -

, Acthatn Last Asplcation

@+ = + =l + Il e ¥

r

Welcome to Keyboard Maestro 9

The best way to get to know Keyboard Maestro is to see it in action.

If you're new to Keyboard Maestro, try the Tutorial to see how you can

create a simple macro in just a few steps. Assistance
Immediately solve problems or

. get more support options.
Start Tutorial
Learn more »

Show this window when Keyboard Maestro opens




If you are new to Keyboard Maestro, start the tutorial and Keyboard Maestro will walk you through creating a simple macro.
Macros Window

This window lets you manipulate Macros and Macro Groups, creating new ones, deleting old ones, enabling and disabling
them, editing them and so on.

You get this window pane by launching Keyboard Maestro.

[ ] [ ] = Keyboard Maestro Editor — Type Clipboard
th 3 < ® > a-
Share Used History Modified Run Search
Groups A J Macros v

& All Macros [ Lowercase Eritter |
@ Enabled Macros B open in BBedit CIFilter T Type CIl pboard

Acorn @ Paste Plain Text GV

BBEdit Paste Pravious Clipboard "3V = = .
8™ _ b ) . Triggered by any of the following:

Clipboard Filters '@ Paste Selection Into... OEEC ~

clpbonr = The Status Menu

Finder G- Uppercase BFiter [l The exact case string “=-=" is typed (then

Global Macro Group

deleted)

Switcher Group

And 3 Disabled Groups

Will execute the following actions:
T Insert Text by Typing
| %SystemClipboard%

&+ - v + - v Edit ?

The window contains a list of Macro Groups and their associated Macros.

You can create a new Macro Group by clicking the |+| button below the Groups list.

You can create a new Macro by selecting a macro group and then clicking the |+| button below the Macros list.
You can see the selected Macro Group or Macro in the right hand column, and edit it by clicking the Edit button.

You can select the All Macros meta-Group to show all Macros, and you can use the search field to filter down the list of
macros.

You can rename a Macro Group or Macro by double clicking it and changing the title.

You can delete a Macro Group by selecting it and clicking the B button below the Groups list.

You can delete a Macro by selecting it and clicking the B button below the Macros list.

Similarly, you can enable or disable Macro Groups or Macros by clicking their respective |V | button.
You cannot delete, rename or modify the Global Macro Group.

See also the Macro Groups, Macros and Macro Editor Window sections.

Tutorial

If you are new to Keyboard Maestro, start the tutorial by clicking the button in the Welcome window or by
choosing the Help » Tutorial menu and Keyboard Maestro will walk you through creating a simple macro.




=/ Keyboard Maestro Editor — Untitled Macro
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Follow the instructions. Keyboard Maestro will hilight the location of the various buttons to help you quickly create a macro.
You can even use the tutorial as a wizard to create a hot key triggered macro to perform any of Keyboard Maestro’s many
actions.

Macro Group Editor

To edit a Macro Group, select it and click the Edit button. Its details will be shown in the right hand column. You can edit its
name, control which applications it is available in, and how it will be activated.

eCe #/ Keyboard Maestro Editor — BBEdit
Ul < ® Q-
Share Used History Modified Run Search
Groups A J Macros v
& All Macros @ Duplicate Line Mone 5
B BEEdit
# Enabled Macros @ Format HTML Mone

Acorn & Uppercase Line MNone

€ Enable Macro Group :
I

) . & Available in these applications:
Clipboard Filters

Clipboards 0 ° < BBEdit
Finder < Available in all windows
Global Macro Group 2 Shows a palette until:

Switcher Group
) The hot key Click v is pressed.
And 3 Disabled Groups

The corresponding status menu entry is selected.
The corresponding macro palette entry is clicked.

Palette Style

@+ - v + [_Edit ] ?

Typically a group’s macros would be available everywhere (available in all applications), or it might be specific to a particular
application (available in the following applications) in which case you might name the Macro Group after the application.

You can also configure the macro group to be activated only after a Hot Key press (either for a single use or toggled on and
off), and whether to display the macros in a floating palette.

See also the Macros section.



Macro Editor Window

To edit a Macro, select it and click the Edit button. Its details will be shown in the right hand column. You can edit its name,
add or remove triggers, and configure its action list.

o ® +4 Keyboard Maestro Editor — Delayed Click
th % < @ > Q-
Share Used History Modified Run Search
Groups A 4 Macros v
& All Macros e Activate PCalc Mone
’ Delayed Click
& Enabled Macros b Delayed Click Palette % Y
Acorn Process Sallaries U . -
) i ) _ Triggered by any of the following:
g BBEdit @ Quick Macro for CF1 ~F1
Clipboard Filters Save Clipboard to Disk  Menu o ° < The global macro palette entry is clicked.
Clipboards @ Save to Clippings F2 This macro will be listed in the global floating
Finder @ Search the Web AOG palette and will execute when the entry is clicked.
Global Macre Group T@ Set Front Window Size... MNone 2 Or by script.
Switcher Group @ Set Front Window Size... None Or via the web server for public, authenticated, and i0S access.

And 3 Disabled Groups 38 Trigger Macro by Name ~"CHT ; . X
Will execute the following actions:

[} Type Your Name AN
3£ untitled Macro F2 » (1) Pause for 20 Seconds {‘}
> E Move and Click at (0,0) from the Current Mouse Loc... Q
© New Action
® + tol [+/—}v] 1of12 + BT 1 | Record ?

To add a trigger, click the green |®| button and select the type of trigger. To remove a trigger, click the red |©| button.

29>

To see how to execute this macro via a script, select from the “Or by script’” menu. How you can execute the macro remotely

is also displayed.

To add an action, click the New Action button, or equivalently the |+| button below the detail view. This will show the lists of
possible actions. Double click one or more of them to add actions to the action list for this macro.

You can also Copy and Paste actions, as well as drag them around to rearrange them. Use the B button and |¥'| button to delete
or enable/disable the selected actions.

You can try the selected actions by clicking the button.
You can click the button to record your actions.

To learn more about creating or editing Macros, see the Macros section.

Macro Library Window

This window contains example and template macros you can add to your macro collection. You can use the macros as is, or
edit them to customize them for your particular needs.

You get this window by choosing the Window » Macro Library menu.




800 Macro Library

Categories Entries
L] All Entries “:' Activate Window Switcher
. Clipboards ‘g Display Current Mouse Position
B File ‘g Funky Glyphs
. Image ‘@ Menu Glyphs
| Interface Control x Nudge Mouse
. iTunes Control _ Number Pad
. Miscellaneous ‘ga Open Trash
.| Switchers E\ Record Quick Macro
.| System Control D Remap To Forward Delete
L Text k Simulate Scroll Wheel
L Web _ Spotlight Text Insertions
. Windows ‘g Swap Characters

L_é Delayed Click

Use the status menu to click the mouse after a 20 second
dalay. This is useful to give you time to walk to the printer
and insert envelopes or colored paper without making two
trips.

Insert Q-

Each entry represents one or more macros, usually in a single macro group, but occasionally in more than one macro group.
You can learn about them by selecting them, and then you can insert them into your macros by clicking the button or
by dragging them to a particular macro group (dragging is not available if the library entry represents more than one macro

group as you can't drag to two macro groups).

You can add macros to your library by choosing the File » Export as Macro Library menu and selecting the Add to My Mactro

Library checkbox. You can get Macro Library entries from us or from other Keyboard Maestro users and add them to you
library by double clicking them or by choosing the File » Import to Macro Library menu.

Remember to use caution when installing a macro or macro library from anyone — macros can potentially do a lot of damage
and compromise the security of your Mac, so only install macros from trusted sources. When importing macros from a file
they will be imported disabled (either the parent macro group will be disabled, or if it exists already, the macros themselves will
be disabled) unless you hold the Option key down.

Icon Chooser Window

This window contains icons you can use to customize your macro and macro groups. You can click on an icon well in the
macro or macro group editor and then show this window and select or create an icon for it.

You get this window by choosing the Window » Icon Chooser menu.

There are three types of icons available. Internal Keyboard Maestro icons:
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When creating icons, you can reference lots of characters:
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Alternatively, you can copy an image from anywhere and paste it in to the icon well (although Keyboard Maestro stores a small
reference to the Icon Chooser icons, so that is much more efficient that storing the image in your macros as copy & paste will).

Macro Inspector Window

This window shows you information about the selected macro or macro group.

You get this window by choosing the Window » Macro Inspector menu.

Testing ¥4
Testing Group

Created 8 May 2015 12:18
Modified Today 14:55
Last used Today 09:14
Used 578 times
Saved 12 hours

Mouse Display Window

This window shows you the mouse location relative to any corner of the main screen or front window.

You get this window by choosing the Window » Mouse Display menu.

X = L

TE ] — -2086C
- 1 211 ©
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You can click the button and then five seconds later Keyboard Maestro will lock the coordinates. You can click the @
button to copy the values, and you can change the relative corner even while the display is locked.

Value Inspector Window

This window shows you the value of the specified variables, clipboards, calculations or tokens.

You get this window by choosing the Window » Value Inspector menu.

[ ] [ ] Value Inspector

©© ¢ calculation| HOUR() / 3 |
466666667

© © < variable Value
26000.01

©© < Clipboard £ Image

©© < Token Text %WindowName%1%
Keyboard Maestro Editor

The contextual menu (control or right click in the window) will allow you to toggle whether the window is displayed only while
the Keyboard Maestro editor is at the front, or whether the window floats above all applications.

Palette Theme Editor

This window allows you to configure the appearance of the various macro palette.

You can choose a style, the opacity of the palette, the size of the entries, the number of columns, whether the entries include
the icon, the text and/or the trigger, and whether the palette shrinks when the mouse is not over it.

[ ] [ ] Theme Editor
2 Sungroper r—— n
Size: 32 : Columns: ) [

icon B Text | Center Title

O™

Conflict o
Black Swan Sample h
Bluebottle Jellyfish "%
Check Bandicoot
Example Kangaroo
Goanna Instance

Style: Copy Default Revert

Recording Window

This window shows you when Keyboard Maestro is recording your actions.



You get this window by clicking the button in the Macro Editor window or by triggering a Record Quick Macro

action.

Recording

Clicking on this window will stop all recording, or you can pause recording, or add a 0.25 second Pause action to the current
recording. Option-clicking the button (v9.0+) will turn on “real time” recording and Keyboard Maestro will record a
pause between each action to simulate playback at approximately the same speed as the recording,

Macro Debugger

You get this window by choosing the Status Menu » Start Debugging menu by triggering a Debugger Start action.

o B Keyboard Maestro Debugger
| Pause New Macros

X | Calculate

Prompt for User Input ‘Calculate’

Conflict Palette

You get a conflict palette when a Hot Key would trigger two or more actions.

~Q B
ocuments

ownloads
ropbox
ovies
usic
ictures

Note how the distinguisihing characters are highlighted — pressing those keys will select the desired trigger, or filter the list so
that only those macros remain:

~Q B
Open Documents

22 Open Downloads
2 Open Dropbox

this continues until only one macro remains which is immediately executed.

Trigger Macro by Name
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You get this window by executing the Trigger Macro by Name action.

P app - Activate PCalc *f
. Activate Application Launcher ~E-
. Activate Application Switcher Al
.. Activate Last Application g8+
= Activate Next Application NEE -
™ Bring Application Windows to Front et
Hide Front Application N#+
A .
Activate PCalc
‘tgy Paste Selection Into Last Application X{r3C

%, Red Striksthrough Global Macro Group

& Reopen Safari Windows
B Resize Main Window Created Today 2:26 pm
Modified 30 Apr 2013 2:03 pm
Last used Never
‘ta Screen Captures Used Never
Shop Mac Saved None yet

‘i@ Save to Clippings F2

Type a string to filter the macros.
Note that the filtering is not just by macro name.
Application Launcher Window

This window lets you launch applications.

You get this window by triggering the Activate Application Launcher macro.

To learn more about the Application Launcher, see the Application Launcher section.

Application Switcher Window

This window lets you switch between active applications, as well as quit or hide applications or quickly launch frequently used
applications.

You get this window by triggering the Activate Application Switcher macro.

To learn more about the Application Switcher, see the Application Switcher section.
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Window Switcher Window

This window lets you switch between windows in the current application, as well as close or minimize windows.

You get this window by triggering the Activate Window Switcher macro.

Keyboard Maestro

DesKiop
Documents

Downloads

Library,

Movies
Music

windows

To learn more about the Window Switcher, see the Window Switcher section.

Named Clipboard Switcher Window

This window lets you select between named clipboards to Cut, Copy or Paste to/from.

You get this window by triggering one of the Activate Clipboard Switcher macros.

o0 ® ¢ Named Clipboard Switcher

Address -ﬂ-
@ ‘A Stairways Software Pty Ltd

ID#10679

PO Box 16

Nobby Beach QLD 4218

Australia

1 22 August, 14:07 4.5 KB

Contact Us ¥

=7 ‘A Keyboard Maestro Forum
support@stairways.com

Web Site Feedback Form
2 22 August, 14:05 2.3KB
Keyboard Maestro Icon ¥
=/ =

3 22 August, 14:04 1024 « 1024 - 1.2 ME
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Select something and select a named clipboard and click the button or button to cut/copy to a named clipboatd.
Select a named clipboard and click the button button to paste a named clipboard. Click the |+ button to create a new
named clipboard. Select a named clipboard and click the |Quick Look| button to view it. Select a named clipboard and click the
B button to delete it.

Click the [x| button to toggle whether the window should close after an action.
Use the search field to filter the named clipboards.

To learn more about the Clipboard Switcher, see the Named Clipboard Switcher section.

Clipboard History Switcher Window

This window lets you paste from your clipboard history of items that you have previously cut or copied.

You get this window by triggering the Clipboard History Switcher macro.

[ NON ] i4 Clipboard History Switcher
@~ - *xom - of o
s = {}

5:52 1874 » 1064 - 882 KB
x/ ‘A Keyboard Maestro Forum fe3
support @stairways.com

Web Site Feedback Form
2 5:52 2.3KB
s = {}
3 15:52 1024 % 1024 - 682 KB
wf A No0eeeeeeee e
4 15:62 22B

Cut or copy something and it will appear in this list. Select an item and click the button button to paste a named
clipboard. Select an item and click the || button (or press Command-L) to mark it as a favorite, or click the ™/ button (or
press Command-S) to send it to another Mac. Select an item and click the B button to delete it (this is useful if you want to

delete a password or other sensitive information).

To view an item more fully, select it and click the |Quick Look| button (or press Space) to display the Quick Look window.




To send a clipboard to another Mac running Keyboard Maestro, click the || button to display the sending window.

Select the desired local destination, or type a host:port destination to send it to a remote Mac, and click the send button.
Keyboard Maestro will keep trying to send to the Mac even if it can't connect right now, so as long as both Macs are connected
to the Internet eventually, the clipboard should get through. While a clipboard is being sent, it is marked with a progress icon.
If a clipboard is marked to be sent in the future, it is marked with a . Once it has been successfully sent, it is marked with a
. If it fails to be sent, and Keyboard Maestro has given up, it is marked with a m Clipboards that have been received are
marked with a .

Click the [x| button to toggle whether the window should close after an action.
Use the search field to filter the named clipboards.

To learn more about the Clipboard History Switcher, see the Clipboard History Switcher section.

Preferences Window

This window lets you configure Keyboard Maestro.

You get this window by launching Keyboard Maestro and choosing the Keyboard Maestro » Preferences menu.

To learn more about the Preferences, see the Preferences section.

Preferences General Pane

This window pane lets you configure general preferences.
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Preferences Palettes Pane

This window pane lets you configure the default palettes style, as well as the global and conflict palette styles.

You can also configure whether the conflict palette appears under the mouse.

® Preferences: Palettes

Clm @ O X a

General Palettes Web Server Clipboards Variables Excluded

Palette Styles:

Default Palette Style

Global Macro Palette Style

Applications Palette Style

Conflict Palette Style

Place Conflict Palette Under Mouse
Include Conflict Palette in Touch Bar

Preferences Web Server Pane

This window pane lets you configure the built-in web server which enables remote execution of macros.



@ Preferences: Web Server
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General Palettes Web Server Clipboards Variables Excluded

Web Server Enabled Connect

HTTP Port: | 4496 HTTPS port iz one more (4497).

Login with this username and password to
access any macro you have defined.

Public Web triggered macros will be available to
Password: eessess anyene who can connect to your Mac.

Web Browser Access Enabled
i0S Access Enabled (requires username & password)

Receive Clipboards into Clipboard History
Replacing Current Clipboard

Username: peter

‘Web server is enabled for public & authenticated & iOS access and receiving clipboards.

Preferences Clipboards Pane

This window pane lets you add, remove and rename Named Clipboards and see and change their values.

[ ] Preferences: Clipboards

—
e O A
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Nice Comments

Temporary

Preferences Variables Pane

This window pane lets you add and remove variables, and see and change their values.
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Preferences Exclude Pane

This window pane lets you add and remove applications from the global Excluded Applications list.

[ ] Preferences: Excluded
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About Window Pane

This window shows you the version of this copy of Keyboard Maestro, to whom it is registered, and allows you to visit the web

site.

You get this window by launching Keyboard Maestro and choosing the Keyboard Maestro » About Keyboard Maestro menu.




About Keyboard Maestro

 {

Keyboard Maestro

Version 9.0
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Trial Version
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www.keyboardmaestro.com

support@stairways.com

@ Stairways Software Pty Ltd. 2004-2019

Keyboard Maestro App Menus

Below is a complete list of all menus. Note that in some cases you must hold down the Option Key E (or M or Opt|) to
see the menu item. For example, the “Expand All Actions” item in the Actions menu.

Keyboard Maestro

The Keyboard Maestro menu contains menu items relating to the Keyboard Maestro application as a whole.
About Keyboard Maestro

The About Keyboard Maestro command in the Keyboard Maestro menu displays the About Keyboard Maestro window.

Purchase Keyboard Maestro
The Purchase Keyboard Maestro command in the Keyboard Maestro menu lets you purchase Keyboard Maestro online.
Purchase Keyboard Maestro Upgrade

The Purchase Keyboard Maestro Upgrade command in the Keyboard Maestro menu lets you purchase an upgrade to
Keyboatd Maestro online.

Register Keyboard Maestro

The Register Keyboard Maestro command in the Keyboard Maestro menu displays the serial number entry window allowing you to
enter your username (email address) and serial number. Make sutre you enter them exactly as sent to you. If your email address
shows up as “Registered to” in the About Keyboard Maestro box, then you are already registered.

Check For Update

The Check For Update command in the Keyboard Maestro menu checks to see if there are any updates to Keyboard Maestro and
offers to download and install them if there are.

Preferences



The Preferences command in the Keyboard Maestro menu displays the Preferences window.

Services

across multiple applications. You can learn more about Mac QS X Services from your Mac QS X documentation, and you can
install new services which will work with Keyboard Maestro. Keyboard Maestro includes full support for Services, so relevant
Services on your system are available in Keyboard Maestro.

Hide Keyboard Maestro

The Hide Keyboard Maestro command in the Keyboard Maestro menu will hide the Keyboard Maestro application and all its
windows. Click on Keyboard Maestro's Dock icon or choose Show All to show Keyboard Maestro again. Note that generally
you should just quit the Keyboard Maestro editor when you are not modifying your macros.

Hide Others

The Hide Others command in the Keyboard Maestro menu will hide all other applications. Choose Show All to show them again.
Show All

The Show A/l command in the Keyboard Maestro menu will show all hidden applications.

Quit Keyboard Maestro

The Quit Keyboard Maestro command in the Keyboard Maestro menu will Quit Keyboard Maestro. The Keyboard Maestro Engine
will remain running and all enabled Keyboard Maestro features will continue to operate (unless you have specifically quit the
Keyboard Maestro Engine).

File

The File menu is where you import or export Macros or launch or quit the Keyboard Maestro Engine.

New Smart Group

The New Smart Group command in the Frle menu creates and starts editing a new smart group.

New Macro Group

The New Macro Group command in the File menu creates and starts editing a new macro group.

New Macro

The New Macro command in the Fil menu creates and starts editing a new macro.

New Editor Window

The New Editor Window command in the Fi/e menu creates a new editor window. Closing the last editor window will quit the
Keyboard Maestro editor (the Keyboard Maestro Engine will continue operating as usual).

Close
The Close command in the F7/e menu closes the front window.

Close All



The Close All command in the Fi/e menu closes all the windows and quits the Keyboard Maestro editor (the
Keyboard Maestro Engine will continue operating as usual). Hold the Option key down to select this menu item.

Run Macro
The Run Macro command in the File menu runs the currently selected macro.

Share

The Share menu in the File menu lets you share the selected macro group, macro or actions with any appropriate sharing
service on your Mac, including sharing to the forum [https://forum.keyboardmaestro.com]. If you hold the Shift key down before

starting your menu selection you can share just an image of the selection, which will allow you to share to services that only
allow selection of images.

Export Actions

The Export Actions command in the File menu exports the selected actions to a file that you can import later or on another Mac
or send to othets.

Export Macros

The Export Macros command in the Fz/e menu exports the selected macros to a file that you can import on another Mac. This is
one way to transfered macros from one Mac to another or to share macros with friends or colleagues.

Export as Macro Library

The Export as Macro Library command in the File menu exports the selected macros to a library file that you can share with
others. If you create any interesting macros please consider sending them to us and we will make them available on our web
site or in a future version of Keyboard Maestro.

See also the Macro Library section.

Note that you should generally only export as library if you want to import the macros multiple times. Otherwise just exporting
the macros is sufficient.

Export as Trigger File

The Export as Trigger File command in the File menu lets you save a file that will trigger a macro when opened (that is, a file you
can open in the Finder to trigger a macro).

Import Actions

The Import Actions command in the File menu lets you select a saved action file and imports the actions it contains into the

current macro.
Import Macros Safely

The Import Macros Safely command in the File menu lets you select a saved macro file and imports the macros it contains,
disabling them (either disabling created macro groups, or disabling the contained macros as appropriate).

If you do not completely trust the source of the macros, you should import them this way.
Import Macros

The Import Macros command in the Fife menu lets you select a saved macro file and imports the macros it contains. Hold the
Option key down to select this menu item. Macros imported this way could trigger immediately, so use this command only if
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you completely trust the source of the macros.
Import to Macro Library

The Import to Macro Library command in the Fi/e menu lets you import a shared macro library file into your macro library.
Macros in your library are not active, but can be added into one or more macro groups to become active.

See also the Macro Library section.

Revert Macros

The Revert Macros menu in the Fi/e menu lets you revert to a previous version of your macros. If you find you have really
messed up your macros, you can restore your macros to a backup version of how they were when you first launched Keyboard
Maestro, or how they were yesterday or even several days ago.

Start Syncing Macros

The Start Syncing Macros command in the File menu lets you start syncing your macros with another Mac.

See also the Macro Syncing section.
Reveal Macro Sync File

The Reveal Macro Syne File command in the Fi/e menu lets you see where your macro sync file is.

See also the Macro Syncing section.

Stop Syncing Macros

The Stop Syncing Macros command in the Fi/e menu lets you stop syncing your macros.

See also the Macro Syncing section.
Launch Engine

The Launch Engine command in the Fi/e menu lets you start the Keyboard Maestro Engine manually. The

Keyboard Maestro Engine performs all the Macro, Application Switcher, Window Switcher and Clipboard Switcher functions
even while Keyboard Maestro itself is not running; It is launched automatically as a Startup Item when you login (assuming you
have enabled that in the Preferences window) or any time you launch Keyboard Maestro. If it is not running for any reason you

can start it manually with this command. This menu item only exists while the Keyboard Maestro Engine is not running,
Quit Engine

The Quit Engine command in the Fi/e menu lets you quit the Keyboard Maestro Engine. The Keyboard Maestro Engine
performs all the Macro, Application Switcher, Window Switcher and Clipboard Switcher functions even while

Keyboard Maestro itself is not running. It is launched automatically as a Startup Item when you login (assuming you have
enabled that in the Preferences window). If you quit the Keyboard Maestro Engine these functions will no longer operate. This

menu item only exists while the Keyboard Maestro Engine is running.
Edit

The Edit menu contains menu items relating to text and selections.
Undo

The Undo command in the Ediz menu undoes the previous command.



Redo

The Redo command in the Edit menu redoes the previous undone command.

Cut

The Cut command in the Edif menu copies the current selection to the system clipboard and then deletes the selection.
Copy

The Copy command in the Edif menu copies the current selection to the system clipboard.

Copy as

The Copy as sub-menu in the Edif menu menu allows you to copy the selection in a variety of formats.

Copy as Text

The Copy as Text command in the Cgpy as sub-menu in the Edit menu menu allows you to copy the selected macro or actions as
styled text.

Copy as Image

The Copy as Image command in the Cogpy as sub-menu in the Edir menu menu allows you to copy the selected macro or actions
as an image.

Copy as XML

The Copy as XML command in the Copy as sub-menu in the Edit menu menu allows you to copy the selected macro or actions
as XML.

Copy UUID

The Copy UUID command in the Copy as sub-menu in the Edi menu menu allows you to copy the selected macro or macro
group’s UUID (Universally Unique ID).

Paste

The Paste command in the Edif menu pastes the current system clipboard into the current selection.

Delete

The Delete command in the Edif menu deletes the current selection.

Select All

The Select A/l command in the Edif menu selects all text or items.

Deselect All

The Deselect A/l command in the Edif menu deselects all text or items. Hold the Option key down to select this menu item.
Duplicate

The Duplicate command in the Edit menu duplicates the selected items.



Make Alias

The Make Alias command in the Edit menu makes an alias to the selected macros. It creates a new macro that just executes the

original macro.

You may also use EL ot Drag/Drop with ﬂl to another Macro Group.

Insert Action

The Insert Action command in the Edit menu lets you insert any of the many actions available in Keyboard Maestro.
Insert Action by Name

The By Name command in the Edit » Insert Action menu lets you insert any of the many actions available in Keyboard Maestro

by name.
Insert Function

The Insert Function sub-menu in the Edit menu lets you insert any of the many functions available in Keyboard Maestro. The

functions will be inserted, together with an example of any parameters it takes.

Most numeric fields in Keyboard Maestro can process an expression containing these functions. These fields are indicated
either by having up/down steppets, or a |C|in the field while editing;

Insert Function by Name

The By Name command in the Edit » Insert Function menu lets you insert any of the many functions available in

Keyboard Maestro by name.
Insert Token

The Insert Token sub-menu in the Edif menu lets you insert any of the many Tokens available in Keyboard Maestro. The token

will be inserted, together with an example format of any parameters it takes.

Most text fields in Keyboard Maestro can process Tokens. These fields are indicated by having a | T|in the field while editing.
Insert Token by Name

The By Name command in the Edit » Insert Token menu lets you insert any of the many tokens available in Keyboard Maestro
by name.

Insert Variable

The Insert Variable command in the Edit menu lets you insert any of your variables.

Insert Variable by Name

The By Name command in the Edit » Insert 1V ariable menu lets you insert any of your variables by name.
Automatic Completions

The Automatic Completions command in the Edit menu lets you toggle automatic text completion. When off, you can still
complete variables, tokes, and functions by pressing F5.

View



The Iiew menu contains menu items relating to display and actions.

Sort Macros by Name

The Name command in the Iiew » Sort Macros by menu sorts the macros in the main window by name.
Sort Macros by Trigger

The Trigger command in the 17w » Sort Macros by menu sorts the macros in the main window by trigger. This is useful to see
what hot keys are available, or to group all Typed String triggers together.

Sort Macros by Date Created

The Date Created command in the 17ew » Sort Macros by menu sorts the macros in the main window by the date created.

Sort Macros by Date Modified

The Date Modified command in the 17ew » Sort Macros by menu sorts the macros in the main window by the date modified
(most recently modified at the top). This is useful to see what macros you have recently modified. You can also use the
button at the top of the macro editor to show the recently modified macros.

Sort Macros by Date Used

The Date Used command in the Iiew » Sort Macros by menu sorts the macros in the main window by date used (most recently
executed at the top). This is useful to see what macros you have recently executed, especially if you think one might have been
executed inadvertently. You can also use the button at the top of the macro editor to show the recently used macros.

Sort Macros by Use Count

The Use Count command in the 17ew » Sort Macros by menu sorts the macros in the main window by use count (most used
macros at the top).

Sort Macros by Time Saved

The Time Saved command in the * View » Sort Macros by* menu sorts the macros in the main window by time saved (most
time saved at the top).

Disabled to Bottom

The Disabled to Bottoms command in the Iiew X Sort Macros by menu sorts the disabled mactos to the bottom of the macro list.
Select Groups Column

The Select Groups Column command in the IZew menu focuses on the Macro Groups column.

Select Macros Column

The Select Group Column command in the [7ew menu focuses on the Macros column.

Select Macro

The Select Macro menu in the 1zew menu lets you select a recently edited or used macro.

Select Macro by Name



The By Name menu in the 17ew » Select Macro menu lets you select a macro by name.

Select Macro Last Used

The Last Used menu in the Vew P> Select Macro menu lets you select the most recently triggered macro.
Select Macro Last Edited

The Last Edited menu in the [ew > Select Macro menu lets you select the most recently edited mactro.
Select Macro Previous Edited

The Previons Edited menu in the VView > Select Macro menu lets you select the previous edited macro (edited macros form a list,
and this moves backward along the list).

Select Macro Next Edited

The Next Edited menu in the [7ew » Select Macro menu lets you select the next edited macro (edited macros form a list, and this
moves forward along the list).

Reveal Parent Group

The Reveal Parent Group command in the 77w menu selects the parent macro group of the currently selected macros. If you are
editing a macro and the parent macro group is not the only selected macro group, then the parent macro groups’s name is
shown in the top right corner of the window. Clicking on this name will also reveal the parent macro group.

Show Disabled Macro Groups

The Show Disabled Macro Groups command in the [7ew menu shows all macro groups (enabled or disabled) in the Macro
Groups column. You can hide all the disabled Macro Groups with the Hide Disabled Macro Groups command.

Hide Disabled Macro Groups

The Hide Disabled Macro Groups command in the [Zew menu hides all disabled macro groups in the Macro Groups column.
Instead, a single placeholder group is shown that “contains” all the disabled Macro Groups. You can double click the Disabled
Macro Groups placeholder to temporarily reveal the disabled macro groups. You can show all the disabled Macro Groups with
the Show Disabled Macro Groups command.

Enable

The Enable command in the [Zew menu enables Macro Groups, Macros or Actions as appropriate.

Disable

The Disable command in the 17w menu disables Macro Groups, Macros or Actions as approptiate.

Start Editing Macros

The Start Editing Macros command in the 7ew menu turns on edit mode. Edit mode allows you to modify macros and macro
groups. You may prefer to leave it on permanently, or you may like to turn it off when you are not making changes to give a
more concise and visually appealing view of the macros and macro groups.

Stop Editing Macros

The Stop Editing Macros command in the 7ew menu turns off edit mode.



Rename
The Rename command in the 17ew menu edits the name of the currently selected Macro Group or Macro.

Record

The Record command in the 7ew menu toggles recording on and off. It is available while editing a macro. Hold the option key
down to record without a delay.

Record Without Delay

The Record Without Delay command in the I7ew menu toggles recording on and off immediately (without the normal short
countdown). It is available while editing a macro. Hold the shift key down to select the menu.

Enter Full Screen
The Enter Full Screen command in the 7ew menu will expand the window to full screen.
Actions

The Actions menu contains menu items relating to actions. These items have analogs in the action gear @ | menu and

contextual menu for actions, and some menu items appear only in the appropriate menu.

Show Actions

The Show Actions command in the Actions menu shows the action list. It is available while editing a macro. Double click or drag
actions from the action list to add them to your macro. This menu toggles to Hide Actions when the action list is already
showing. You alternatively also choose Insert Action by Name from the Edit menu to insert actions by name or use the Insert
Action menu in the Edif to select actions.

Try

The Try command in the Actions menu tries the selected actions. It is available while editing a macro.

Enable

The Enable command in the Aezions menu enables actions.

Disable

The Disable command in the Actions menu disables actions.

Rename

The Rename command in the Actions menu renames actions.

Set Color

The Set Color menu in the Actions menu sets the color of actions.

Note: A blue striped color is reserved to mark the action as a match for the current search.
Set Note

The Set Note command in the _Actions menu sets the notes of actions.



Paste Above

The Paste Above command in the Actions menu pastes previously copied actions above the selected actions.
Paste Below

The Paste Below command in the Aczions menu pastes previously copied actions below the selected actions.

Paste Replacing

The Paste Replacing command in the Actions menu pastes previously copied actions, replacing the selected actions.
Duplicate

The Duplicate command in the the Actions menu duplicates the selected actions.

Engroup

The Engroup menu in the Actions lets you enclose the selected actions within a container action such as a Group, Repeat, If Then
E/se or other control flow action. You can also turn the selected macros into a sub-macro.

Degroup

The Degroup command in the Actions removes the selected actions from their parent container action, and removes the
container action if it is now empty.

Set Action Timeout

The Set Action Tinmeont command in the Actions menu sets the timeout for the selected action.

Timeout Aborts Macro

The Tineont Aborts Macro command in the Actions menu controls whether the macro is aborted if the action is timed out.
Notify on Timeout

The Notify on Timeont command in the Actions menu controls whether you are notified if the action is timed out.
Failure Aborts Macro

The Failure Aborts Macro command in the Actions menu controls whether the macro is aborted if the action fails.
Notify on Failure

The Notify on Failure command in the Actions menu controls whether you are notified if the action fails.
Expand Action

The Expand Action command in the [7ew menu expands (discloses) the selected actions. Hold the option key down to expand
all actions in a given sublist.

Expand All Actions

The Expand All Actions command in the I7ew menu expands (discloses) the selected actions and all other actions in the same
sublist. Hold the option key down to select this command.



Collapse Action

The Collapse Action command in the 17ew menu collapses the selected actions. Hold the option key down to collapse all actions
in a given sublist.

Collapse All Actions

The Collapse All Actions command in the ["Zew menu collapses the selected actions and all other actions in the same sublist.
Hold the option key down to select this command.

Parent Action

The Parent Action command in the 7ew menu moves the selection to the containing action.
Enter Action

The Enter Action command in the Zew menu moves the selection to the contained action.
Help

The Help command in the 17ew menu displays the wiki help for the selected action.
Window

The Window menu contains menu items relating to windows.

Minimize

The Minimize command in the Window menu minimizes the front window.

Zoom

The Zoom command in the Window menu zooms the front window.

Keyboard Maestro Editor

The Keyboard Maestro Editor command in the Window menu brings the frontmost Keyboard Maestro macro editing window to
the front.

Macro Library

The Macro Library command in the Window menu shows or hides the macro library.

See also the Macro Library section.
Icon Chooser

The Icon Chooser command in the Window menu shows or hides the Icon Chooser.

See also the Icon Chooser section.

Macro Inspector

The Macro Inspector command in the Window menu shows or hides the Macro Inspector.

See also the Macro Inspector Window section.




Mouse Display

The Mouse Display command in the Window menu shows or hides the Mouse Display, which shows the mouse location in real

time.

See also the Mouse Display Window section.

Value Inspector

The Value Inspector command in the Window menu shows or hides the Value Inspector, which shows values of variables, tokens,
calculations, or clipboards that you can select.

See also the Value Inspector Window section.

Bring All to Front

The Bring All to Front command in the Window menu brings all Keyboard Maestro windows to the front.

Help

The He/p menu contains menu items relating to Help. You can also use the search field in this menu to find help on the wiki.
Interactive Help

The Interactive Help command in the Help menu starts the in-application assistance system. If you're having trouble with
something not working the way you expect, this system may help you find out where the problem is, or offer suggestions for
other sources os assistance.

Keyboard Maestro User Manual

The Keyboard Maestro User Mannal command in the Help menu displays the Keyboard Maestro user manual on the Keyboard
Maestro Wiki.

Keyboard Maestro Quick Start

The Keyboard Maestro Quick Start command in the He/lp menu displays the Keyboard Maestro quick start help web page, which
quickly gets you up to speed in using Keyboard Maestro.

Welcome to Keyboard Maestro

The Welcome to Keyboard Maestro command in the Help menu displays the Welcome message, giving you a quick overview of what
support resources are available for helping you get started using Keyboard Maestro.

Keyboard Maestro Web Site

The Keyboard Maestro Web Site command in the Help menu takes you to the Keyboard Maestro web site.
Keyboard Maestro Wiki

The Keyboard Maestro Wiki command in the He/p menu takes you to the Keyboard Maestro wiki.
Keyboard Maestro Forum

The Keyboard Maestro Forum command in the He/p menu takes you to the Keyboard Maestro forum.

Stairways Software Web Site



The Stairways Software Web Site command in the Help menu takes you to the Stairways Software web site.

Tutorial

The Tutorial command in the He/lp menu starts the in-application tutorial. The tutorial will walk you through creating a simple
macro. By varying the actions slightly, you can create a variety of macros that are triggered by hot keys and that open various
documents.

Practice Gestures

The Practice Gestures command in the Help menu starts the gesture system and lets you practice gestures, to ensure you can
reliably trigger Gesture triggered macros.

ICU Date Format References

The ICU Date Format References command in the He/p menu takes you to the ICU Date Format References web site.

ICU Regular Expression References

The ICU Regular Expression References command in the He/p menu takes you to the ICU Regular Expression References web site.
Regular Expression Unicode Properties

The Regular Expression Unicode Properties command in the He/p menu takes you to the Regular Expression Unicode Properties
web site.

Third Party Licenses

The Third Party Licenses command in the He/p menu displays the licenses folder containing the third party licenses for code used
in Keyboard Maestro.

Open Logs Folder

The Open Logs Folder command in the Help menu displays the Keyboard Maestro Logs folder.

Open Preferences Folder

The Open Preferences Folder command in the He/p menu displays the Keyboard Maestro Preferences folder.
Report Bugs or Feature Requests

The Report Bugs or Featnre Requests command in the He/p menu allows you to report any bugs you find or and features you would
like implemented (hat tip to the wonderful image editor, Acorn [https://www.stairways.com/action/linkthruPacorn]).

Service and Support

The Service and Support command in the Help menu displays the service and support details, including how to contact us and
where you can get more assistance.

Status Menu

The Status Menn menu appears on the right side of the menu bar showing (by default) the Keyboard Maestro icon (although
you can control the icon in the General preference pane). It is generally visible any time the Keyboard Maestro Engine is

running (unless you turn it off in the General preference pane). You use it to control the Keyboard Maestro Engine, to execute

your Status Menu triggered macros, and to switch to applications.
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Launch Keyboard Maestro Editor

The Launch Keyboard Maestro Editor command in the Status Menn menu launches Keyboard Maestro so you can edit your macros.
You can also edit your macros directly by holding down the option key while choosing them in the Status Menu menu or in a
palette.

Paste

The Paste menu in the S7atus Menn menu includes the recent text items in the clipboard history so you can easily paste in past

items using this menu.

Hold the Shift key down to paste as plain text, and the Option key down to just set the clipboard without pasting.
Activate Clipboard History Switcher

The Activate Clipboard History Switcher command in the Status Menu » Paste menu lets you activate the Clipboard History

Switchert.

Your Macros

Your macros that include the Status Menu Trigger and that are currently active will be listed in this menu. You can select them

to trigger them.

This is great for less frequently used macros that you will not remember a hot key or other trigger, as well as for macros that
feel like they should be menu commands, such as actions that perform a complicated task.

Show Applications Palette

Toggles the display of the Applications Palette.

Recent

The Recent menu in the Status Menu menu contains a list of all recently quit applications.
Running

The Running menu in the Status Menu menu contains a list of all running applications.
Applications

The Applications menu in the Status Menu menu contains a list of all applications.
Utilities

The Ulilities menu in the Status Menu menu contains a list of all utility applications.
Cancel

The Cancel command in the Szatus Menn menu contains a list of all currently running macros and allows you to cancel them.

You can also cancel all currently running macros by holding all the modifiers (Command, Control, Option, Shift) down and
clicking on the S7atus Menu menu.

Start Debugging

The Start Debugging command in the Status Menn menu opens the macrodebugger window and starts debugging.



https://wiki.keyboardmaestro.com:8443/trigger/Status_Menu

See also the Macro Debugger section.

Quit Keyboard Maestro Engine

The Quit Keyboard Maestro Engine command in the Status Menn menu quits the Keyboard Maestro Engine.
Tips

Remembering Macro Hot Keys

Hot Key triggers are only useful if you can remember which key does what.

Consider using mnemonic keys. For example, in your email client, you might define a set of Macros to Insert Text action, so

use Control-A for your Address, Control-S for your Signature, Control-N for your Name, and so on.

Be consistent in your choice of Hot Keys. For example, use function keys to launch applications, Control-Function Keys to

open documents, Control-Letter to insert text, and so on.

Consider using a single hot key for a set of related functionality. Keyboard Maestro will display a conflict palette and let you
select from the choices.

Keyboard Maestro also interoperates with KeyCue — if you use both applications and hold the control key down KeyCue will
display all your active Hot Keys.

Use the Conflict Palette

If you have two or more macros with the same Hot Key, pressing that key will display the conflict palette, listing all the
conflicting macros. You can then press further keys to filter the list until one remains which is then immediately executed.

Use the Trigger Macro by Name Action

Another way to reduce having to remember Hot Keys is to use the Trigger Macro by Name action to trigger macros based on
their name.

Use the Insert Menus

In the editor, there are menus in the Edit menu to inserting actions, functions and text tokens and variables. These can be very

useful for both learning about what is available and quickly inserting elements. You can also use text completions to insert
functions in numeric fields and tokens and text token fields.

If you hold down the Option key while selecting from these menus you can get help on any of the actions, functions or tokens.

There are also By Name versions to quickly insert actions, functions, tokens or variables by name.
Pay Attention to the Gear Icon

The gear @ menu in the top right of the menu shows you a variety of different things depending on exactly how it looks.

If the action has a timeout, then a clock face will appear in the middle of the gear. If the timeout has been left as the default,
the time will be three o'clock, otherwise the time will be an impossible 4.5 o'clock.

If the action has extra configuration options, the gear menu will have a blue center.
The gear menu itself also shows you whether the item has notes, and whether it will abort or notify you if the action fails.

And finally, the gear menu includes a Help command which will take you to the wiki help on the action.

Use Function Keys for Global Hot Keys
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It is quite hard to come up with global Hot Keys that will not conflict with those keys used by any application (a conflict is not
really a problem, the Macro Hot Key will simply override the application, but this is not always desirable). It is best to use
function keys, especially in conjunction with modifiers, as global Hot Keys since they tend not to be used by most applications.

Use the Number Pad
Remember that the number pad is available (and distinct from the numbers on the main keyboard).

Troubleshooting

See the wiki Troubleshooting page for how to resolve any problems we have anticipated.

Mojave

If you have upgraded to Mojave (or later), and are having problems, start by toggling the Accessibility permissions off and on
for Keyboard Maestro and Keyboard Maestro Engine. A bug in the Mojave upgrade process results in the Accessibility
permissions appearing to be on, but not actually being on which leads to failures and confusion.

In-built Assistance

If you are finding a macro is not firing when you expect it to, or something weird is happening when you don't expect it to, or
choose Help » Interactive Help menu) to bring up an interactive assistance system which might help you narrow down the

problem.
How do I get more help?

For more information about a specific Keyboard Maestro feature consult the Keyboard Maestro User Manual, post a question

to the Keyboard Maestro Forum [https://forum keyboardmaestro.com/], visit the Keyboard Maestro

[https:/ /www.keyboardmaestro.com/] web site or the Keyboard Maestro Wiki or contact us [https://contact.stairways.com/].

Generally the best place to ask about specific macros is the forum [https://forum.keyboardmaestro.com/] since there are many

helpful people there and so you will get more varied and quicker answers.

While we are happy to help you learn how to use Keyboard Maestro, we cannot generally help with writing specific macros -
use the forum for that.

We always respond to email, however email is no longer a guaranteed medium and spam filters can delete your message to us
or our message to you. Messages sent using the feedback form will always get to us, emails sent to us will pretty much always
get to us, but if you do not receive a response within one business day check your spam filters to see if they have trapped our
reply. If you use the feedback form and want a reply, make sure you enter your email address!

Support

For sales enquiries, customer setvice, technical suppott, ot to contact project management, email us at support@stairways.com

[mailto:support@stairways.com| or use our Web Site Feedback Form [https:/ /www.stairways.com/form/feedback].

Extensive online documentation on Keyboard Maestro can be found in the Keyboard Maestro User Manual and on the wiki at
Keyboard Maestro Wiki.

You can join the Keyboard Maestro Forum [https://forum.keyboardmaestro.com/] online community consisting of the developers

and Keyboard Maestro users — this is the best place to get help with specific macros.

For ideas, see the Macro Examples section, or the Macro Library section of the Keyboard Maestro Wiki.

You can download Keyboard Maestro from https://download.stairways.com/ |https://download.stairways.com/]. You can

download old vetsions of our applications from the archive site at https://files.stairways.com/ [https://files.stairways.com/].
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You can purchase Keyboard Maestro at https://putchase.staitways.com/ [https://purchase.stairways.com/].

You can look up your current or previous license status and serial numbers, and get information about discounted upgrades

from https://enquiry.stairways.com/ [https://enquiry.stairways.com/].

For more information about anything to do with Keyboard Maestro visit https://www.keyboardmaestro.com/

[https:/ /www.keyboardmaestro.com/].

Glossary

Collection An ordered sequence of strings that you can iterate through using the For Each action

Clipboard The system clipboard is where you store items when you Copy and Paste. When you Copy an
item, it is temporarily stored in the Clipboard and when you Paste, the item is copied from the
Clipboard into your currently selection

Clipboard History Normally the system stores only one clipboard. Keyboard Maestro keeps a history of your
system clipboard, ensuring you never lose data on the clipboard and allowing you to copy and
paste multiple items,

Clipboard Switcher is a feature of Keyboard Maestro that allows you to copy or paste to/from a set of

Named Clipboards

Conflict Palette

is a palette that lets you disambiguate your selection when a macro trigger triggers multiple

macros simultaneously

Excluded Applications

is the set of applications that should not appear in the Application Switcher list, allowing you to
hide applications you rarely want to switch to. These applications are also ignored when hiding
other applications

Global Macro Group

a predefined Macro Group that always exists and is the default location for new Macros

GUID

see UUID

Hot Key

A keystroke that acts as a Macro Trigger to start the execution of Macro Actions in a Macro

KeyCue

software from ergonis that displays command keys and can also display Keyboard Maestro
Hot Keys (more info [https://www.stairways.com/action/linkthrurkeycuel)

Keyboard Maestro Engine

The process that enables your Macros, Application Switcher, Window Switcher, Named

Clipboard Switcher and web server to work even after you quit Keyboard Maestro

Mac QS X see OS X
Mac QS see QS X
Macro Macros are used to automate your workflow, procedure, or process on your Mac. A Macro

Macro Action

an action you wish to perform, such as opening a file, typing some text, controlling Safari, and so

on

Macro Group

a set of Macros which can be restricted to only a defined set of applications

Macro Palette

a floating palette containing any active Macros that have a Macro Palette trigger. The palette only
appears in applications with at least once active Macro Palette triggered Macro

Macro Trigger an event, such as a Hot Key, application launch, time of day, that starts the execution of a Macro
Michael Kamprath the original developer of Application Switcher and Keyboard Maestro
Named Clipboard Keyboard Maestro provides a set of named clipboards where you can permanently store

information (text, logos, graphics, etc)

Notification Center

Mac QS X Mountain Lion introduced a system wide notification center which shows you alerts
in the uppet-right corner of your screen, without interrupting what you're doing

Apple’s Macintosh operating system versions 10.0 and up
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Palette a floating window containing macros that you can trigger. There are several different kinds of
palettes and you can style them in various ways

Program Switcher the premier application management utility for Classic Mac QS, written by Michael Kamprath it
was in part the inspiration for Keyboard Maestro and forms one of the components of
Keyboard Maestro

Quick Macro a macro recorded on the fly in another application. see the Recording section

Record Quick Macro the action that when triggered records a Quick Macro. see the Recording section

Regular Expression aka RegEx, a way of matching strings based on patterns. When Keyboard Maestro refers to

“matching” it means by regular expression, in particular ICU Regular Expressions

[https:/ /www.stairways.com/action/linkthruricuregex|

Sandboxed an Apple technology that limits what an application can do and how it can interface with the rest
of the system and other applications. This is great for security for applications that work with
just their own data, but is impossible with workflow applications like Keyboard Maestro

Shortcut a Shortcut is another name for a Macro (it is also another name for an Alias but that is a different
context to the normal Keyboard Maestro Macro context)

Smart Group a saved search set of Macros

Sorting Characters You can control the sorting order of macros by prefixing two characters and a closing
patrenthesis to the name, eg “01)My Macro”. The prefix will be removed before displaying in the
macro palette or status menu, but will be used to control the order of the macros shown.

Status Menu the icon menus at the right of your menu bar
Text Tokens See Tokens
Tokens tokens allow you to insert dynamic text, such as the current date or time, into various text fields,

see the Tokens section

Tokenized see Tokens
Toolbar see Palette
UID see UUID
UUID a Universally Unique IDentifier for Macros and Macro Groups and other purposes that remains

the same even if you rename or modify a macro or macro group, or import a Macro built on

another Mac. Also known as a GUID [https:/ /en.wikipedia.org/wiki/Globally_unique_identifier].

Z-order refers to the order of windows from frontmost to furthest back

Administrative Details

Requirements
Keyboard Maestro 9 requires QS X 10.11 or later.
Distribution

You may distribute this application in any way you wish as long as you only distribute the unmodified Keyboard Maestro
package, as downloaded from www.stairways.com [http:/ /www.stairways.com]. You may not break Keyboard Maestro up into its

component files and distribute parts of it separately.

History

Stairways Software.
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Development continued on version 1 through the end of 2002, and then work began on version 2. The first beta of 2.0 was
released in early 2003 and development continued until the 2.0b6 beta released in May 2003. After that, life and work got in the
way. Keyboard Maestro languished for over a year as Michael found that he did not have the time or energy to continue
development.

Around May 2004, we contacted Michael as a concerned user to query the long delay in the eagerly awaited 2.0 release. When
we learned that Michael was considering abandoning the application we offered to purchase it from him to ensure that we
would not lose this valuable tool, as well as to continue the fine tradition that he had started.

On June 30, 2004 the deal was struck and Stairways Software acquired all the rights to Keyboard Maestro. Our aim was to
resolve the outstanding issues with Keyboard Maestro and release 2.0 as soon as possible, which we did in September 2004.
Keyboard Maestro 2 introduced many new Macro Triggers (such as Application, Time of Day, and so on), Macro Groups to

allow easy control over when macros are active, and many new actions.

Development of Keyboard Maestro competed for resources with development of Interarchy until the latter was sold to lead
developer Matthew Drayton in early 2007. After a short break, development on Keyboard Maestro 3 started in earnest and
resulted in many new features, including improved and streamlined user interface, recording, new triggers, built-in web server,
new actions, and numerous minor enhancements. Keyboard Maestro 3 was released in April 2008 followed by a succession of
releases over the rest of 2008.

Development of Keyboard Maestro 4 began in late 2008 and was released in late 2009. Version 4 was a complete rewrite of the
user interface, bringing with it a modern look and feel reminiscent of various modern Apple applications. Further minor
releases were made through 2010, followed by the initial release of Keyboard Maestro’s baby brother Switcher Maestro and the
Mac App Store version in January 2011.

By that point, development of Keyboard Maestro 5 was well under way and was released in July 2011. Keyboard Maestro 5
built on the solid user interface of version 4, but added depth and breadth of power with almost no addition of complexity.
Keyboard Maestro added such powerful features as control flow, conditions, variables, and calculations as well as many new
actions, and enhancements to the application and clipboard history switchers. Further minor releases were made over the next
year, adding things like a For Each action, File actions and Image actions.

Development of Keyboard Maestro 6 began in mid 2012 and was released in May 2013. Version 6 kept the user interface
largely unchanged, while adding significant new features, including macro syncing, macro debugging, plug in actions, full
support for styled text, support for controlling Safari and Google Chrome web browsers, trigger by name facility.
Keyboard Maestro 6 also sported a stylish new icon from Iconaholic [https:/ /www.stairways.com/action/linkthruriconaholic] as

well as customizable status menu icons and full Retina graphic support. It was followed by a succession of releases throughout
2013 and 2014.

Development of Keyboard Maestro 7 began in late 2014 was was released in July 2015. Version 7 concentrated on streamlining
the editor, adding things like Smart Groups, auto-completion, Insert Action by name and menu, disclosure folding for sub-
action lists, renaming, coloring, and adding notes to actions and more. Version 7 also added themed palettes, and the usual
plethora of new actions and triggers. Macro Groups could now be targeted at specific windows, and macros could be triggered
by window, folder or clipboard changes. It was followed by a succession of releases throughout 2016.

Development of Keyboard Maestro 8 began in late 2016. Version 8 concentrated on further refinements to the editor,
including AppleScript support, in-built assistance, variable text sizes, machine learning, dragging, Touch Bar support, expansion
of various action menus and more. Also new is enhanced MIDI suppott, Local/Instance vatiables, Dictionaries, Gestute, Cron
and Remote triggers, and a bunch of new actions, conditions, collections and tokens.

Development of Keyboard Maestro 9 began in mid 2018. Version 9 concentrated on adding Dark Mode support across all of
Keyboard Maestro, multiple editor windows to the editor, OCR support, wide ranging JSON support, and extending support
for regular expressions. Version 9 also brings support for Stream Deck, and has a hardened runtime and is notorized for
additional security. There is also a plethora of new actions and lots of refinements.

Going forward, we plan to develop Keyboard Maestro aggressively, bringing it to new levels of both power and ease of use in
the long tradition of both S X and Stairways Software.
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Thanks to Dan Benjamin for doing the voice overs on the tutorial videos.
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¢ John Gruber [https://daringfireball.net/], Aristotle Pagaltzis [http://plasmasturm.org/] for Title Case.

¢ Kelan Champagne [http://kelan.io/] for the YRKSpinningProgressIndicator

[http:/ /kelan.io /2009 /yrkspinningprogressindicators/].

e Matt Gemmell [https://mattgemmell.com/] — Magic Aubergine for MGAnimatedView and MGTemplateEngine.
¢ Michael Ash [https://www.mikeash.com/] for MAKVONotificationCenter.

e Matthew Ball for MBCoverFlow [https://github.com/mattball/MBCoverFlowView].

¢ Rainer Brockerhoff [https://wwwbrockerhoff.net/] for RBSplitView [https:/ /brockerhoff.net/src/rbs.html].
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¢ Brian D K Jones for VDKQueue.
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* Flying Meat [https://flyingmeat.com] for FMDB.

¢ Random Ideas for NSTimer+Blocks.

e For OpenCV [https://opencv.org/].

Thanks to Ken, Corentin, Stephen, Brad and others for their great assistance with beta testing.
Thanks to Jim Underwood for outstanding assistance on the forum and wiki.
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Thanks to Andy for great help editing this documentation.
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Warranty

This application should do what we have described in this document. If it does not, you can simply stop using it. If you
purchase it, and within 30 days find that it does not do what we have desctibed here, then you can request a refund and your
money will be refunded and we will cancel your license.

Licenses

Keyboard Maestro is copyright 2019 Stairways Software Pty Ltd. All Rights Reserved. You may use this application for a short
trial period and then you must purchase the application or stop using it.

Keyboard Maestro is licensed on a per user basis and individual users may use it on up to five Macs. You must purchase a
license for each user using Keyboard Maestro.

license is granted for their use.
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Fine Print

Keyboard Maestro, keyboardmaestro.com and stairways.com are the property of Stairways Software Pty Ltd. Macros can be
dangerous if misused, either accidentally or maliciously, especially if you install a third-party macro. You are entirely responsible
for the consequences of any macro execution, no matter what its source, even if it was included with Keyboard Maestro or
comes from any Stairways Software web site including the wiki and forum. Stairways Software Pty Ltd hereby disclaims all
warranties relating to this software, whether express or implied, including without limitation any implied warranties of
merchantability or fitness for a particular purpose. Stairways Software Pty Ltd will not be liable for any special, incidental,
consequential, indirect or similar damages due to loss of data or any other reason, even if Stairways Software Pty Ltd or an
agent of theirs has been advised of the possibility of such damages. In no event shall Stairways Software Pty Ltd be liable for
any damages, regardless of the form of the claim. The person using the software bears all risk as to the quality and
performance of the software.

To be entirely clear, this software is provided “AS IS”. You waive the implied warranty of infringement. Stairways Softwate's
liability to you for costs, damages, or other losses arising from your use of the software - including third-party claims against
you - is limited to a refund of your license fee. Stairways Software may not be held liable for any consequential damages related
to your use of the software.

Stairways Software can terminate your license by refunding your license fee.
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